summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-07-12 19:45:16 +0200
committerhaawda2020-07-12 19:45:16 +0200
commit03a484ea23306d0f0ad74dcd3a81a44f61da9da4 (patch)
tree1b2b362ca06b8fb3349113310f6100694522e7ad
parenta14f4cd0e9c87eda0deda747d24200ed2daa31ea (diff)
downloadaur-bibcure.tar.gz
avoid python2 dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 313e98d21c88..798a56824c30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = bibcure
pkgdesc = Helps you to have a better bibtex file
pkgver = 0.3.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/bibcure/bibcure
arch = any
license = AGPL3
- depends = python2-bibtexparser
- depends = python2-future
+ depends = python-bibtexparser
+ depends = python-future
depends = doi2bib
depends = title2bib
depends = arxivcheck
diff --git a/PKGBUILD b/PKGBUILD
index b3dbbcc25bd6..9f1ebb429ff7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
pkgname=bibcure
pkgver=0.3.0
-pkgrel=3
+pkgrel=4
pkgdesc="Helps you to have a better bibtex file"
url="https://github.com/bibcure/bibcure"
arch=('any')
license=('AGPL3')
-depends=('python2-bibtexparser' 'python2-future' 'doi2bib' 'title2bib' 'arxivcheck')
+depends=('python-bibtexparser' 'python-future' 'doi2bib' 'title2bib' 'arxivcheck')
source=("$pkgname-$pkgver.tar.gz::https://github.com/bibcure/bibcure/archive/$pkgver.tar.gz")
sha256sums=('b87a89ea2c1f7b414c41aba9f382da14cc2dfeb2a5b8c92e04625c745080bd81')
package() {
cd $pkgname-$pkgver
- python2 setup.py install --root="$pkgdir"/ --optimize=1
+ python setup.py install --root="$pkgdir"/ --optimize=1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}