summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsardach2019-09-02 13:43:35 -0500
committersardach2019-09-02 13:43:35 -0500
commit7aa9fc9b139a6e4fa6486709f06e8e3846dc7554 (patch)
treee8cac04c59d9e8b9bc53bc732d1e53a9afbec6fd
downloadaur-bibisco.tar.gz
PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2abd157d998d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bibisco
+ pkgdesc = Novel writing software. Community Edition.
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://www.bibisco.com/
+ arch = x86_64
+ license = GPL3
+ depends = npm
+ source = git+https://github.com/andreafeccomandi/bibisco
+ md5sums = SKIP
+
+pkgname = bibisco
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d4987d6cafc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: sardach <sardach@uwu.mx>
+pkgname=bibisco
+_pkgname='bibisco CE'
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Novel writing software. Community Edition."
+arch=('x86_64')
+url="https://www.bibisco.com/"
+license=('GPL3')
+depends=('npm')
+source=("git+https://github.com/andreafeccomandi/bibisco")
+md5sums=('SKIP');
+build() {
+ cd "$srcdir"/bibisco/bibisco/app
+ npm install
+}
+package() {
+mkdir -p $pkgdir/usr/share/$pkgname
+mkdir -p $pkgdir/usr/bin/
+mv $srcdir/bibisco/bibisco/app/* $pkgdir/usr/share/$pkgname
+echo '#!/bin/bash
+cd /usr/share/bibisco/
+npm start
+' > $pkgdir/usr/bin/bibisco
+chmod +x $pkgdir/usr/bin/bibisco
+}
+
+
+
+
+