summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nägele2020-03-22 23:35:01 +0100
committerDaniel Nägele2020-03-22 23:35:01 +0100
commit620c55e3ca0d132283511bac99656ee48a688065 (patch)
tree3394feb4d5bbfaecadd45f6418f34ee23ff6dd3b
downloadaur-bin-bin.tar.gz
initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--bin.service12
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45adcf98b061
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bin-bin
+ pkgdesc = A paste bin written in Rust. Github Release Binary.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/w4/bin
+ arch = x86_64
+ license = WTFPL
+ conflicts = bin
+ source = https://github.com/w4/bin/releases/download/v1.0.2/bin-v1.0.2-x86_64-unknown-linux-gnu.tar.gz
+ source = bin.service
+ sha256sums = f8166e15d921bc8c67ae1c16777ea73dba4275197a9f1073645529ebe6f36a53
+ sha256sums = 4cb0c08af068637bb9c6330d41f34defc4173a863c2e2dd33f06fbffccfd80dc
+
+pkgname = bin-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0868295e3612
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Daniel Nägele <arch@danieln.de>
+pkgname=bin-bin
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="A paste bin written in Rust. Github Release Binary."
+arch=('x86_64')
+url="https://github.com/w4/bin"
+license=('WTFPL')
+conflicts=('bin')
+source=("https://github.com/w4/bin/releases/download/v1.0.2/bin-v${pkgver}-x86_64-unknown-linux-gnu.tar.gz" 'bin.service')
+sha256sums=('f8166e15d921bc8c67ae1c16777ea73dba4275197a9f1073645529ebe6f36a53'
+ '4cb0c08af068637bb9c6330d41f34defc4173a863c2e2dd33f06fbffccfd80dc')
+
+package() {
+ cd "$srcdir"
+
+ install -Dm644 bin.service "$pkgdir/usr/lib/systemd/system/bin.service"
+ install -Dm755 bin "$pkgdir/usr/bin/bin"
+}
+
diff --git a/bin.service b/bin.service
new file mode 100644
index 000000000000..9b8b3f5b3854
--- /dev/null
+++ b/bin.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=A paste bin
+After=network.target
+
+[Service]
+User=nobody
+Type=simple
+ExecStart=/usr/bin/bin
+Restart=always
+
+[Install]
+WantedBy=multi-user.target