summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2018-02-27 19:42:28 -0500
committerEli Schwartz2018-02-27 19:42:28 -0500
commit56ff05a34cd7c291a1b4c9379f27dcd5e7f56969 (patch)
tree34700d33e5522d4e022db15671bc2ea3f54a3d31
parent04f631afce07aeb73041c87b524a393ec82cd6b8 (diff)
downloadaur-56ff05a34cd7c291a1b4c9379f27dcd5e7f56969.tar.gz
Revert "Fixed PKGBUILD"
This reverts commit 04f631afce07aeb73041c87b524a393ec82cd6b8. In no sane world does this fix anything at all, instead a number of things have regressed. Specifically, the badly designed use of bash in the systemd service, the fact that an architecture-dependent package was casually switched to lie and claim it is an "any" package, moving away from the upstream naming for the service, and not cleaning up after being stopped.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--binfmt-support.service (renamed from binfmts.service)8
3 files changed, 21 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62cd0af4759e..0c779c423f93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
+# Generated by mksrcinfo v8
+# 二 1月 9 02:09:17 UTC 2018
pkgbase = binfmt-support
pkgdesc = register interpreters for various binary formats
pkgver = 2.1.8
pkgrel = 2
url = http://packages.debian.org/en/sid/binfmt-support
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL
- depends = glibc
- depends = systemd
depends = libpipeline
- source = http://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_2.1.8.orig.tar.gz
- source = binfmts.service
- md5sums = b86d8a8d310e246f1e02b91366472681
- md5sums = 0000a524a3d97583563a0d1d6f6b1ecb
+ source = ftp://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_2.1.8.orig.tar.gz
+ source = binfmt-support.service
+ sha256sums = ebad04db8444d2275d042b5074fa3e160bcf3e2c23ee9b660e75f5acd73618a2
+ sha256sums = efba2300b9f0c8c5c14696d2b25836d91edaaad8d30c64ed7d3eab0163b2553e
pkgname = binfmt-support
diff --git a/PKGBUILD b/PKGBUILD
index a064bd305986..502b9d63212b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,19 @@ pkgname=binfmt-support
pkgver=2.1.8
pkgrel=2
pkgdesc="register interpreters for various binary formats"
-arch=(any)
+arch=(i686 x86_64)
url="http://packages.debian.org/en/sid/binfmt-support"
license=('GPL')
-depends=('glibc' 'systemd' 'libpipeline')
+depends=('libpipeline')
makedepends=()
-source=(
- http://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_$pkgver.orig.tar.gz
- binfmts.service
- )
-md5sums=(
- 'b86d8a8d310e246f1e02b91366472681'
- '0000a524a3d97583563a0d1d6f6b1ecb'
- )
+source=(ftp://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_$pkgver.orig.tar.gz
+ binfmt-support.service)
+sha256sums=('ebad04db8444d2275d042b5074fa3e160bcf3e2c23ee9b660e75f5acd73618a2'
+ 'efba2300b9f0c8c5c14696d2b25836d91edaaad8d30c64ed7d3eab0163b2553e')
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --libexecdir=/usr/lib --sbindir=/usr/bin
+ ./configure --prefix=/usr --libexecdir=/usr/lib --sbindir=/usr/bin --localstatedir=/var
make
}
@@ -26,5 +22,5 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
install -dm0755 $pkgdir/var/lib/binfmts
- install -Dm755 ../binfmts.service $pkgdir/usr/lib/systemd/system/binfmts.service
+ install -Dm644 $srcdir/binfmt-support.service $pkgdir/usr/lib/systemd/system/binfmt-support.service
}
diff --git a/binfmts.service b/binfmt-support.service
index 7e6256908d5f..b7035d853aec 100644
--- a/binfmts.service
+++ b/binfmt-support.service
@@ -4,12 +4,14 @@ Documentation=man:update-binfmts(8)
[Service]
Type=oneshot
-ExecStart=/bin/bash -c "exec /usr/bin/update-binfmts --enable"
-KillMode=none
+ExecStart=/usr/bin/update-binfmts --enable
+ExecStop=/usr/bin/update-binfmts --disable
+KillMode=process
Restart=no
+RemainAfterExit=yes
[Install]
WantedBy=multi-user.target
-# This service file writes "enabled" to /proc/sys/fs/binfmt_misc/status,
+# This service file writes "enabled" to /proc/sys/fs/binfmt_misc/status,
# and registers all binfmt specifications in /var/lib/binfmts (default)