summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2018-02-27 19:42:36 -0500
committerEli Schwartz2018-02-27 19:42:36 -0500
commit5a3f39042dbb2407df7150476505bea0aceba757 (patch)
treeca64efabcc7d70db4067015162640d2a5a895c8a
parent56ff05a34cd7c291a1b4c9379f27dcd5e7f56969 (diff)
downloadaur-5a3f39042dbb2407df7150476505bea0aceba757.tar.gz
Clean up some nastiness, don't overwrite upstream-provided systemd unit.
This package is still completely pointless as systemd-binfmt on modern Arch system already does this for us. So this is only being fixed in time to be deleted anyways.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c779c423f93..a100be99916e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
-# Generated by mksrcinfo v8
-# 二 1月 9 02:09:17 UTC 2018
pkgbase = binfmt-support
pkgdesc = register interpreters for various binary formats
pkgver = 2.1.8
pkgrel = 2
- url = http://packages.debian.org/en/sid/binfmt-support
+ url = https://packages.debian.org/en/sid/binfmt-support
arch = i686
arch = x86_64
license = GPL
depends = libpipeline
- source = ftp://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_2.1.8.orig.tar.gz
- source = binfmt-support.service
+ options = emptydirs
+ source = http://http.debian.net/debian/pool/main/b/binfmt-support/binfmt-support_2.1.8.orig.tar.gz
sha256sums = ebad04db8444d2275d042b5074fa3e160bcf3e2c23ee9b660e75f5acd73618a2
- sha256sums = efba2300b9f0c8c5c14696d2b25836d91edaaad8d30c64ed7d3eab0163b2553e
pkgname = binfmt-support
diff --git a/PKGBUILD b/PKGBUILD
index 502b9d63212b..38dcde13f4f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,25 @@ pkgname=binfmt-support
pkgver=2.1.8
pkgrel=2
pkgdesc="register interpreters for various binary formats"
-arch=(i686 x86_64)
-url="http://packages.debian.org/en/sid/binfmt-support"
+arch=('i686' 'x86_64')
+url="https://packages.debian.org/en/sid/binfmt-support"
license=('GPL')
depends=('libpipeline')
-makedepends=()
-source=(ftp://ftp.de.debian.org/debian/pool/main/b/binfmt-support/binfmt-support_$pkgver.orig.tar.gz
- binfmt-support.service)
-sha256sums=('ebad04db8444d2275d042b5074fa3e160bcf3e2c23ee9b660e75f5acd73618a2'
- 'efba2300b9f0c8c5c14696d2b25836d91edaaad8d30c64ed7d3eab0163b2553e')
+options=('emptydirs')
+source=("http://http.debian.net/debian/pool/main/${pkgname:0:1}/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz")
+sha256sums=('ebad04db8444d2275d042b5074fa3e160bcf3e2c23ee9b660e75f5acd73618a2')
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --libexecdir=/usr/lib --sbindir=/usr/bin --localstatedir=/var
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --disable-upstart
make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
- install -dm0755 $pkgdir/var/lib/binfmts
- install -Dm644 $srcdir/binfmt-support.service $pkgdir/usr/lib/systemd/system/binfmt-support.service
}