summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWeitian Leung2018-03-05 22:19:09 +0800
committerWeitian Leung2018-03-05 22:19:09 +0800
commitdeb4d4e99732f823f4da50f7b411e9621b8bbc06 (patch)
treef84ffb7fc9a8cc9f340a4395688ee66d8feba547
parent6f5ef7712007ce45a44de9b0ac7cb25833eeb788 (diff)
downloadaur-deb4d4e99732f823f4da50f7b411e9621b8bbc06.tar.gz
Temporary switch to golang branch to fix no update wallpaper at startup
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--bing-wallpaper-git.install10
3 files changed, 17 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cf12a47aa4c..97aec0e1aaa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Mar 5 13:50:55 UTC 2018
+# Mon Mar 5 14:18:56 UTC 2018
pkgbase = bing-wallpaper-git
pkgdesc = Bing Wallpaper of the Day as your Linux Desktop's wallpaper
pkgver = r46
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/marguerite/linux-bing-wallpaper
install = bing-wallpaper-git.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 1801238d467f..da69fd10ae79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bing-wallpaper-git
pkgver=r46
-pkgrel=1
+pkgrel=2
pkgdesc="Bing Wallpaper of the Day as your Linux Desktop's wallpaper"
arch=(any)
url="https://github.com/marguerite/linux-bing-wallpaper"
@@ -16,6 +16,11 @@ source=("$pkgname::git+https://github.com/marguerite/linux-bing-wallpaper.git")
sha512sums=('SKIP')
install=${pkgname}.install
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git checkout golang
+}
+
pkgver() {
cd "${srcdir}/${pkgname}"
printf "r%s" "$(git rev-list --count HEAD)"
diff --git a/bing-wallpaper-git.install b/bing-wallpaper-git.install
index 2d2b23297840..2e8fcab32b68 100644
--- a/bing-wallpaper-git.install
+++ b/bing-wallpaper-git.install
@@ -1,4 +1,4 @@
-post_install() {
+hints() {
echo "-------------------------------------------------------------------------------------------------------"
echo "Run 'systemctl --user start bing-wallpaper.service' to start the service"
echo "Run 'systemctl --user enable bing-wallpaper.service' for autostart bing-wallpaper."
@@ -6,3 +6,11 @@ post_install() {
echo "See https://wiki.archlinux.org/index.php/Systemd/User#Environment_variables"
echo "-------------------------------------------------------------------------------------------------------"
}
+
+post_install() {
+ hints
+}
+
+post_upgrade() {
+ hints
+}