summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhndrkk2022-08-30 15:52:08 +0200
committerhndrkk2022-08-30 15:52:08 +0200
commit75b596dd2bea379146cc8c101c2640788e53e51a (patch)
tree1f76407b030bfa40674a23f5799ca0efd1fa9ef3
parentef86dbabd440a4f00c76137012f2eb8f15fcd148 (diff)
downloadaur-bino-git.tar.gz
update source url, add patch
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
-rw-r--r--ffmpeg4.4.patch48
3 files changed, 63 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6c096a3412e..d7709526ed06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by mksrcinfo v8
-# Thu Feb 16 02:42:07 UTC 2017
pkgbase = bino-git
pkgdesc = Stereoscopic 3D video player with multi-display support.
- pkgver = 1.6.5.r2.gd6ab95c
- pkgrel = 1
+ pkgver = 1.6.8
+ pkgrel = 2
url = http://bino3d.org/
arch = i686
arch = x86_64
license = GPLv3
makedepends = git
- depends = ffmpeg
+ depends = ffmpeg4.4
depends = freealut
depends = freeglut
depends = glew
@@ -18,8 +16,9 @@ pkgbase = bino-git
optdepends = lirc: for infrared remote control
provides = bino
conflicts = bino
- source = bino-git::git+http://git.savannah.gnu.org/r/bino.git
+ source = bino-git::git+https://git.marlam.de/git/bino.git
+ source = ffmpeg4.4.patch
+ md5sums = SKIP
md5sums = SKIP
pkgname = bino-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3001e380946f..021e5a4f0148 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,21 @@
-# Maintainer: aksr <aksr at t-com dot me>
+# MAINTAINER: ramen <hendrikjschick@gmail.com>
+# CONTRIBUTOR: aksr <aksr at t-com dot me>
pkgname=bino-git
-pkgver=1.6.5.r2.gd6ab95c
-pkgrel=1
-epoch=
+pkgver=1.6.8
+pkgrel=2
pkgdesc="Stereoscopic 3D video player with multi-display support."
arch=('i686' 'x86_64')
url="http://bino3d.org/"
license=('GPLv3')
-groups=()
-depends=('ffmpeg' 'freealut' 'freeglut' 'glew' 'libass' 'qt5-base')
+depends=('ffmpeg4.4' 'freealut' 'freeglut' 'glew' 'libass' 'qt5-base')
makedepends=('git')
optdepends=('lirc: for infrared remote control')
-checkdepends=()
provides=('bino')
conflicts=('bino')
-replaces=()
-backup=()
-options=()
-changelog=
-install=
-source=("$pkgname::git+http://git.savannah.gnu.org/r/bino.git")
+source=("$pkgname::git+https://git.marlam.de/git/bino.git" ffmpeg4.4.patch)
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP' 'SKIP')
+
pkgver() {
cd "$srcdir/$pkgname"
@@ -31,6 +25,7 @@ pkgver() {
build() {
cd "$srcdir/$pkgname"
autoreconf -i
+ patch -Np1 -i ${srcdir}/ffmpeg4.4.patch
./configure --prefix=/usr --with-qt-version=5
make
}
diff --git a/ffmpeg4.4.patch b/ffmpeg4.4.patch
new file mode 100644
index 000000000000..f80929080a40
--- /dev/null
+++ b/ffmpeg4.4.patch
@@ -0,0 +1,48 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -143,25 +143,6 @@ if test -z "$PKG_CONFIG"; then
+ AC_MSG_WARN([please install pkg-config; Debian package: pkg-config])
+ fi
+
+-dnl FFmpeg
+-PKG_CHECK_MODULES([libavformat], [libavformat >= 52.110.0 libavcodec libavutil], [HAVE_LIBAVFORMAT=1], [HAVE_LIBAVFORMAT=0])
+-if test "$HAVE_LIBAVFORMAT" != "1"; then
+- AC_MSG_WARN([required library libavformat >= 52.110.0 not found:])
+- AC_MSG_WARN([$libavformat_PKG_ERRORS])
+- AC_MSG_WARN([libavformat >= 52.110.0 is provided by libav >= 0.7 or FFmpeg >= 0.7])
+-fi
+-PKG_CHECK_MODULES([libavdevice], [libavdevice >= 52.5.0], [HAVE_LIBAVDEVICE=1], [HAVE_LIBAVDEVICE=0])
+-if test "$HAVE_LIBAVDEVICE" != "1"; then
+- AC_MSG_WARN([required library libavdevice >= 52.5.0 not found:])
+- AC_MSG_WARN([$libavdevice_PKG_ERRORS])
+- AC_MSG_WARN([libavdevice >= 52.5.0 is provided by libav >= 0.7 or FFmpeg >= 0.7])
+-fi
+-PKG_CHECK_MODULES([libswscale], [libswscale >= 0.14.1 libavutil], [HAVE_LIBSWSCALE=1], [HAVE_LIBSWSCALE=0])
+-if test "$HAVE_LIBSWSCALE" != "1"; then
+- AC_MSG_WARN([required library libswscale >= 0.14.1 not found:])
+- AC_MSG_WARN([$libswscale_PKG_ERRORS])
+- AC_MSG_WARN([libswscale >= 0.14.1 is provided by libav >= 0.7 or FFmpeg >= 0.7])
+-fi
+ AC_CHECK_FUNCS([sysconf])
+
+ dnl libass
+@@ -400,11 +381,16 @@ UPDATE_DESKTOP_DATABASE=""
+ AC_ARG_VAR([UPDATE_DESKTOP_DATABASE], [update-desktop-database command])
+ AC_CHECK_PROGS([UPDATE_DESKTOP_DATABASE], [update-desktop-database])
+
++dnl ffmpeg4.4 libs
++LIBS="$LIBS /usr/lib/libswscale.so.5"
++LIBS="$LIBS /usr/lib/libavutil.so.56"
++LIBS="$LIBS /usr/lib/libavformat.so.58"
++LIBS="$LIBS /usr/lib/libavdevice.so.58"
++LIBS="$LIBS /usr/lib/libavcodec.so.58"
++CPPFLAGS="$CPPFLAGS -I/usr/include/ffmpeg4.4"
++
+ dnl Check if all libraries were found
+ if test "$am_cv_func_iconv" != "yes" \
+- -o "$HAVE_LIBAVFORMAT" != "1" \
+- -o "$HAVE_LIBAVDEVICE" != "1" \
+- -o "$HAVE_LIBSWSCALE" != "1" \
+ -o "$HAVE_LIBASS" != "1" \
+ -o "$HAVE_LIBOPENAL" != "1" \
+ -o "$HAVE_LIBQTOPENGL" != "1" \