summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoricecamphor2023-11-23 23:39:55 +0530
committericecamphor2023-11-23 23:39:55 +0530
commit122b6e09d4c30123c4d1895169d80722094b6be7 (patch)
tree3d3368853baad5e86231f46d765e487e640f6843
downloadaur-biodiff-bin.tar.gz
biodiff v1.1.0
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--ChangeLog14
-rw-r--r--PKGBUILD22
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76d2342dcccf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = biodiff-bin
+ pkgdesc = Hex diff viewer using alignment algorithms from biology
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/8051Enthusiast/biodiff
+ changelog = ChangeLog
+ arch = x86_64
+ license = MIT
+ depends = gcc-libs
+ depends = glibc
+ provides = biodiff
+ provides = git-biodiff
+ conflicts = biodiff
+ source = https://github.com/8051Enthusiast/biodiff/releases/download/v1.1.0/biodiff-linux-1.1.0.zip
+ md5sums = 827ff2469fbe282a15cb9b82686adbe4
+ sha256sums = 73377d86c52de66034f0aabfa725af5173340d3a7ccbdd4f872cc3d0d64988ae
+
+pkgname = biodiff-bin
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..6151376e06dc
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,14 @@
+
+# biodiff v1.1.0
+https://github.com/8051Enthusiast/biodiff/releases/tag/v1.1.0
+
+- Make bytes per row adjustable
+- Add automatic determination of bytes per row based on data in view
+- Redesign Goto menu
+- Make address only use as many digits as necessary
+- Add alignment of selected regions
+- Allow disabling terminal-escape based scroll
+- Fix some flickering when using terminal-escape based scroll
+- Add ability to jump up and down to differences and insertions
+- Add address difference to status bar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7227a23128c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: icecamphor <camphor@skiff.com>
+
+pkgname='biodiff-bin'
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Hex diff viewer using alignment algorithms from biology"
+arch=('x86_64')
+url="https://github.com/8051Enthusiast/biodiff"
+license=('MIT')
+depends=('gcc-libs' 'glibc')
+provides=('biodiff' 'git-biodiff')
+conflicts=('biodiff')
+changelog=ChangeLog
+source=('https://github.com/8051Enthusiast/biodiff/releases/download/v1.1.0/biodiff-linux-1.1.0.zip')
+md5sums=('827ff2469fbe282a15cb9b82686adbe4')
+sha256sums=('73377d86c52de66034f0aabfa725af5173340d3a7ccbdd4f872cc3d0d64988ae')
+
+
+package() {
+ install -Dm755 ./biodiff "$pkgdir/usr/bin/biodiff"
+ install -Dm755 ./git-biodiff "$pkgdir/usr/bin/git-biodiff"
+}