summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Ellithorpe2018-04-04 22:25:25 -0700
committerJosh Ellithorpe2018-04-04 22:26:14 -0700
commit61bd4eccf9ec92a67511c6134a9925291e0d415f (patch)
tree1b1a478b2322fac3c05cf4b445084e150642e754
parentc56fe94eda1f0f220bafe14339502f0cf45c5021 (diff)
downloadaur-61bd4eccf9ec92a67511c6134a9925291e0d415f.tar.gz
Bump to 0.17.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--patch.diff70
3 files changed, 9 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f578e8823e4c..e6ca7c36cd54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitcoin-abc-qt
pkgdesc = Bitcoin ABC with bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt
- pkgver = 0.16.2
- pkgrel = 2
+ pkgver = 0.17.0
+ pkgrel = 1
url = https://bitcoinabc.org
install = bitcoin.install
arch = i686
@@ -28,20 +28,18 @@ pkgbase = bitcoin-abc-qt
conflicts = bitcoin-qt
backup = etc/bitcoin/bitcoin.conf
backup = etc/logrotate.d/bitcoin
- source = https://github.com/Bitcoin-ABC/bitcoin-abc/archive/v0.16.2.tar.gz
+ source = https://github.com/Bitcoin-ABC/bitcoin-abc/archive/v0.17.0.tar.gz
source = bitcoin.conf
source = bitcoin.logrotate
source = bitcoin.service
source = bitcoin-reindex.service
source = bitcoin.install
- source = patch.diff
- sha256sums = d63616b5399f7bcff88bf874a1880ba8d55b44b8ff9b07d0d56f5b5dfa64d0d9
+ sha256sums = 3c346df244cd6cc0236a3f8564e9a8c52ee7927540f201863748cd2288550613
sha256sums = b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35
sha256sums = 8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f
sha256sums = 9643eed2c20d78a9c7347df64099765773615f79d3b8a95693d871c933516880
sha256sums = 35ff9331d7df8b90adfc7d82752cca4f8b7ff23a29e5d10b07e4e3fc78050679
sha256sums = 6db7458a85a0b469ab95ad78e431d0a5db078d8809a5f4340ee040f304a9dc0d
- sha256sums = 6b146dc6158d753440c7bf4ea05fa8c38ae7411d4e0cb74a444fcc797b904b5c
pkgname = bitcoin-abc-qt
diff --git a/PKGBUILD b/PKGBUILD
index 503a866a524a..af8faea62410 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Josh Ellithorpe <quest@mac.com>
pkgname=bitcoin-abc-qt
-pkgver=0.16.2
-pkgrel=2
+pkgver=0.17.0
+pkgrel=1
pkgdesc="Bitcoin ABC with bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt"
arch=('i686' 'x86_64')
url="https://bitcoinabc.org"
@@ -14,15 +14,13 @@ source=(https://github.com/Bitcoin-ABC/bitcoin-abc/archive/v$pkgver.tar.gz
bitcoin.logrotate
bitcoin.service
bitcoin-reindex.service
- bitcoin.install
- patch.diff)
-sha256sums=('d63616b5399f7bcff88bf874a1880ba8d55b44b8ff9b07d0d56f5b5dfa64d0d9'
+ bitcoin.install)
+sha256sums=('3c346df244cd6cc0236a3f8564e9a8c52ee7927540f201863748cd2288550613'
'b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35'
'8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f'
'9643eed2c20d78a9c7347df64099765773615f79d3b8a95693d871c933516880'
'35ff9331d7df8b90adfc7d82752cca4f8b7ff23a29e5d10b07e4e3fc78050679'
- '6db7458a85a0b469ab95ad78e431d0a5db078d8809a5f4340ee040f304a9dc0d'
- '6b146dc6158d753440c7bf4ea05fa8c38ae7411d4e0cb74a444fcc797b904b5c')
+ '6db7458a85a0b469ab95ad78e431d0a5db078d8809a5f4340ee040f304a9dc0d')
backup=('etc/bitcoin/bitcoin.conf'
'etc/logrotate.d/bitcoin')
provides=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-tx' 'bitcoin-qt')
@@ -32,9 +30,6 @@ install=bitcoin.install
build() {
cd "$srcdir/bitcoin-abc-$pkgver"
- msg2 'Patching...'
- patch -p1 < ../patch.diff
-
msg2 'Building...'
./autogen.sh
./configure \
diff --git a/patch.diff b/patch.diff
deleted file mode 100644
index d45b98593b7f..000000000000
--- a/patch.diff
+++ /dev/null
@@ -1,70 +0,0 @@
-diff --git a/src/miner.h b/src/miner.h
-index bf79bdfd6..cc9c62c1f 100644
---- a/src/miner.h
-+++ b/src/miner.h
-@@ -71,7 +71,7 @@ struct modifiedentry_iter {
- // TODO: refactor to avoid duplication of this logic.
- struct CompareModifiedEntry {
- bool operator()(const CTxMemPoolModifiedEntry &a,
-- const CTxMemPoolModifiedEntry &b) {
-+ const CTxMemPoolModifiedEntry &b) const {
- double f1 = double(b.nSizeWithAncestors *
- a.nModFeesWithAncestors.GetSatoshis());
- double f2 = double(a.nSizeWithAncestors *
-@@ -87,7 +87,7 @@ struct CompareModifiedEntry {
- // This is sufficient to sort an ancestor package in an order that is valid
- // to appear in a block.
- struct CompareTxIterByAncestorCount {
-- bool operator()(const CTxMemPool::txiter &a, const CTxMemPool::txiter &b) {
-+ bool operator()(const CTxMemPool::txiter &a, const CTxMemPool::txiter &b) const {
- if (a->GetCountWithAncestors() != b->GetCountWithAncestors())
- return a->GetCountWithAncestors() < b->GetCountWithAncestors();
- return CTxMemPool::CompareIteratorByHash()(a, b);
-diff --git a/src/txmempool.h b/src/txmempool.h
-index c51ca831b..72c066335 100644
---- a/src/txmempool.h
-+++ b/src/txmempool.h
-@@ -245,7 +245,7 @@ struct mempoolentry_txid {
- */
- class CompareTxMemPoolEntryByDescendantScore {
- public:
-- bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) {
-+ bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) const {
- bool fUseADescendants = UseDescendantScore(a);
- bool fUseBDescendants = UseDescendantScore(b);
-
-@@ -272,7 +272,7 @@ class CompareTxMemPoolEntryByDescendantScore {
- }
-
- // Calculate which score to use for an entry (avoiding division).
-- bool UseDescendantScore(const CTxMemPoolEntry &a) {
-+ bool UseDescendantScore(const CTxMemPoolEntry &a) const {
- double f1 = double(a.GetSizeWithDescendants() *
- a.GetModifiedFee().GetSatoshis());
- double f2 =
-@@ -287,7 +287,7 @@ class CompareTxMemPoolEntryByDescendantScore {
- */
- class CompareTxMemPoolEntryByScore {
- public:
-- bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) {
-+ bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) const {
- double f1 = double(b.GetTxSize() * a.GetModifiedFee().GetSatoshis());
- double f2 = double(a.GetTxSize() * b.GetModifiedFee().GetSatoshis());
- if (f1 == f2) {
-@@ -299,14 +299,14 @@ class CompareTxMemPoolEntryByScore {
-
- class CompareTxMemPoolEntryByEntryTime {
- public:
-- bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) {
-+ bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) const {
- return a.GetTime() < b.GetTime();
- }
- };
-
- class CompareTxMemPoolEntryByAncestorFee {
- public:
-- bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) {
-+ bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) const {
- double aFees = double(a.GetModFeesWithAncestors().GetSatoshis());
- double aSize = a.GetSizeWithAncestors();
-