summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Squillace2017-01-06 00:38:50 +0000
committerFilippo Squillace2017-01-06 00:38:50 +0000
commitc972a22f62622cb4c555dec03f3faa8d65e3b9de (patch)
tree14b15e85ea635ca8d66713341d6034d3fd76332d
parent5c7bafa6548179027ede252c32c3dfde47f33f80 (diff)
downloadaur-c972a22f62622cb4c555dec03f3faa8d65e3b9de.tar.gz
Update source to the bitlbee repo
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
2 files changed, 26 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ea30ec2e8a2..83e233d84a89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
-# Generated by mksrcinfo v8
-# Wed Jan 27 00:12:48 UTC 2016
pkgbase = bitlbee-facebook-git
pkgdesc = Facebook protocol plugin for BitlBee
- pkgver = r108.8ba3f26
+ pkgver = r121.ece0715
pkgrel = 1
- url = https://github.com/jgeboski/bitlbee-facebook
+ url = https://github.com/bitlbee/bitlbee-facebook
arch = i686
arch = x86_64
arch = armv7h
+ arch = arm6h
license = GPL
makedepends = git
depends = bitlbee
depends = json-glib
conflicts = bitlbee-facebook
- source = git+https://github.com/jgeboski/bitlbee-facebook.git
+ source = git+https://github.com/bitlbee/bitlbee-facebook.git#branch=master
md5sums = SKIP
pkgname = bitlbee-facebook-git
diff --git a/PKGBUILD b/PKGBUILD
index d1e5d8e779bc..5573196b9fd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,46 @@
+# Maintainer: Filippo Squillace <feel dot sqoox at gmail dot com>
# Maintainer: polyzen <polycitizen@gmail.com>
# Contributor: mickael9 <mickael9 at gmail dot com>
pkgname=bitlbee-facebook-git
-pkgver=r108.8ba3f26
+pkgver=r121.ece0715
pkgrel=1
pkgdesc='Facebook protocol plugin for BitlBee'
-arch=('i686' 'x86_64' 'armv7h')
-url='https://github.com/jgeboski/bitlbee-facebook'
+arch=('i686' 'x86_64' 'armv7h' 'arm6h')
+url='https://github.com/bitlbee/bitlbee-facebook'
license=('GPL')
depends=('bitlbee' 'json-glib')
makedepends=('git')
conflicts=('bitlbee-facebook')
-source=('git+https://github.com/jgeboski/bitlbee-facebook.git')
+
+source=("git+https://github.com/bitlbee/${pkgname%-git}.git#branch=master")
md5sums=('SKIP')
pkgver() {
- cd ${pkgname%%-git}
+ cd "$srcdir/${pkgname%-git}"
+
+# The examples below are not absolute and need to be adapted to each repo. The
+# primary goal is to generate version numbers that will increase according to
+# pacman's version comparisons with later commits to the repo. The format
+# VERSION='VER_NUM.rREV_NUM.HASH', or a relevant subset in case VER_NUM or HASH
+# are not available, is recommended.
+
+# Git, tags available
+# printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+
+# Git, no tags available
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
}
build() {
- cd ${pkgname%%-git}
- ./autogen.sh
- ./configure --prefix=/usr
+ cd "$srcdir/${pkgname%-git}"
+ ./autogen.sh --prefix=/usr
make
}
package() {
- cd ${pkgname%%-git}
+ cd "$srcdir/${pkgname%-git}"
make DESTDIR="$pkgdir" install
}