diff options
author | Dimitris Kiziridis | 2020-05-10 00:54:51 +0300 |
---|---|---|
committer | Dimitris Kiziridis | 2020-05-10 00:54:51 +0300 |
commit | 6486cad2b63a86825167cfeef19bc6dd8567674c (patch) | |
tree | 2a2d79771be9598851cf05d1e3d633197094713a | |
parent | 034aea2318ef13063934a52b5671f63b4c124d5c (diff) | |
download | aur-bitly-client.tar.gz |
sanitize pkgbuild
-rw-r--r-- | .SRCINFO | 6 | ||||
-rw-r--r-- | PKGBUILD | 7 |
2 files changed, 9 insertions, 4 deletions
@@ -4,11 +4,13 @@ pkgbase = bitly-client pkgrel = 1 url = https://github.com/specious/bitly-client arch = x86_64 - license = MIT + license = ISC makedepends = npm + depends = nodejs + depends = bash noextract = bitly-client-1.7.2.tar.gz source = bitly-client-1.7.2.tar.gz::https://github.com/specious/bitly-client/archive/v1.7.2.tar.gz - md5sums = 49ce0af9fb2ad2a257c4c086c11e6aa6 + sha256sums = 9106390a4c56391bc755acc10177f7e98a80d1a95a08ced483b115995a89a6d8 pkgname = bitly-client @@ -6,11 +6,12 @@ pkgrel=1 pkgdesc="Create and manage your Bitly shortlinks from the command line" arch=('x86_64') url='https://github.com/specious/bitly-client' -license=('MIT') +license=('ISC') +depends=('nodejs' 'bash') makedepends=('npm') noextract=("${pkgname}-${pkgver}.tar.gz") source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz") -md5sums=('49ce0af9fb2ad2a257c4c086c11e6aa6') +sha256sums=('9106390a4c56391bc755acc10177f7e98a80d1a95a08ced483b115995a89a6d8') package() { npm install -g --user root --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tar.gz" @@ -23,4 +24,6 @@ package() { mv "$tmppackage" "$pkgjson" chmod 644 "$pkgjson" chown -R root:root "${pkgdir}" + install -Dm644 "${pkgdir}/usr/lib/node_modules/bitly-client/node_modules/bitly/LICENCE" \ + "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" }
\ No newline at end of file |