summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilo Gilad2018-07-31 07:54:21 -0400
committerMilo Gilad2018-07-31 07:54:21 -0400
commit2cb0277810535a73ced52ef7405c0ccc9d99bfcd (patch)
treeb8c8ba30f66769f7f9791b0401114b58c702b936
downloadaur-2cb0277810535a73ced52ef7405c0ccc9d99bfcd.tar.gz
Init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD25
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68732de947ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = bitwarden-bin
+ pkgdesc = A secure and free password manager for all of your devices.
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://bitwarden.com
+ arch = x86_64
+ license = GPL
+ depends = alsa-lib
+ depends = gconf
+ depends = gtk2
+ depends = libnotify
+ depends = libsecret
+ depends = libxss
+ depends = libxtst
+ depends = nspr
+ depends = nss
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/bitwarden/desktop/releases/download/v1.4.0/Bitwarden-1.4.0-amd64.deb
+ sha512sums = e4dcf90a34bd891ef7ea1e69689402d1222d215c3315db9031d7fda2720c3a1bdbc6b838fe80e51a8126866c4ca3854216d9b8cdfaf8527e95aab56aea13b0b0
+
+pkgname = bitwarden-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cafdac87372
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Generated by debtap
+# Maintainer: Milo Gilad <myl0gcontact@gmail.com>
+pkgname=bitwarden-bin
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A secure and free password manager for all of your devices."
+arch=('x86_64')
+url="https://bitwarden.com"
+license=('GPL')
+groups=('')
+depends=('alsa-lib' 'gconf' 'gtk2' 'libnotify' 'libsecret' 'libxss' 'libxtst' 'nspr' 'nss')
+options=('!strip' '!emptydirs')
+source=("https://github.com/bitwarden/desktop/releases/download/v${pkgver}/Bitwarden-${pkgver}-amd64.deb")
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ # Symlink
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/Bitwarden/bitwarden" "${pkgdir}/usr/bin/${pkgname}"
+}
+
+sha512sums=('e4dcf90a34bd891ef7ea1e69689402d1222d215c3315db9031d7fda2720c3a1bdbc6b838fe80e51a8126866c4ca3854216d9b8cdfaf8527e95aab56aea13b0b0')