summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Hansen2023-12-16 19:10:16 -0800
committerScott Hansen2023-12-16 19:10:16 -0800
commitd8bf932707f8e9535fbe4bc59244b24a067633e3 (patch)
tree88cf159c4e3fccb0ba4b929c9c5f451df997c552
parent90f5641f64da8098c378985d40d93f78598ef0bd (diff)
downloadaur-bitwarden-menu-git.tar.gz
Add prepare() git clean per packaging guidelines and add python-hatchling to makedepends
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc4079e1b053..d5b075703e8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitwarden-menu-git
pkgdesc = Dmenu/Rofi frontend for Bitwarden/Vaultwarden.
- pkgver = r50.7cb8386
+ pkgver = r101.1324b78
pkgrel = 1
url = https://github.com/firecat53/bitwarden-menu
install = bitwarden-menu.install
@@ -11,6 +11,8 @@ pkgbase = bitwarden-menu-git
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
+ makedepends = python-hatchling
+ makedepends = python-hatch-vcs
depends = python
depends = python-pynput
depends = bitwarden-cli
diff --git a/PKGBUILD b/PKGBUILD
index c06db62d5e67..0e732f8f60b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,8 @@ arch=('any')
url="https://github.com/firecat53/bitwarden-menu"
license=('MIT')
depends=('python' 'python-pynput' 'bitwarden-cli' 'python-xdg')
-makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel'
+ 'python-hatchling' 'python-hatch-vcs')
optdepends=('dmenu: either dmenu or rofi is required'
'rofi: either dmenu or rofi is required'
'xdotool: required for typing non-U.S. Unicode characters'
@@ -22,6 +23,10 @@ source=("git+https://github.com/firecat53/$_gitname.git")
md5sums=('SKIP')
install="$_pkgname.install"
+prepare() {
+ git -C "$_gitname" clean -dfx
+}
+
pkgver() {
cd "$_gitname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"