summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Richter2021-02-19 20:20:42 +0100
committerMarkus Richter2021-02-19 20:20:42 +0100
commit56517edaac70115a72d603a6eb983ad5d8764633 (patch)
tree73f7a3aa144e089daa465f970cd846361d221aa4
parenta78efac975fea2110d85dcf39839fb7574a0a908 (diff)
downloadaur-bitwarden_rs-vault.tar.gz
2.18.1
- Adapt changes to patch from http://github.com/dani-garcia/bw_web_builds - Hide the `API Key` section under `My Account` - Hide emergency access and custom org user type functionality - Hide `Single Organization` policy and Business Portal warning message Upstream Changes: 2.17.0 - GDPR Compilance - New policies for "single org" and "require sso" - Bug fixes 2.17.1 - Bug fixes - Enforce email 2fa if joining org with policy using SSO - SSO for Desktop and CLI fail (and Directory Connector) - SSO for Browser Extension fails 2.18.0 - New Features - Encrypted Export - Emergency Access - Personal Ownership Policy - Custom Roles and Permissions for Organization users - Changes - Minor UI tweaks - Bug Fixes 2.18.1 - Fixed full text search - New 404 page - Emergency Access fixes - TOTP and password copy fix
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Set-Vault-BaseURL.patch36
-rw-r--r--PKGBUILD12
3 files changed, 41 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd10df3b63f3..b4b69bcd1b5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitwarden_rs-vault
pkgdesc = Integrates the Vault Web-Interface into bitwarden_rs.
- pkgver = 2.16.2
+ pkgver = 2.18.1
pkgrel = 1
url = https://github.com/bitwarden/web
install = bitwarden_rs-vault.install
@@ -13,14 +13,14 @@ pkgbase = bitwarden_rs-vault
depends = bitwarden_rs
conflicts = bitwarden_rs-vault-git
conflicts = bitwarden_rs-vault-bin
- source = https://github.com/bitwarden/web/archive/v2.16.2.tar.gz
- source = https://github.com/bitwarden/jslib/archive/f30d6f8027055507abfdefd1eeb5d9aab25cc601.tar.gz
+ source = https://github.com/bitwarden/web/archive/v2.18.1.tar.gz
+ source = https://github.com/bitwarden/jslib/archive/9ddec9baf8b6e7de58c00744eb371dc68e1b6383.tar.gz
source = 0001-Set-Vault-BaseURL.patch
source = 0002-Disable-Git-Submodule-Commands.patch
source = bitwarden_rs-vault.install
- sha512sums = ffbfa7e2fa5cc47289062a7f1147f26be7312c7f0404235b1756acc776e372ab5525221957ea7cc4a5595409504d8705553425758ba166d210c5255620acc78f
- sha512sums = 1801f91af9a52f0d1364137c40bc2382cc4b683206b73c6effc26ad81c547341b156713617f7c692402b77b8861cfb60ef6b2c3385d5f31a006ac4d53e6e0389
- sha512sums = 4545846940c07216b64df1922b7742ba14fc39c0ca12115f9422125dc4716d9c9d14ce0213213f44ba6fc66a6b49b9ef28bb5943a24920059a634ebb07716634
+ sha512sums = 0dc238afff8db0325cf40bc372321b96faf2d76ea949a9c79231c3c017a8c5527dacc202a8eb85baa430bbb1ca0dee09d23eb18a57da58bbae7b3e30b6750734
+ sha512sums = 48765f82e2ad6b2b00be52905e35dfb8b65577711d0f1887790988b2c5e75f946f8e0c89e539a6057cd90334a4a9afa971f3b6827108d7b694e0f8dcc86545f8
+ sha512sums = 2ef68843f7f20eb506d8f3e3801b54885334f1d5ae774a53732ff693042d0de77bc32434185afdfb9ebb32ca3f66962065b68b7dd16b5bc967c6ffb6db9c168b
sha512sums = adaa6037e59f08a6a44f681c8eab915c0738069989f9d6acbf46e4d3135f69696fa7735a65158979fbc924b27f43bdf255648e615b33495ac7da418e89f27c90
sha512sums = 0b93ea1a442f15ac2445bc0cb759887b0826215edbc73dabb150de8ac136c8712c18b798ff397a06d50989332562a36382b5b7d962e60c2f2619d0f46cf9b04d
diff --git a/0001-Set-Vault-BaseURL.patch b/0001-Set-Vault-BaseURL.patch
index 75609d89c7ae..88240d4507a9 100644
--- a/0001-Set-Vault-BaseURL.patch
+++ b/0001-Set-Vault-BaseURL.patch
@@ -1,5 +1,5 @@
diff --git a/src/app/app.component.ts b/src/app/app.component.ts
-index 6807ec89..62dbe456 100644
+index 51853633..c9b3d48a 100644
--- a/src/app/app.component.ts
+++ b/src/app/app.component.ts
@@ -140,6 +140,10 @@ export class AppComponent implements OnDestroy, OnInit {
@@ -14,10 +14,10 @@ index 6807ec89..62dbe456 100644
break;
case 'analyticsEventTrack':
diff --git a/src/app/services/services.module.ts b/src/app/services/services.module.ts
-index e64240ad..025fdef1 100644
+index 3e4d8dfa..f5bf60e4 100644
--- a/src/app/services/services.module.ts
+++ b/src/app/services/services.module.ts
-@@ -127,24 +127,32 @@ const environmentService = new EnvironmentService(apiService, storageService, no
+@@ -135,24 +135,32 @@ const environmentService = new EnvironmentService(apiService, storageService, no
const auditService = new AuditService(cryptoFunctionService, apiService);
const eventLoggingService = new EventLoggingService(storageService, apiService, userService, cipherService);
@@ -74,10 +74,10 @@ index 5560c476..a9b954a8 100644
this.ngZone.run(() => {
this.u2fListening = false;
diff --git a/src/scss/styles.scss b/src/scss/styles.scss
-index 676e275f..ba9888fc 100644
+index 55b3c92c..c48e2baf 100644
--- a/src/scss/styles.scss
+++ b/src/scss/styles.scss
-@@ -1,5 +1,34 @@
+@@ -1,5 +1,56 @@
@import "../css/webfonts.css";
+/**** START Bitwarden_RS CHANGES ****/
@@ -93,6 +93,9 @@ index 676e275f..ba9888fc 100644
+/* Hide any link pointing to subscriptions */
+a[href$="/settings/subscription"] { @extend %bwrs-hide; }
+
++/* Hide any link pointing to emergency access */
++a[href$="/settings/emergency-access"] { @extend %bwrs-hide; }
++
+/* Hide the `Enterprise Single Sign-On` button on the login page */
+a[href$="/sso"] { @extend %bwrs-hide; }
+
@@ -103,6 +106,25 @@ index 676e275f..ba9888fc 100644
+app-organization-plans > form > div.form-check { @extend %bwrs-hide; }
+app-organization-plans > form > h2.mt-5 { @extend %bwrs-hide; }
+
++/* Hide the `API Key` section under `My Account` */
++app-account > div:nth-child(9),
++app-account > p,
++app-account > button:nth-child(11),
++app-account > button:nth-child(12) {
++ @extend %bwrs-hide;
++}
++
++/* Hide the radio button and label for the `Custom` org user type */
++#userTypeCustom, label[for^=userTypeCustom] {
++ @extend %bwrs-hide;
++}
++
++/* Hide the warning that policy config is moving to Business Portal */
++app-org-policies > app-callout { @extend %bwrs-hide; }
++
++/* Hide `Single Organization` policy */
++app-org-policies > table > tbody > tr:nth-child(4) { @extend %bwrs-hide; }
++
+/* Hide Tax Info and Form in Organization settings */
+app-org-account > div.secondary-header:nth-child(3) { @extend %bwrs-hide; }
+app-org-account > div.secondary-header:nth-child(3) + p { @extend %bwrs-hide; }
@@ -113,10 +135,10 @@ index 676e275f..ba9888fc 100644
$primary-accent: #1252A3;
$secondary: #ced4da;
diff --git a/webpack.config.js b/webpack.config.js
-index 3391d5ff..c4e2c0b5 100644
+index b6da3558..eef05772 100644
--- a/webpack.config.js
+++ b/webpack.config.js
-@@ -176,6 +176,7 @@ const config = {
+@@ -178,6 +178,7 @@ const config = {
},
minimizer: [
new TerserPlugin({
diff --git a/PKGBUILD b/PKGBUILD
index 6120d974c1aa..448af0019b4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Markus Richter <mqus at disroot dot org>
-_jslib_commit="f30d6f8027055507abfdefd1eeb5d9aab25cc601"
+_jslib_commit="9ddec9baf8b6e7de58c00744eb371dc68e1b6383"
pkgname=bitwarden_rs-vault
-pkgver=2.16.2
+pkgver=2.18.1
pkgrel=1
pkgdesc="Integrates the Vault Web-Interface into bitwarden_rs."
arch=('any')
@@ -11,16 +11,16 @@ license=('AGPL3')
# python2 is included because the used npm package node-sass depends on node-gyp (and therefore python2) transitively. This issue should be solved with node-sass >4.14.1.
makedepends=('npm' 'nodejs' 'git' 'python2')
depends=('bitwarden_rs')
-conflicts=("bitwarden_rs-vault-git" "bitwarden_rs-vault-bin")
+conflicts=("${pkgname}-"{git,bin})
install=bitwarden_rs-vault.install
source=("https://github.com/bitwarden/web/archive/v$pkgver.tar.gz"
"https://github.com/bitwarden/jslib/archive/${_jslib_commit}.tar.gz"
"0001-Set-Vault-BaseURL.patch"
"0002-Disable-Git-Submodule-Commands.patch"
"$pkgname.install")
-sha512sums=('ffbfa7e2fa5cc47289062a7f1147f26be7312c7f0404235b1756acc776e372ab5525221957ea7cc4a5595409504d8705553425758ba166d210c5255620acc78f'
- '1801f91af9a52f0d1364137c40bc2382cc4b683206b73c6effc26ad81c547341b156713617f7c692402b77b8861cfb60ef6b2c3385d5f31a006ac4d53e6e0389'
- '4545846940c07216b64df1922b7742ba14fc39c0ca12115f9422125dc4716d9c9d14ce0213213f44ba6fc66a6b49b9ef28bb5943a24920059a634ebb07716634'
+sha512sums=('0dc238afff8db0325cf40bc372321b96faf2d76ea949a9c79231c3c017a8c5527dacc202a8eb85baa430bbb1ca0dee09d23eb18a57da58bbae7b3e30b6750734'
+ '48765f82e2ad6b2b00be52905e35dfb8b65577711d0f1887790988b2c5e75f946f8e0c89e539a6057cd90334a4a9afa971f3b6827108d7b694e0f8dcc86545f8'
+ '2ef68843f7f20eb506d8f3e3801b54885334f1d5ae774a53732ff693042d0de77bc32434185afdfb9ebb32ca3f66962065b68b7dd16b5bc967c6ffb6db9c168b'
'adaa6037e59f08a6a44f681c8eab915c0738069989f9d6acbf46e4d3135f69696fa7735a65158979fbc924b27f43bdf255648e615b33495ac7da418e89f27c90'
'0b93ea1a442f15ac2445bc0cb759887b0826215edbc73dabb150de8ac136c8712c18b798ff397a06d50989332562a36382b5b7d962e60c2f2619d0f46cf9b04d')