summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Wiesinger2024-06-19 21:26:13 +0100
committerManuel Wiesinger2024-06-19 21:26:13 +0100
commitb35dbc2648597bd0a62b466819401f0d960426a0 (patch)
tree4aaa6d88d5fdd4a3f2248c608e5bdf1be8fc87e6
parent1c70d1ff17eeeb814838f08dc3d8f3c04802c913 (diff)
downloadaur-bitwuzla.tar.gz
Move gtest python-pytest to makedepends
Even needed with --nocheck
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6377a4bfae45..39473f274a8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = bitwuzla
pkgdesc = SMT solver for the theories of fixed-size bit-vectors, floating-point arithmetic, arrays and uninterpreted functions and their combinations
pkgver = 0.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://bitwuzla.github.io
arch = x86_64
license = MIT
- checkdepends = gtest
- checkdepends = python-pytest
makedepends = cadical>=1.5.0
makedepends = cmake
makedepends = cython
makedepends = doxygen
+ makedepends = gtest
makedepends = meson>=0.64
makedepends = ninja
makedepends = python-breathe
+ makedepends = python-pytest
makedepends = python-sphinx
makedepends = python-sphinx-tabs
makedepends = python-sphinx_rtd_theme
diff --git a/PKGBUILD b/PKGBUILD
index da0510fcc4cf..c81537f3c4a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=bitwuzla
pkgname=("${pkgbase}" "${pkgbase}-doc")
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc='SMT solver for the theories of fixed-size bit-vectors, floating-point arithmetic, arrays and uninterpreted functions and their combinations'
arch=('x86_64')
url='https://bitwuzla.github.io'
@@ -18,9 +18,11 @@ makedepends=(
'cmake'
'cython'
'doxygen'
+ 'gtest' # Needed even with --nocheck
'meson>=0.64'
'ninja'
'python-breathe'
+ 'python-pytest' # Needed even with --nocheck
'python-sphinx'
'python-sphinx-tabs'
'python-sphinx_rtd_theme'
@@ -28,7 +30,6 @@ makedepends=(
'python>=3.7'
'symfpu-cvc5'
)
-checkdepends=('gtest' 'python-pytest')
optdepends=(
'cryptominisat5: Support for the CryptoMiniSat SAT solver'
'python>=3.7: Python bindings'