summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2023-05-22 21:40:09 -0400
committerPatrick Northon2023-05-22 21:40:09 -0400
commit4fbd57fb084eec709ea1299725294a15bf536ad5 (patch)
tree4954dfcf77087c62f9a35994394f725ba79b81fa
parentdb8e8658a834e02a8a67fd3c6fc323667375b49d (diff)
downloadaur-blackvoxel.tar.gz
Update URL, move data dir and remove install file.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--blackvoxel.install11
3 files changed, 7 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10fdb41dfa84..87d82a89308e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,15 +2,14 @@ pkgbase = blackvoxel
pkgdesc = Game of automation and programming in a voxel world
pkgver = 2.5
pkgrel = 1
- url = http://www.blackvoxel.com/
- install = blackvoxel.install
+ url = https://www.blackvoxel.com/
arch = x86_64
license = GPL3
depends = glew
depends = hicolor-icon-theme
depends = mesa
depends = sdl
- source = blackvoxel-2.5.tar.bz2::http://www.blackvoxel.com//dm_download.php?file=170&key=1
+ source = blackvoxel-2.5.tar.bz2::https://www.blackvoxel.com//dm_download.php?file=170&key=1
sha256sums = 357fc6f4be66401b52fbbf3db8ab7b4293a3e7b3332a01f99c990d1ec36c6996
pkgname = blackvoxel
diff --git a/PKGBUILD b/PKGBUILD
index 45e8f0851fbb..03e5be7b8841 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,18 @@ pkgver=2.5
pkgrel=1
pkgdesc="Game of automation and programming in a voxel world"
arch=('x86_64')
-url='http://www.blackvoxel.com/'
+url='https://www.blackvoxel.com/'
license=('GPL3')
depends=('glew' 'hicolor-icon-theme' 'mesa' 'sdl')
-install="${pkgname}.install"
_srcdir="${pkgname}_source_2_50"
source=("${pkgname}-${pkgver}.tar.bz2::${url}/dm_download.php?file=170&key=1")
sha256sums=('357fc6f4be66401b52fbbf3db8ab7b4293a3e7b3332a01f99c990d1ec36c6996')
+_datadir="/usr/share/games/${pkgname}"
+
build() {
cd "${_srcdir}"
- make BV_DATA_LOCATION_DIR="/usr/share/${pkgname}" installable
+ make BV_DATA_LOCATION_DIR="${_datadir}" installable
}
package() {
@@ -24,7 +25,7 @@ package() {
make install \
doinstall=true \
DESTDIR="${pkgdir}" \
- BV_DATA_INSTALL_DIR="/usr/share/${pkgname}" \
+ BV_DATA_INSTALL_DIR="${_datadir}" \
BV_BINARY_INSTALL_DIR='/usr/bin' \
icondir2='/usr/share/icons/' \
desktopdir='/usr/share/applications/'
diff --git a/blackvoxel.install b/blackvoxel.install
deleted file mode 100644
index 5be14e68d10a..000000000000
--- a/blackvoxel.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install () {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade () {
- post_install
-}
-
-post_remove() {
- post_install
-}