aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-10-08 15:11:08 +0200
committerbartus2019-10-08 15:11:08 +0200
commit1b0dd1d97a79375987ef2a02c123d9622a0a077a (patch)
treeef4261d9f83c1c8a50e4ba25edc93e57c4072ef1
parentad187da36fd5fb114262d3b8812214c0e88e2bec (diff)
downloadaur-1b0dd1d97a79375987ef2a02c123d9622a0a077a.tar.gz
Travis: drop optix (download to painful)
-rw-r--r--.travis.yml9
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 9 deletions
diff --git a/.travis.yml b/.travis.yml
index 15bbc3e1cae5..0ad938e71f12 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -33,13 +33,11 @@ archlinux:
- cuda
- moreutils
- oidn
- - optix
before_install:
# 1.Override `package-cleanup.hook` to preserve cache for travis.
# 2.Enable ccache
# 3.Multithreaded build and compress
# 4.Suppress all gcc warnings
-# 5.Put optix in yay cache
- |
sudo mkdir /etc/pacman.d/hooks/
sudo ln -s /dev/null /etc/pacman.d/hooks/package-cleanup.hook
@@ -48,7 +46,6 @@ archlinux:
sudo sed -i '/^COMPRESSXZ/s/\xz/xz -T 2/' /etc/makepkg.conf
sudo sed -i '$a CFLAGS="$CFLAGS -w"' /etc/makepkg.conf
sudo sed -i '$a CXXFLAGS="$CXXFLAGS -w"' /etc/makepkg.conf
- mkdir -p ~/.cache/yay/optix && cp /var/cache/pacman/pkg/NVIDIA-OptiX-SDK-7.0.0-linux64.sh ~/.cache/yay/optix
script:
# Normalize TRAVIS variable
- |
@@ -60,7 +57,7 @@ archlinux:
- ccache -s
- ccache -z
# set timeout to 50m minus current uptime, minus travis cache in time, minus 60 second buffer for arch-travis cleanup.
- - timeout $((50*60-arch_uptime-travis_uptime-60)) makepkg -s --noconfirm > >(ts -s '%.T'); _makepkg_return=$?
+ - timeout $((50*60-arch_uptime-travis_uptime-60)) makepkg -s --noconfirm DISABLE_OPTIX=1 > >(ts -s '%.T'); _makepkg_return=$?
- sudo pacman -Sc --noconfirm
- ccache -s
- ccache -z
@@ -68,10 +65,6 @@ archlinux:
script:
- "export travis_uptime=$(cut -d' ' -f1 /proc/uptime|cut -d'.' -f1)"
- 'echo "Travis initialization time: $travis_uptime seconds"'
-#- 'curl -Ls "https://developer.download.nvidia.com/designworks/optix/secure/7.0.0/ga/NVIDIA-OptiX-SDK-7.0.0-linux64.sh?LOhihLF99zzm6EAXMViu7GfZXfW8lN6IaQ-KhJwHgWx1-tIBMUjiwjPKBvB_585iVoKU9spDrpIHyyWnb9AarWCf2Kgv5nwpJfg9ai4DbsTRYtEmFfTSCo04t0idjs6Wfh-dtfbbrkAHIF_1vx5AvrS5DeQCt2jbLxKADQ8WOm9qpw" > ~/.pkg-cache/NVIDIA-OptiX-SDK-7.0.0-linux64.sh'
-#- 'chmod -w ~/.pkg-cache/NVIDIA-OptiX-SDK-7.0.0-linux64.sh'
-#- 'du -h ~/.pkg-cache/NVIDIA-OptiX-SDK-7.0.0-linux64.sh'
-- 'head ~/.pkg-cache/NVIDIA-OptiX-SDK-7.0.0-linux64.sh'
# assume caching out will take the same amount of time as caching in those making build time equal to 50 minutes minus two time current uptime.
- "curl -s https://raw.githubusercontent.com/bartoszek/arch-travis/master/arch-travis.sh| timeout $((50*60-2*travis_uptime)) bash"
- "echo pacman pkg cache size: $(du -h ~/.pkg-cache|cut -f1) in $(ls ~/.pkg-cache|wc -l) files"
diff --git a/PKGBUILD b/PKGBUILD
index 034b9b05d0f5..6202c89eaf1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ depends=('alembic' 'libgl' 'python' 'python-numpy' 'openjpeg' 'desktop-file-util
'openvdb' 'opencollada' 'opensubdiv' 'openshadinglanguage' 'libtiff' 'libpng')
makedepends=('git' 'cmake' 'boost' 'mesa' 'llvm')
((DISABLE_NINJA)) || makedepends+=('ninja')
-((DISABLE_CUDA)) && optdepends=('cuda: CUDA support in Cycles') || makedepends+=('cuda' 'optix>=7.0')
+((DISABLE_CUDA)) && optdepends=('cuda: CUDA support in Cycles') || { makedepends+=('cuda') ; ((DISABLE_OPTIX)) || makedepends+=('optix>=7.0'); }
provides=('blender-2.81')
conflicts=('blender-2.81')
license=('GPL')