aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-05-19 20:07:47 +0200
committerbartus2018-05-19 20:07:47 +0200
commite175f79fa7e66b0f93d16b736ecc0e9de7dafc24 (patch)
treec5cf6d252613c5cb50c1bdb830fd568bf3bd0efa
parentd880e753d1b7b8d59ef8ae2e3a9cf37e7da02d97 (diff)
downloadaur-e175f79fa7e66b0f93d16b736ecc0e9de7dafc24.tar.gz
add alembic, fix audaspace ffmpeg, turn off legacy modules
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--ffmpeg.patch39
3 files changed, 53 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5a8c57c18b2..aeece8253e2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blender-2.8-git
pkgdesc = Development version of Blender 2.8 branch
- pkgver = 2.8_r74789.cd6daea7d32
- pkgrel = 2
+ pkgver = 2.8_r76530.0492e56fece
+ pkgrel = 1
url = http://blender.org/
install = blender.install
arch = i686
@@ -12,8 +12,11 @@ pkgbase = blender-2.8-git
makedepends = boost
makedepends = mesa
makedepends = llvm
+ depends = alembic
depends = libgl
depends = python
+ depends = python-numpy
+ depends = openjpeg
depends = desktop-file-utils
depends = hicolor-icon-theme
depends = ffmpeg
@@ -39,6 +42,7 @@ pkgbase = blender-2.8-git
source = blender-dev-tools.git::git://git.blender.org/blender-dev-tools.git
source = blender-2.8.desktop
source = SelectCudaComputeArch.patch
+ source = ffmpeg.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
@@ -46,6 +50,7 @@ pkgbase = blender-2.8-git
md5sums = SKIP
md5sums = cd108dca1c77607c6a7cc45aa284ea97
md5sums = 9454ff7e994f72ead5027356e227cbd2
+ md5sums = 9d4bfb5b3dd33e95b13cc6c7d9d2d2e1
pkgname = blender-2.8-git
diff --git a/PKGBUILD b/PKGBUILD
index da17076abead..f94b25880d66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=blender-2.8-git
-pkgver=2.8_r74789.cd6daea7d32
-pkgrel=2
+pkgver=2.8_r76530.0492e56fece
+pkgrel=1
pkgdesc="Development version of Blender 2.8 branch"
arch=('i686' 'x86_64')
url="http://blender.org/"
-depends=('libgl' 'python' 'desktop-file-utils' 'hicolor-icon-theme'
+depends=('alembic' 'libgl' 'python' 'python-numpy' 'openjpeg' 'desktop-file-utils' 'hicolor-icon-theme'
'ffmpeg' 'fftw' 'openal' 'freetype2' 'libxi' 'openimageio' 'opencolorio'
'openvdb' 'opencollada' 'opensubdiv' 'openshadinglanguage' 'libtiff' 'libpng')
optdepends=('cuda: CUDA support in Cycles')
@@ -28,6 +28,7 @@ source=('git://git.blender.org/blender.git#branch=blender2.8' \
'blender-dev-tools.git::git://git.blender.org/blender-dev-tools.git' \
blender-2.8.desktop \
SelectCudaComputeArch.patch \
+ ffmpeg.patch \
)
md5sums=('SKIP'
'SKIP'
@@ -36,7 +37,7 @@ md5sums=('SKIP'
'SKIP'
'cd108dca1c77607c6a7cc45aa284ea97'
'9454ff7e994f72ead5027356e227cbd2'
- )
+ '9d4bfb5b3dd33e95b13cc6c7d9d2d2e1')
# determine whether we can precompile CUDA kernels
_CUDA_PKG=`pacman -Qq cuda 2>/dev/null` || true
@@ -57,6 +58,7 @@ prepare() {
git submodule foreach git checkout master
git submodule foreach git pull --rebase origin master
git apply ${srcdir}/SelectCudaComputeArch.patch
+ git apply ${srcdir}/ffmpeg.patch
}
build() {
@@ -72,8 +74,7 @@ build() {
cmake "$srcdir/blender" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DWITH_INSTALL_PORTABLE=OFF \
- -DWITH_GAMEENGINE=ON \
- -DWITH_PLAYER=OFF \
+ -DWITH_ALEMBIC=NO \
-DWITH_OPENCOLORIO=ON \
-DWITH_FFTW3=ON \
-DWITH_SYSTEM_GLEW=ON \
diff --git a/ffmpeg.patch b/ffmpeg.patch
new file mode 100644
index 000000000000..94ffa7eba914
--- /dev/null
+++ b/ffmpeg.patch
@@ -0,0 +1,39 @@
+diff --git a/extern/audaspace/CMakeLists.txt b/extern/audaspace/CMakeLists.txt
+index 9e2921ef35a..67f8ada7802 100644
+--- a/extern/audaspace/CMakeLists.txt
++++ b/extern/audaspace/CMakeLists.txt
+@@ -412,6 +412,10 @@ if(WITH_FFMPEG)
+ plugins/ffmpeg/FFMPEGWriter.h
+ )
+
++ list(APPEND INC
++ ../../intern/ffmpeg
++ )
++
+ if(NOT PLUGIN_FFMPEG)
+ list(APPEND INCLUDE ${FFMPEG_INCLUDE_DIRS})
+ list(APPEND LIBRARIES ${FFMPEG_LIBRARIES})
+diff --git a/extern/audaspace/plugins/ffmpeg/FFMPEGReader.cpp b/extern/audaspace/plugins/ffmpeg/FFMPEGReader.cpp
+index 6b79cc5abfd..5e9ec29f302 100644
+--- a/extern/audaspace/plugins/ffmpeg/FFMPEGReader.cpp
++++ b/extern/audaspace/plugins/ffmpeg/FFMPEGReader.cpp
+@@ -16,6 +16,7 @@
+
+ #include "FFMPEGReader.h"
+ #include "Exception.h"
++#include "../../../../intern/ffmpeg/ffmpeg_compat.h"
+
+ #include <algorithm>
+
+diff --git a/extern/audaspace/plugins/ffmpeg/FFMPEGWriter.cpp b/extern/audaspace/plugins/ffmpeg/FFMPEGWriter.cpp
+index f79f0f7fc6b..6b89a83613c 100644
+--- a/extern/audaspace/plugins/ffmpeg/FFMPEGWriter.cpp
++++ b/extern/audaspace/plugins/ffmpeg/FFMPEGWriter.cpp
+@@ -16,6 +16,7 @@
+
+ #include "FFMPEGWriter.h"
+ #include "Exception.h"
++#include "../../../../intern/ffmpeg/ffmpeg_compat.h"
+
+ #include <algorithm>
+ #include <cstring>