summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2016-06-18 15:14:34 +0200
committerÓscar García Amor2016-06-18 15:14:34 +0200
commit59a4fc12b9d2dfb2e47755cf28c56d2e7eafd92c (patch)
treefbe20cc8e9894b9cb0ecee3a6b28a5f8b301c01c
downloadaur-59a4fc12b9d2dfb2e47755cf28c56d2e7eafd92c.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..802f38741548
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = blink
+ pkgdesc = A state of the art, easy to use SIP client
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://icanblink.com
+ arch = any
+ license = GPL3
+ license = FreeBSD
+ depends = cython2
+ depends = icu
+ depends = libvncserver
+ depends = python2-application
+ depends = python2-cjson
+ depends = python2-eventlib
+ depends = python2-gmpy2
+ depends = python2-gnutls
+ depends = python2-pyqt4
+ depends = python2-sip
+ depends = python2-sipsimple
+ depends = python2-zope-interface
+ source = https://github.com/AGProjects/blink-qt/archive/release-2.0.0/blink-qt-2.0.0.tar.gz
+ sha256sums = 28cb43a4030eed444c45af8bbc627b8fe60523847c1db53337f4d4ebbd8bca2a
+
+pkgname = blink
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..444423a05c01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
+
+pkgname='blink'
+_reponame='blink-qt'
+pkgver='2.0.0'
+pkgrel='1'
+pkgdesc='A state of the art, easy to use SIP client'
+arch=('any')
+url='http://icanblink.com'
+license=('GPL3' 'FreeBSD')
+depends=('cython2'
+ 'icu'
+ 'libvncserver'
+ 'python2-application'
+ 'python2-cjson'
+ 'python2-eventlib'
+ 'python2-gmpy2'
+ 'python2-gnutls'
+ 'python2-pyqt4'
+ 'python2-sip'
+ 'python2-sipsimple'
+ 'python2-zope-interface')
+
+source=("https://github.com/AGProjects/${_reponame}/archive/release-${pkgver}/${_reponame}-${pkgver}.tar.gz")
+sha256sums=('28cb43a4030eed444c45af8bbc627b8fe60523847c1db53337f4d4ebbd8bca2a')
+
+build() {
+ cd ${srcdir}/${_reponame}-release-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_reponame}-release-${pkgver}
+ python2 setup.py install --root="${pkgdir}"
+
+ # license
+ install -Dm644 LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+
+ # desktop file
+ install -Dm644 ${srcdir}/${_reponame}-release-${pkgver}/debian/${pkgname}.desktop \
+ ${pkgdir}/usr/share/applications/${pkgname}.desktop
+}