summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Lopes2022-01-26 22:12:51 +0000
committerJose Lopes2022-01-26 22:12:51 +0000
commit6f0026ccddb269cad1ac8721c5182528e2566de7 (patch)
tree1dcb59c3d1681a403868d1c35a7809c6fb32d881
parentefc6043170d1521f9b997840821b22505560d7ae (diff)
downloadaur-6f0026ccddb269cad1ac8721c5182528e2566de7.tar.gz
Solve issues with python 3.10
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--fix_MutableSet.patch12
-rw-r--r--fix_for_python310.patch106
4 files changed, 113 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4e0a1aa342d..991afa6b5a45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blink
pkgdesc = Fully featured, easy to use SIP client with a Qt based UI
pkgver = 5.1.8
- pkgrel = 2
+ pkgrel = 3
url = https://icanblink.com
arch = aarch64
arch = x86_64
@@ -20,8 +20,8 @@ pkgbase = blink
depends = qt5-webkit
optdepends = x11vnc: for screen sharing
source = blink-5.1.8.tar.gz::https://github.com/AGProjects/blink-qt/archive/a54013c11bee521a224c81c021e1bf453320ca79.tar.gz
- source = fix_MutableSet.patch
+ source = fix_for_python310.patch
b2sums = 7b0feab275f4c2abecb86784ce134aad7ef0129fc61aad7ef3ceb4ead61f1f7b0959e13faa4bfcb0705341e3d101034371f7714a14996e046ceffc96a3bbc878
- b2sums = 1560c07c3ca8fecc1a47f793b06150cb3c4375a96f79e667202f13830d041cd318b024c6062e27e9a8f92c077b77a5095e0741a25b81a69378457959e1e4954d
+ b2sums = 7f4d6ea14a19a0f5e120855621a5e275303abc8924b0047ea0db3b4dda11cdf501a809c0723708751faef6d3d05a469bfa21050dcddeeb7d71ecaff82b48b0ee
pkgname = blink
diff --git a/PKGBUILD b/PKGBUILD
index 0acbdcc0440f..33225cbd4f82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=blink-qt
pkgname=blink
pkgver=5.1.8
-pkgrel=2
+pkgrel=3
pkgdesc='Fully featured, easy to use SIP client with a Qt based UI'
arch=('aarch64' 'x86_64')
url='https://icanblink.com'
@@ -25,15 +25,15 @@ depends=(
)
optdepends=('x11vnc: for screen sharing')
_commit=a54013c11bee521a224c81c021e1bf453320ca79 # 5.1.8
-source=("$pkgname-$pkgver.tar.gz::https://github.com/AGProjects/${_pkgname}/archive/$_commit.tar.gz" 'fix_MutableSet.patch')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/AGProjects/${_pkgname}/archive/$_commit.tar.gz" 'fix_for_python310.patch')
b2sums=(
'7b0feab275f4c2abecb86784ce134aad7ef0129fc61aad7ef3ceb4ead61f1f7b0959e13faa4bfcb0705341e3d101034371f7714a14996e046ceffc96a3bbc878'
- '1560c07c3ca8fecc1a47f793b06150cb3c4375a96f79e667202f13830d041cd318b024c6062e27e9a8f92c077b77a5095e0741a25b81a69378457959e1e4954d'
+ '7f4d6ea14a19a0f5e120855621a5e275303abc8924b0047ea0db3b4dda11cdf501a809c0723708751faef6d3d05a469bfa21050dcddeeb7d71ecaff82b48b0ee'
)
prepare() {
cd $_pkgname-$_commit
- patch --forward --strip=1 --input="${srcdir}/fix_MutableSet.patch"
+ patch --forward --strip=1 --input="${srcdir}/fix_for_python310.patch"
}
build() {
diff --git a/fix_MutableSet.patch b/fix_MutableSet.patch
deleted file mode 100644
index dcd1043ded9a..000000000000
--- a/fix_MutableSet.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- blink-git/blink/chatwindow.py.orig 2021-12-20 11:46:36.793749556 +0000
-+++ blink-git/blink/chatwindow.py 2021-12-20 11:47:01.243794043 +0000
-@@ -18,7 +18,8 @@
- from application.python.descriptor import WriteOnceAttribute
- from application.python.types import MarkerType
- from application.system import makedirs
--from collections import MutableSet, deque
-+from collections.abc import MutableSet
-+from collections import deque
- from datetime import datetime, timedelta
- from itertools import count
- from lxml import etree, html
diff --git a/fix_for_python310.patch b/fix_for_python310.patch
new file mode 100644
index 000000000000..15cf45a09190
--- /dev/null
+++ b/fix_for_python310.patch
@@ -0,0 +1,106 @@
+diff --git a/blink/chatwindow.py b/blink/chatwindow.py
+index e55f590..40da6de 100644
+--- a/blink/chatwindow.py
++++ b/blink/chatwindow.py
+@@ -18,7 +18,8 @@ from application.python import Null, limit
+ from application.python.descriptor import WriteOnceAttribute
+ from application.python.types import MarkerType
+ from application.system import makedirs
+-from collections import MutableSet, deque
++from collections.abc import MutableSet
++from collections import deque
+ from datetime import datetime, timedelta
+ from itertools import count
+ from lxml import etree, html
+diff --git a/blink/sessions.py b/blink/sessions.py
+index 9805515..9928831 100644
+--- a/blink/sessions.py
++++ b/blink/sessions.py
+@@ -5094,13 +5094,13 @@ class IncomingDialogBase(QDialog):
+ total_width = width + window_frame_size.width()
+ total_height = height + window_frame_size.height()
+
+- x = limit(screen_geometry.center().x() - total_width/2, min=available_geometry.left(), max=available_geometry.right()-total_width)
++ x = int(limit(screen_geometry.center().x() - total_width/2, min=available_geometry.left(), max=available_geometry.right()-total_width))
+ if slot is None:
+ y = -1
+ elif slot % 2 == 0:
+- y = screen_geometry.center().y() + (slot-1)*total_height/2
++ y = int(screen_geometry.center().y() + (slot-1)*total_height/2)
+ else:
+- y = screen_geometry.center().y() - slot*total_height/2
++ y = int(screen_geometry.center().y() - slot*total_height/2)
+
+ if available_geometry.top() <= y <= available_geometry.bottom() - total_height:
+ self.setGeometry(x, y, width, height)
+diff --git a/blink/widgets/buttons.py b/blink/widgets/buttons.py
+index c3b18bf..72aefd5 100644
+--- a/blink/widgets/buttons.py
++++ b/blink/widgets/buttons.py
+@@ -620,8 +620,8 @@ class StateButton(QToolButton):
+ return pixmap
+
+ size = max(pixmap.width(), pixmap.height())
+- offset_x = (size - pixmap.width())/2
+- offset_y = (size - pixmap.height())/2
++ offset_x = int((size - pixmap.width())/2)
++ offset_y = int((size - pixmap.height())/2)
+
+ new_pixmap = QPixmap(size, size)
+ new_pixmap.fill(Qt.transparent)
+diff --git a/blink/widgets/lineedit.py b/blink/widgets/lineedit.py
+index ee63e81..f03ac54 100644
+--- a/blink/widgets/lineedit.py
++++ b/blink/widgets/lineedit.py
+@@ -68,13 +68,13 @@ class LineEdit(QLineEdit):
+ text_rect.adjust(spacing, 0, -spacing, 0)
+ mid_height = text_rect.center().y() + 1 - (text_rect.height() % 2) # need -1 correction for odd heights -Dan
+ if self.left_layout.count() > 0:
+- left_height = mid_height - self.left_widget.height()/2
++ left_height = int(mid_height - self.left_widget.height()/2)
+ left_width = self.left_widget.width()
+ if left_width == 0:
+- left_height = mid_height - self.left_widget.sizeHint().height()/2
++ left_height = int(mid_height - self.left_widget.sizeHint().height()/2)
+ self.left_widget.move(text_rect.x(), left_height)
+ text_rect.setX(self.left_margin)
+- text_rect.setY(mid_height - self.right_widget.sizeHint().height()/2.0)
++ text_rect.setY(int(mid_height - self.right_widget.sizeHint().height()/2.0))
+ text_rect.setHeight(self.right_widget.sizeHint().height())
+ self.right_widget.setGeometry(text_rect)
+
+@@ -201,8 +201,8 @@ class SearchIcon(QWidget):
+ def paintEvent(self, event):
+ painter = QPainter(self)
+ if self.icon is not None:
+- x = (self.width() - self.icon.width()) / 2
+- y = (self.height() - self.icon.height()) / 2
++ x = int((self.width() - self.icon.width()) / 2)
++ y = int((self.height() - self.icon.height()) / 2)
+ painter.drawPixmap(x, y, self.icon)
+
+
+@@ -232,8 +232,8 @@ class ClearButton(QAbstractButton):
+ painter = QPainter(self)
+ icon = self.icon_pressed if self.isDown() else self.icon
+ if icon is not None:
+- x = (self.width() - icon.width()) / 2
+- y = (self.height() - icon.height()) / 2
++ x = int((self.width() - icon.width()) / 2)
++ y = int((self.height() - icon.height()) / 2)
+ painter.drawPixmap(x, y, icon)
+ else:
+ width = self.width()
+diff --git a/blink/widgets/video.py b/blink/widgets/video.py
+index eff4f7c..5ecab6a 100644
+--- a/blink/widgets/video.py
++++ b/blink/widgets/video.py
+@@ -56,7 +56,7 @@ class VideoSurface(QWidget):
+ self.cursors.resize_bottom = QCursor(QIcon(Resources.get('icons/resize-bottom.svg')).pixmap(16), hotX=8, hotY=16)
+ if framerate is not None:
+ self._clock = QTimer()
+- self._clock.setInterval(1000/framerate)
++ self._clock.setInterval(int(1000/framerate))
+ self._clock.timeout.connect(self.update)
+ else:
+ self._clock = None