summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Lopes2023-06-14 19:50:34 +0100
committerJose Lopes2023-06-14 19:50:34 +0100
commita7b56db0a663dbe76b7ff48740173158fca8db71 (patch)
tree535a91ef35a3b16ea2b7d7fb61693170e937472d
parentd5cce290146fd4e4b0a5663648f288a0b4d6dee9 (diff)
downloadaur-a7b56db0a663dbe76b7ff48740173158fca8db71.tar.gz
Update to version 5.5.1
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
3 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cbfc767ac21..d0e326871650 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = blink
pkgdesc = Fully featured, easy to use SIP client with a Qt based UI
- pkgver = 5.5.0
- pkgrel = 2
+ pkgver = 5.5.1
+ pkgrel = 1
url = https://icanblink.com
arch = aarch64
arch = x86_64
license = GPL-3+
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = icu
depends = libvncserver
depends = python-application
@@ -28,7 +31,7 @@ pkgbase = blink
depends = qt5-svg
depends = qt5-webkit
optdepends = x11vnc: for screen sharing
- source = blink-5.5.0.tar.gz::https://github.com/AGProjects/blink-qt/archive/5.5.0.tar.gz
- b2sums = 3fca90bfd78e747c6bd3c46c7ca9a064b3bbd7fb44e51d79d2820f3a516783b499bb836e9620cbb4c3c2fb74dc475ab01f28840f71bc901c1a714bbbd16f1182
+ source = blink-5.5.1.tar.gz::https://github.com/AGProjects/blink-qt/archive/5.5.1.tar.gz
+ b2sums = 866dd26e3e729e1f4b7072e8a6d03f71b676a9191036f266c6243ea12c33d92b6a497509ca7c7d96bf46dd069bebe611b122107f89133aa141a992057bd43e13
pkgname = blink
diff --git a/.gitignore b/.gitignore
index 96b8d2e11375..c447acddfb79 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
*.tar.zst
src/
pkg/
+.build \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 371ba1997d2d..9e0a43cdfeec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
_pkgname=blink-qt
pkgname=blink
-pkgver=5.5.0
-pkgrel=2
+pkgver=5.5.1
+pkgrel=1
pkgdesc='Fully featured, easy to use SIP client with a Qt based UI'
arch=('aarch64' 'x86_64')
url='https://icanblink.com'
license=('GPL-3+')
+makedepends=('python-build' 'python-installer' 'python-wheel')
depends=(
'icu'
'libvncserver'
@@ -36,17 +37,17 @@ depends=(
optdepends=('x11vnc: for screen sharing')
source=("$pkgname-$pkgver.tar.gz::https://github.com/AGProjects/${_pkgname}/archive/${pkgver}.tar.gz")
b2sums=(
- '3fca90bfd78e747c6bd3c46c7ca9a064b3bbd7fb44e51d79d2820f3a516783b499bb836e9620cbb4c3c2fb74dc475ab01f28840f71bc901c1a714bbbd16f1182'
+ '866dd26e3e729e1f4b7072e8a6d03f71b676a9191036f266c6243ea12c33d92b6a497509ca7c7d96bf46dd069bebe611b122107f89133aa141a992057bd43e13'
)
build() {
cd $_pkgname-$pkgver
- python3 setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $_pkgname-$pkgver
- python3 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
# license
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"