summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Lopes2022-07-20 18:11:24 +0100
committerJose Lopes2022-07-20 18:12:26 +0100
commite0fb6e68acde99fb46d266c4746e0d83591ecdd9 (patch)
tree41aa73508add1ba728d3ec76232bb25b8bed442c
parent6f0026ccddb269cad1ac8721c5182528e2566de7 (diff)
downloadaur-e0fb6e68acde99fb46d266c4746e0d83591ecdd9.tar.gz
Update to version 5.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--fix_for_python310.patch106
3 files changed, 14 insertions, 125 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 991afa6b5a45..1f4991626559 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blink
pkgdesc = Fully featured, easy to use SIP client with a Qt based UI
- pkgver = 5.1.8
- pkgrel = 3
+ pkgver = 5.2.0
+ pkgrel = 1
url = https://icanblink.com
arch = aarch64
arch = x86_64
@@ -16,12 +16,12 @@ pkgbase = blink
depends = python-pyqt5
depends = python-service-identity
depends = python-sipsimple
+ depends = python-formencode
+ depends = python-sqlobject
depends = qt5-svg
depends = qt5-webkit
optdepends = x11vnc: for screen sharing
- source = blink-5.1.8.tar.gz::https://github.com/AGProjects/blink-qt/archive/a54013c11bee521a224c81c021e1bf453320ca79.tar.gz
- source = fix_for_python310.patch
- b2sums = 7b0feab275f4c2abecb86784ce134aad7ef0129fc61aad7ef3ceb4ead61f1f7b0959e13faa4bfcb0705341e3d101034371f7714a14996e046ceffc96a3bbc878
- b2sums = 7f4d6ea14a19a0f5e120855621a5e275303abc8924b0047ea0db3b4dda11cdf501a809c0723708751faef6d3d05a469bfa21050dcddeeb7d71ecaff82b48b0ee
+ source = blink-5.2.0.tar.gz::https://github.com/AGProjects/blink-qt/archive/5.2.0.tar.gz
+ b2sums = f414238e1266ac8c5a279d4810b69ff86839a3af5ce35ef6def25dfbae6372cde77c1906101196b2b6630e753134b93417e5045f2c80786b3fe2b139d18126dd
pkgname = blink
diff --git a/PKGBUILD b/PKGBUILD
index 33225cbd4f82..13b7bc512bc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=blink-qt
pkgname=blink
-pkgver=5.1.8
-pkgrel=3
+pkgver=5.2.0
+pkgrel=1
pkgdesc='Fully featured, easy to use SIP client with a Qt based UI'
arch=('aarch64' 'x86_64')
url='https://icanblink.com'
@@ -20,29 +20,24 @@ depends=(
'python-pyqt5'
'python-service-identity'
'python-sipsimple'
+ 'python-formencode'
+ 'python-sqlobject'
'qt5-svg'
'qt5-webkit'
)
optdepends=('x11vnc: for screen sharing')
-_commit=a54013c11bee521a224c81c021e1bf453320ca79 # 5.1.8
-source=("$pkgname-$pkgver.tar.gz::https://github.com/AGProjects/${_pkgname}/archive/$_commit.tar.gz" 'fix_for_python310.patch')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/AGProjects/${_pkgname}/archive/${pkgver}.tar.gz")
b2sums=(
- '7b0feab275f4c2abecb86784ce134aad7ef0129fc61aad7ef3ceb4ead61f1f7b0959e13faa4bfcb0705341e3d101034371f7714a14996e046ceffc96a3bbc878'
- '7f4d6ea14a19a0f5e120855621a5e275303abc8924b0047ea0db3b4dda11cdf501a809c0723708751faef6d3d05a469bfa21050dcddeeb7d71ecaff82b48b0ee'
+ 'f414238e1266ac8c5a279d4810b69ff86839a3af5ce35ef6def25dfbae6372cde77c1906101196b2b6630e753134b93417e5045f2c80786b3fe2b139d18126dd'
)
-prepare() {
- cd $_pkgname-$_commit
- patch --forward --strip=1 --input="${srcdir}/fix_for_python310.patch"
-}
-
build() {
- cd $_pkgname-$_commit
+ cd $_pkgname-$pkgver
python3 setup.py build
}
package() {
- cd $_pkgname-$_commit
+ cd $_pkgname-$pkgver
python3 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
# license
diff --git a/fix_for_python310.patch b/fix_for_python310.patch
deleted file mode 100644
index 15cf45a09190..000000000000
--- a/fix_for_python310.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-diff --git a/blink/chatwindow.py b/blink/chatwindow.py
-index e55f590..40da6de 100644
---- a/blink/chatwindow.py
-+++ b/blink/chatwindow.py
-@@ -18,7 +18,8 @@ from application.python import Null, limit
- from application.python.descriptor import WriteOnceAttribute
- from application.python.types import MarkerType
- from application.system import makedirs
--from collections import MutableSet, deque
-+from collections.abc import MutableSet
-+from collections import deque
- from datetime import datetime, timedelta
- from itertools import count
- from lxml import etree, html
-diff --git a/blink/sessions.py b/blink/sessions.py
-index 9805515..9928831 100644
---- a/blink/sessions.py
-+++ b/blink/sessions.py
-@@ -5094,13 +5094,13 @@ class IncomingDialogBase(QDialog):
- total_width = width + window_frame_size.width()
- total_height = height + window_frame_size.height()
-
-- x = limit(screen_geometry.center().x() - total_width/2, min=available_geometry.left(), max=available_geometry.right()-total_width)
-+ x = int(limit(screen_geometry.center().x() - total_width/2, min=available_geometry.left(), max=available_geometry.right()-total_width))
- if slot is None:
- y = -1
- elif slot % 2 == 0:
-- y = screen_geometry.center().y() + (slot-1)*total_height/2
-+ y = int(screen_geometry.center().y() + (slot-1)*total_height/2)
- else:
-- y = screen_geometry.center().y() - slot*total_height/2
-+ y = int(screen_geometry.center().y() - slot*total_height/2)
-
- if available_geometry.top() <= y <= available_geometry.bottom() - total_height:
- self.setGeometry(x, y, width, height)
-diff --git a/blink/widgets/buttons.py b/blink/widgets/buttons.py
-index c3b18bf..72aefd5 100644
---- a/blink/widgets/buttons.py
-+++ b/blink/widgets/buttons.py
-@@ -620,8 +620,8 @@ class StateButton(QToolButton):
- return pixmap
-
- size = max(pixmap.width(), pixmap.height())
-- offset_x = (size - pixmap.width())/2
-- offset_y = (size - pixmap.height())/2
-+ offset_x = int((size - pixmap.width())/2)
-+ offset_y = int((size - pixmap.height())/2)
-
- new_pixmap = QPixmap(size, size)
- new_pixmap.fill(Qt.transparent)
-diff --git a/blink/widgets/lineedit.py b/blink/widgets/lineedit.py
-index ee63e81..f03ac54 100644
---- a/blink/widgets/lineedit.py
-+++ b/blink/widgets/lineedit.py
-@@ -68,13 +68,13 @@ class LineEdit(QLineEdit):
- text_rect.adjust(spacing, 0, -spacing, 0)
- mid_height = text_rect.center().y() + 1 - (text_rect.height() % 2) # need -1 correction for odd heights -Dan
- if self.left_layout.count() > 0:
-- left_height = mid_height - self.left_widget.height()/2
-+ left_height = int(mid_height - self.left_widget.height()/2)
- left_width = self.left_widget.width()
- if left_width == 0:
-- left_height = mid_height - self.left_widget.sizeHint().height()/2
-+ left_height = int(mid_height - self.left_widget.sizeHint().height()/2)
- self.left_widget.move(text_rect.x(), left_height)
- text_rect.setX(self.left_margin)
-- text_rect.setY(mid_height - self.right_widget.sizeHint().height()/2.0)
-+ text_rect.setY(int(mid_height - self.right_widget.sizeHint().height()/2.0))
- text_rect.setHeight(self.right_widget.sizeHint().height())
- self.right_widget.setGeometry(text_rect)
-
-@@ -201,8 +201,8 @@ class SearchIcon(QWidget):
- def paintEvent(self, event):
- painter = QPainter(self)
- if self.icon is not None:
-- x = (self.width() - self.icon.width()) / 2
-- y = (self.height() - self.icon.height()) / 2
-+ x = int((self.width() - self.icon.width()) / 2)
-+ y = int((self.height() - self.icon.height()) / 2)
- painter.drawPixmap(x, y, self.icon)
-
-
-@@ -232,8 +232,8 @@ class ClearButton(QAbstractButton):
- painter = QPainter(self)
- icon = self.icon_pressed if self.isDown() else self.icon
- if icon is not None:
-- x = (self.width() - icon.width()) / 2
-- y = (self.height() - icon.height()) / 2
-+ x = int((self.width() - icon.width()) / 2)
-+ y = int((self.height() - icon.height()) / 2)
- painter.drawPixmap(x, y, icon)
- else:
- width = self.width()
-diff --git a/blink/widgets/video.py b/blink/widgets/video.py
-index eff4f7c..5ecab6a 100644
---- a/blink/widgets/video.py
-+++ b/blink/widgets/video.py
-@@ -56,7 +56,7 @@ class VideoSurface(QWidget):
- self.cursors.resize_bottom = QCursor(QIcon(Resources.get('icons/resize-bottom.svg')).pixmap(16), hotX=8, hotY=16)
- if framerate is not None:
- self._clock = QTimer()
-- self._clock.setInterval(1000/framerate)
-+ self._clock.setInterval(int(1000/framerate))
- self._clock.timeout.connect(self.update)
- else:
- self._clock = None