summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-21 15:32:48 +0800
committerzxp198210052024-03-21 15:32:48 +0800
commita04ebc93193efc4df0cc4688e3ee853d9f544920 (patch)
treefa14574fcbb18fdf0ccfacea4b511849516bcbbb
parent1a8f7d962f5fd827b395e0da04448fd9cdaeeb0d (diff)
downloadaur-blinker-bin.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--blinker.sh5
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2499f1339af..4c1906226016 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blinker-bin
pkgdesc = Inspired by the 20 20 20 rule, this is a little reminder to look 20 feet away from your screen every 20 minutes. Keep your eyes healthy, reduce eye strain, prevent headaches and increase productivity.
pkgver = 2.1.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/mrkpatchaa/blinker
arch = x86_64
license = CC0-1.0
@@ -12,6 +12,6 @@ pkgbase = blinker-bin
source = blinker-2.1.0.deb::https://github.com/mrkpatchaa/blinker/releases/download/v2.1.0/blinker_2.1.0_amd64.deb
source = blinker.sh
sha256sums = a5d4587f962041b2bd7fa375213e83fcfa6a143a1b7030c2dc2b365654fbdff9
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = blinker-bin
diff --git a/PKGBUILD b/PKGBUILD
index 01047ff3bbe5..7834c027fb7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=blinker-bin
pkgver=2.1.0
_electronversion=28
-pkgrel=4
+pkgrel=5
pkgdesc="Inspired by the 20 20 20 rule, this is a little reminder to look 20 feet away from your screen every 20 minutes. Keep your eyes healthy, reduce eye strain, prevent headaches and increase productivity."
arch=("x86_64")
url="https://github.com/mrkpatchaa/blinker"
@@ -18,11 +18,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('a5d4587f962041b2bd7fa375213e83fcfa6a143a1b7030c2dc2b365654fbdff9'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
}
diff --git a/blinker.sh b/blinker.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/blinker.sh
+++ b/blinker.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file