summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Springer2020-08-12 20:35:24 +0200
committerFelix Springer2020-08-12 20:35:24 +0200
commit79705f861b35f68c8d93b7e644da93e0f814e573 (patch)
tree2cbb9abcb665f3da6d5281b4544589f1c3d59b1e
parente8b74de725d5ebb1f723feddad7c02e6b07ece86 (diff)
downloadaur-79705f861b35f68c8d93b7e644da93e0f814e573.tar.gz
bump version to 0.2.1.1 and use supplied Setup.hs
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--Setup.hs2
3 files changed, 5 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3dd58661b093..7479bc955913 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = blucontrol
pkgdesc = Configurable blue light filter
- pkgver = 0.2.1.0
+ pkgver = 0.2.1.1
pkgrel = 1
url = https://github.com/jumper149/blucontrol
arch = x86_64
@@ -16,12 +16,10 @@ pkgbase = blucontrol
depends = haskell-x11
depends = libx11
depends = libxrandr
- source = https://github.com/jumper149/blucontrol/archive/v0.2.1.0.tar.gz
+ source = https://github.com/jumper149/blucontrol/archive/v0.2.1.1.tar.gz
source = compile-dynamically.patch
- source = Setup.hs
- sha256sums = 131632f6a952cb8325726c368a8fedd670aa7e0c9ce57b4cc7dc00270a4e6f39
+ sha256sums = 6a0f9535de073ab0ae901217d97258cd3c7088a2af424a02cf70c8c89aeb6ba4
sha256sums = 5f535fb64bf4da30547721608039eab4a399547a752dbf405baff36f0c9f6286
- sha256sums = 5066653559d4d6134b022d66a634a17fdcf8db35d28b447e581fec284afa4689
pkgname = blucontrol
diff --git a/PKGBUILD b/PKGBUILD
index 4c8a5d4f5095..61f8f01e069e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Felix Springer <felixspringer149@gmail.com>
pkgname=blucontrol
-pkgver=0.2.1.0
+pkgver=0.2.1.1
pkgrel=1
pkgdesc="Configurable blue light filter"
url="https://github.com/jumper149/${pkgname}"
@@ -23,19 +23,16 @@ depends=(
source=(
"${url}/archive/v${pkgver}.tar.gz"
"compile-dynamically.patch"
- "Setup.hs"
)
sha256sums=(
- '131632f6a952cb8325726c368a8fedd670aa7e0c9ce57b4cc7dc00270a4e6f39'
+ '6a0f9535de073ab0ae901217d97258cd3c7088a2af424a02cf70c8c89aeb6ba4'
'5f535fb64bf4da30547721608039eab4a399547a752dbf405baff36f0c9f6286'
- '5066653559d4d6134b022d66a634a17fdcf8db35d28b447e581fec284afa4689'
)
prepare() {
cd "${pkgname}-${pkgver}"
patch -p1 -i "${srcdir}/compile-dynamically.patch"
- cp "${srcdir}/Setup.hs" "./"
}
build() {
diff --git a/Setup.hs b/Setup.hs
deleted file mode 100644
index 9a994af677b0..000000000000
--- a/Setup.hs
+++ /dev/null
@@ -1,2 +0,0 @@
-import Distribution.Simple
-main = defaultMain