summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Francois Chevrette2019-11-27 00:52:02 -0500
committerJean-Francois Chevrette2019-11-27 00:52:02 -0500
commit4b75062aa5b607ac192229b6ac010e805069f60b (patch)
treefbc6b01efd66e5c7bb87c195969e13ad5befb696
parent3ec78a5819c5eaf1bc023595dd5498631c386fe4 (diff)
downloadaur-4b75062aa5b607ac192229b6ac010e805069f60b.tar.gz
bump to v2.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 654ba10c24eb..82ad600d4ceb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bluejeans
pkgdesc = BlueJeans desktop app for video calls
- pkgver = 1.37.22
+ pkgver = 2.0.0
pkgrel = 1
url = https://www.bluejeans.com
install = bluejeans.install
@@ -62,8 +62,8 @@ pkgbase = bluejeans
depends = wayland
depends = xz
depends = zlib
- source = https://swdl.bluejeans.com/desktop/linux/1.37/1.37.22/bluejeans-1.37.22.x86_64.rpm
- sha256sums = 821fac8ab2fa18a018968143a3ca6f0e1aa2f03e3061676e07e73c2adff80cc2
+ source = https://swdl.bluejeans.com/desktop-app/linux/2.0.0/BlueJeans.rpm
+ sha256sums = c1d213d5556f4238adaba163b2ff35549c66c44a3657377622af9c46112663c7
pkgname = bluejeans
diff --git a/PKGBUILD b/PKGBUILD
index 792885de8a14..44b29cdf3357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# $ curl -s https://bluejeans.com/downloads | grep 'desktop/linux'
pkgname=bluejeans
-pkgver=1.37.22
+pkgver=2.0.0
pkgrel=1
pkgdesc="BlueJeans desktop app for video calls"
arch=('x86_64')
@@ -70,24 +70,16 @@ depends=('alsa-lib'
'xz'
'zlib')
install=bluejeans.install
-source=(https://swdl.bluejeans.com/desktop/linux/${pkgver%.*}/${pkgver}/bluejeans-${pkgver}.x86_64.rpm)
+source=(https://swdl.bluejeans.com/desktop-app/linux/${pkgver}/BlueJeans.rpm)
-sha256sums=('821fac8ab2fa18a018968143a3ca6f0e1aa2f03e3061676e07e73c2adff80cc2')
+sha256sums=('c1d213d5556f4238adaba163b2ff35549c66c44a3657377622af9c46112663c7')
package() {
# add bluejeans wrapper to /usr/bin
mkdir -p "${pkgdir}/usr/bin"
- chmod +x "opt/bluejeans/bluejeans"
- ln -nsf "/opt/bluejeans/bluejeans" "${pkgdir}/usr/bin/bluejeans"
+ ln -nsf "/opt/BlueJeans/bluejeans-v2" "${pkgdir}/usr/bin/bluejeans"
- # install desktop file and icons
- mkdir -p "${pkgdir}/usr/share/applications/"
- mv "opt/bluejeans/bluejeans.desktop" "${pkgdir}/usr/share/applications/"
- mv "opt/bluejeans/icons" "${pkgdir}/usr/share/"
-
- # hack for libudev.so.0
- ln -nsf "/usr/lib/libudev.so.1" "opt/bluejeans/libudev.so.0"
-
- # put the rest in /opt
- mv "opt" "${pkgdir}"
+ # move the rest of the files into the package directory
+ mv "opt" "${pkgdir}/"
+ mv "usr/share" "${pkgdir}/usr/"
}