summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaulo Matias2020-07-16 09:45:19 -0300
committerPaulo Matias2020-07-16 09:45:19 -0300
commita735d83a57f62f22f5adb8e0caf428acff6191bd (patch)
tree7246e2a624ef8787388e55cf3bcbf05fe3757ff2
parentd6f3d46a01583db4d59db6d0de20518cd9211b18 (diff)
downloadaur-a735d83a57f62f22f5adb8e0caf428acff6191bd.tar.gz
#172 fixed upstream
-rw-r--r--.SRCINFO2
-rw-r--r--172.patch86
-rw-r--r--PKGBUILD7
3 files changed, 2 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b99526b62165..abe120e56c0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,9 +15,7 @@ pkgbase = bluespec-git
depends = haskell-split
optdepends = tcl: bluesim and bluetcl
source = git+https://github.com/b-lang-org/bsc.git
- source = 172.patch
sha256sums = SKIP
- sha256sums = 6348a39c84eb57920d05e44813bb233ea105e9f7a426255e45286f27ba7c3067
pkgname = bluespec-git
diff --git a/172.patch b/172.patch
deleted file mode 100644
index 3ff676a02961..000000000000
--- a/172.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-From a40fe6b6144aaf6b2c0484cea02499938c4a3fcf Mon Sep 17 00:00:00 2001
-From: Paulo Matias <matias@ufscar.br>
-Date: Tue, 19 May 2020 10:14:23 -0300
-Subject: [PATCH] Silence false positive overflow error on gcc 10
-
-`0 <= numDigits(v, base) <= 64` for any `v`, `base`. However, since the
-value is returned as an `unsigned int`, gcc 10 alerts for a possible
-overflow on `char buf[value_width+1]`, although it is a false positive.
-By returning an `unsigned short`, the warning (which is actually treated
-as an error due to the CXXFLAGS) is silenced.
----
- src/bluesim/dollar_display.cxx | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/src/bluesim/dollar_display.cxx b/src/bluesim/dollar_display.cxx
-index 61adaaa..9d385fb 100644
---- a/src/bluesim/dollar_display.cxx
-+++ b/src/bluesim/dollar_display.cxx
-@@ -91,7 +91,7 @@ static unsigned int maxWidth(unsigned int nBits, bool isSigned,
-
- // Return the number of digits required to represent a given value
- // in the specified base.
--static unsigned int numDigits(const tValue& v, unsigned int base=10)
-+static unsigned short numDigits(const tValue& v, unsigned int base=10)
- {
- if (v.bits < 2)
- return 1;
-@@ -569,7 +569,7 @@ const char* print_decimal(tFieldDesc& spec, ArgList* args, Target* dest)
- }
- else if (v.bits == 1)
- {
-- unsigned int value_width = numDigits(v);
-+ unsigned short value_width = numDigits(v);
- pad(spec.width, field_width, value_width, ' ', dest);
- if (v.isSigned && v.data.bitVal)
- dest->write_char('-');
-@@ -577,7 +577,7 @@ const char* print_decimal(tFieldDesc& spec, ArgList* args, Target* dest)
- }
- else
- {
-- unsigned int value_width = numDigits(v);
-+ unsigned short value_width = numDigits(v);
- pad(spec.width, field_width, value_width, ' ', dest);
- unsigned long long x;
- if (v.isSigned)
-@@ -632,13 +632,13 @@ const char* print_hex(tFieldDesc& spec, ArgList* args, Target* dest)
- }
- else if (v.bits == 1)
- {
-- unsigned int value_width = numDigits(v,16);
-+ unsigned short value_width = numDigits(v,16);
- pad(spec.width, field_width, value_width, '0', dest);
- dest->write_char(v.data.bitVal ? '1' : '0');
- }
- else
- {
-- unsigned int value_width = numDigits(v,16);
-+ unsigned short value_width = numDigits(v,16);
- pad(spec.width, field_width, value_width, '0', dest);
- unsigned long long x = v.data.uVal;
- if (v.bits < 64)
-@@ -685,13 +685,13 @@ const char* print_octal(tFieldDesc& spec, ArgList* args, Target* dest)
- }
- else if (v.bits == 1)
- {
-- unsigned int value_width = numDigits(v,8);
-+ unsigned short value_width = numDigits(v,8);
- pad(spec.width, field_width, value_width, '0', dest);
- dest->write_char(v.data.bitVal ? '1' : '0');
- }
- else
- {
-- unsigned int value_width = numDigits(v,8);
-+ unsigned short value_width = numDigits(v,8);
- pad(spec.width, field_width, value_width, '0', dest);
- unsigned long long x = v.data.uVal;
- if (v.bits < 64)
-@@ -735,7 +735,7 @@ const char* print_binary(tFieldDesc& spec, ArgList* args, Target* dest)
- }
- else
- {
-- unsigned int value_width = numDigits(v,2);
-+ unsigned short value_width = numDigits(v,2);
- pad(spec.width, field_width, value_width, '0', dest);
- char buf[value_width+1];
- buf[value_width] = '\0';
diff --git a/PKGBUILD b/PKGBUILD
index a9207e94cfb2..f7dba4ecf7d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,10 +11,8 @@ license=('BSD')
depends=('haskell-old-time' 'haskell-syb' 'haskell-regex-compat' 'haskell-split')
makedepends=('git' 'gperf' 'ghc' 'tcl')
optdepends=('tcl: bluesim and bluetcl')
-source=("git+https://github.com/b-lang-org/bsc.git"
- "172.patch")
-sha256sums=('SKIP'
- '6348a39c84eb57920d05e44813bb233ea105e9f7a426255e45286f27ba7c3067')
+source=("git+https://github.com/b-lang-org/bsc.git")
+sha256sums=('SKIP')
_prefix="/opt/bluespec"
pkgver() {
@@ -25,7 +23,6 @@ pkgver() {
prepare() {
cd "$srcdir/bsc"
git submodule update --init --recursive
- patch -Np1 -i ../172.patch
}
build(){