summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyril Levis2020-09-06 23:06:35 +0200
committerCyril Levis2020-09-06 23:06:35 +0200
commitef627443fcb4118090597524a721f4049a80da15 (patch)
treec35e67d99d1d0817405c89a119c4dfc2c4ac0f5c
downloadaur-bluetooth-headset-battery-level-git.tar.gz
Initial upload: bluetooth-headset-battery-level-git r55.d03681d-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fc4c809eb9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bluetooth-headset-battery-level-git
+ pkgdesc = This is a python script to fetch the battery charge level of some Bluetooth headsets.
+ pkgver = r55.d03681d
+ pkgrel = 1
+ url = https://github.com/TheWeirdDev/Bluetooth_Headset_Battery_Level
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python-pybluez
+ provides = bluetooth-headset-battery-level
+ conflicts = bluetooth-headset-battery-level
+ source = bluetooth-headset-battery-level::git+https://github.com/TheWeirdDev/Bluetooth_Headset_Battery_Level
+ sha512sums = SKIP
+
+pkgname = bluetooth-headset-battery-level-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83b7c09485df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Cyrinux <pkgbuilds AT levis DOT name>
+pkgname=bluetooth-headset-battery-level-git
+pkgver=r55.d03681d
+pkgrel=1
+pkgdesc="This is a python script to fetch the battery charge level of some Bluetooth headsets."
+arch=('any')
+depends=('python-pybluez')
+url="https://github.com/TheWeirdDev/Bluetooth_Headset_Battery_Level"
+license=(GPL)
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/TheWeirdDev/Bluetooth_Headset_Battery_Level")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ install -D -m0755 bluetooth_battery.py ${pkgdir}/usr/bin/bluetooth-headset-battery-level
+}