summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlaï Deutel2023-09-13 17:35:38 -0400
committerIlaï Deutel2023-09-13 17:37:19 -0400
commit1c6596bbd9cd3f66f9614f3524a0316b4981f361 (patch)
tree4916a4229ea72d2e51f125269911989fac165d25
downloadaur-bluetuith-git.tar.gz
Initial upload: bluetuith-git 0.1.7.r1.ga088dae-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..948a75b836d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = bluetuith-git
+ pkgdesc = TUI bluetooth manager
+ pkgver = 0.1.7.r1.ga088dae
+ pkgrel = 1
+ url = https://github.com/darkhz/bluetuith
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = aarch64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = git
+ makedepends = go
+ depends = glibc
+ depends = bluez
+ provides = bluetuith
+ conflicts = bluetuith
+ source = bluetuith-git::git+https://github.com/darkhz/bluetuith
+ sha512sums = SKIP
+
+pkgname = bluetuith-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5e537c16f96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Ilaï Deutel <PlMWPh1WSmypRv0JQljz> (echo ... | tr 'A-Za-z' 'l-za-kL-ZA-K' | base64 -d)
+
+pkgname=bluetuith-git
+pkgver=0.1.7.r1.ga088dae
+pkgrel=1
+pkgdesc="TUI bluetooth manager"
+arch=('x86_64' 'i686' 'arm' 'aarch64' 'armv6h' 'armv7h')
+url="https://github.com/darkhz/bluetuith"
+license=('MIT')
+makedepends=('git' 'go')
+depends=('glibc' 'bluez')
+provides=('bluetuith')
+conflicts=('bluetuith')
+source=("${pkgname}::git+https://github.com/darkhz/bluetuith")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
+ -o build \
+ .
+}
+
+check() {
+ cd "$srcdir/$pkgname"
+ go test ./...
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 "build/bluetuith" -t "$pkgdir/usr/bin/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}