summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2019-11-21 20:54:49 -0500
committerTed Alff2019-11-21 20:54:49 -0500
commit539d031d36d869ec8df755dcddadff4795304e7f (patch)
tree0041f8288ada7818c31ab318e37c3073d4fc4f30
parenta0de5a242aa5fb18939128fff022599f7e6f96bf (diff)
downloadaur-539d031d36d869ec8df755dcddadff4795304e7f.tar.gz
Version bump 5.52
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 123f74c90258..9fe3669ed9b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bluez-utils-compat
pkgdesc = Development and debugging utilities for the bluetooth protocol stack. Includes deprecated tools.
- pkgver = 5.51
+ pkgver = 5.52
pkgrel = 1
url = http://www.bluez.org/
arch = i686
@@ -28,11 +28,11 @@ pkgbase = bluez-utils-compat
conflicts = bluez-hcitool
replaces = bluez-hcidump
replaces = bluez<=4.101
- source = https://www.kernel.org/pub/linux/bluetooth/bluez-5.51.tar.xz
- source = https://www.kernel.org/pub/linux/bluetooth/bluez-5.51.tar.sign
+ source = https://www.kernel.org/pub/linux/bluetooth/bluez-5.52.tar.xz
+ source = https://www.kernel.org/pub/linux/bluetooth/bluez-5.52.tar.sign
source = refresh_adv_manager_for_non-LE_devices.diff::https://git.archlinux.org/svntogit/packages.git/plain/trunk/refresh_adv_manager_for_non-LE_devices.diff?h=packages/bluez
validpgpkeys = E932D120BC2AEC444E558F0106CA9F5D1DCF2659
- sha512sums = 8b14eea98f541b981162abce728e0f917654ad3c990721ec398fe41bdd68069fe55ff64b61bc3c3b9f813facf42c995b07619f6d5d153965de27154b1a7b578f
+ sha512sums = 9024481910d1dee85578bf3d7a4fc4be2bece516e6216c91aa1a7ac18537f092b47c41c4a5506ddd7e279599d58002e98203c5439745c01df4dbc22a75234c84
sha512sums = SKIP
sha512sums = c6ef673956963725edc52d667648e51df5b99f820e87705096b4b9338e8a4540722e734f1e8e67998c2fbbefec30645ff1fa064789c8a858f770d1214399561d
diff --git a/PKGBUILD b/PKGBUILD
index 7b906eed4ee7..3dd3c69ef075 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='bluez-utils-compat'
_pkgbase='bluez'
-pkgver=5.51
+pkgver=5.52
pkgrel=1
url="http://www.bluez.org/"
arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
@@ -22,7 +22,7 @@ makedepends=('dbus' 'libical' 'systemd' 'alsa-lib' 'ell')
source=(https://www.kernel.org/pub/linux/bluetooth/"${_pkgbase}-${pkgver}".tar.{xz,sign}
'refresh_adv_manager_for_non-LE_devices.diff::https://git.archlinux.org/svntogit/packages.git/plain/trunk/refresh_adv_manager_for_non-LE_devices.diff?h=packages/bluez')
# see https://www.kernel.org/pub/linux/bluetooth/sha256sums.asc
-sha512sums=('8b14eea98f541b981162abce728e0f917654ad3c990721ec398fe41bdd68069fe55ff64b61bc3c3b9f813facf42c995b07619f6d5d153965de27154b1a7b578f'
+sha512sums=('9024481910d1dee85578bf3d7a4fc4be2bece516e6216c91aa1a7ac18537f092b47c41c4a5506ddd7e279599d58002e98203c5439745c01df4dbc22a75234c84'
'SKIP'
'c6ef673956963725edc52d667648e51df5b99f820e87705096b4b9338e8a4540722e734f1e8e67998c2fbbefec30645ff1fa064789c8a858f770d1214399561d')
validpgpkeys=('E932D120BC2AEC444E558F0106CA9F5D1DCF2659') # Marcel Holtmann <marcel@holtmann.org>
@@ -64,9 +64,11 @@ package() {
install-man1
# add missing tools FS#41132, FS#41687, FS#42716
- for files in `find tools/ -type f -perm -755`; do
- filename="$(basename "$files")"
- install -Dm755 "${srcdir}/${_pkgbase}-${pkgver}"/tools/$filename "${pkgdir}"/usr/bin/$filename
+ for _dir in tools attrib ; do
+ for _files in $( find "$_dir"/ -type f -perm -755 ); do
+ _filename="$( basename "${_files}" )"
+ install -Dm755 "${srcdir}/${_pkgbase}-${pkgver}/${_dir}/${_filename}" "${pkgdir}/usr/bin/${_filename}"
+ done
done
# libbluetooth.so* are part of libLTLIBRARIES and binPROGRAMS targets
@@ -75,5 +77,5 @@ package() {
rm -rf "${pkgdir}"/usr/lib
# move the hid2hci man page out
- mv "${pkgdir}"/usr/share/man/man1/hid2hci.1 "${srcdir}"/
+ # mv "${pkgdir}"/usr/share/man/man1/hid2hci.1 "${srcdir}"/
}