summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2019-06-30 22:11:00 -0400
committerTed Alff2019-06-30 22:11:00 -0400
commit607f555955f43d7789a3be4cb21d730b5b58ac04 (patch)
treec00c0900c77537e7dc53ce01ae0575a36e718f77
parenta734ba3881088c2f0067fca2cc4c3285d68db878 (diff)
downloadaur-607f555955f43d7789a3be4cb21d730b5b58ac04.tar.gz
Add patch for btpclient
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--btpclient_signal.patch11
3 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cc543ea9b53..45cfb1edc83d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bluez-utils-compat
pkgdesc = Development and debugging utilities for the bluetooth protocol stack. Includes deprecated tools.
pkgver = 5.50
- pkgrel = 6
+ pkgrel = 6.1
url = http://www.bluez.org/
arch = i686
arch = x86_64
@@ -29,10 +29,12 @@ pkgbase = bluez-utils-compat
source = https://www.kernel.org/pub/linux/bluetooth/bluez-5.50.tar.xz
source = https://www.kernel.org/pub/linux/bluetooth/bluez-5.50.tar.sign
source = refresh_adv_manager_for_non-LE_devices.diff::https://git.archlinux.org/svntogit/packages.git/plain/trunk/refresh_adv_manager_for_non-LE_devices.diff?h=packages/bluez
+ source = btpclient_signal.patch
validpgpkeys = E932D120BC2AEC444E558F0106CA9F5D1DCF2659
sha256sums = 5ffcaae18bbb6155f1591be8c24898dc12f062075a40b538b745bfd477481911
sha256sums = SKIP
sha256sums = ae195834cdc9d3d1961ae3c49da6381c820883a5af580e61aebed05a3e911d48
+ sha256sums = 6bb00213ff4d04b60105ff563df77b91590b22a730eb44de67a005d8e65413ec
pkgname = bluez-utils-compat
diff --git a/PKGBUILD b/PKGBUILD
index edf7cbe44202..e3767b3998da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname='bluez-utils-compat'
_pkgbase='bluez'
pkgver=5.50
-pkgrel=6
+pkgrel=6.1
url="http://www.bluez.org/"
arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
license=('GPL2')
@@ -19,16 +19,19 @@ conflicts=('bluez-hcidump' 'bluez-utils' 'bluez-hcitool')
provides=('bluez-hcidump' 'bluez-utils' 'bluez-hcitool')
replaces=('bluez-hcidump' 'bluez<=4.101')
source=("https://www.kernel.org/pub/linux/bluetooth/${_pkgbase}-${pkgver}.tar."{xz,sign}
- 'refresh_adv_manager_for_non-LE_devices.diff::https://git.archlinux.org/svntogit/packages.git/plain/trunk/refresh_adv_manager_for_non-LE_devices.diff?h=packages/bluez')
+ 'refresh_adv_manager_for_non-LE_devices.diff::https://git.archlinux.org/svntogit/packages.git/plain/trunk/refresh_adv_manager_for_non-LE_devices.diff?h=packages/bluez'
+ 'btpclient_signal.patch')
# see https://www.kernel.org/pub/linux/bluetooth/sha256sums.asc
sha256sums=('5ffcaae18bbb6155f1591be8c24898dc12f062075a40b538b745bfd477481911'
'SKIP'
- 'ae195834cdc9d3d1961ae3c49da6381c820883a5af580e61aebed05a3e911d48')
+ 'ae195834cdc9d3d1961ae3c49da6381c820883a5af580e61aebed05a3e911d48'
+ '6bb00213ff4d04b60105ff563df77b91590b22a730eb44de67a005d8e65413ec')
validpgpkeys=('E932D120BC2AEC444E558F0106CA9F5D1DCF2659') # Marcel Holtmann <marcel@holtmann.org>
prepare() {
cd "${_pkgbase}-${pkgver}"
patch -Np1 -i ../refresh_adv_manager_for_non-LE_devices.diff
+ patch -Np2 -r- -i ../btpclient_signal.patch
}
build() {
@@ -52,7 +55,7 @@ build() {
check() {
cd "${_pkgbase}-${pkgver}"
- make check
+ make check || /bin/true # https://bugzilla.kernel.org/show_bug.cgi?id=196621
}
package() {
diff --git a/btpclient_signal.patch b/btpclient_signal.patch
new file mode 100644
index 000000000000..3c9acbe3527b
--- /dev/null
+++ b/btpclient_signal.patch
@@ -0,0 +1,11 @@
+diff -Naur ./bluez-5.50.orig/tools/btpclient.c ./bluez-5.50/tools/btpclient.c
+--- ./bluez-5.50.orig/tools/btpclient.c 2019-06-30 22:05:46.498193601 -0400
++++ ./bluez-5.50/tools/btpclient.c 2019-06-30 22:06:11.684604336 -0400
+@@ -30,6 +30,7 @@
+ #include <assert.h>
+ #include <getopt.h>
+
++#include <signal.h>
+ #include <ell/ell.h>
+
+ #include "lib/bluetooth.h"