summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Springer2020-02-01 18:29:19 +0100
committerFelix Springer2020-02-01 18:29:19 +0100
commit01346b2264be8ce7ba05b2c14a675f95e181d95b (patch)
tree233828bb847ddd07a07c9addfb1a491afebc239b
parent36e459cb4c6266ace83e32f9a4ca422c0e235e8f (diff)
downloadaur-01346b2264be8ce7ba05b2c14a675f95e181d95b.tar.gz
move to version 1.12.0, add checksum, remove git-dependency, for git-version check out previous commit!
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5374ade60ff..007f1dae1409 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = blugon
pkgdesc = simple and configurable Blue Light Filter for X
- pkgver = 1.11.4
+ pkgver = 1.12.0
pkgrel = 1
url = https://github.com/jumper149/blugon
arch = x86_64
license = Apache
- makedepends = git
depends = libx11
depends = libxrandr
depends = python
optdepends = xorg-xgamma: backend
- source = git+https://github.com/jumper149/blugon.git
- sha256sums = SKIP
+ source = https://github.com/jumper149/blugon/archive/1.12.0.tar.gz
+ sha256sums = b22a0d432d68a38131b6dd673c6a6358ae43ea7a2757432afafc5285a5865acf
pkgname = blugon
diff --git a/PKGBUILD b/PKGBUILD
index b5362efae8b6..cb97aa411c85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,23 @@
pkgname=blugon
pkgdesc="simple and configurable Blue Light Filter for X"
-pkgver=1.11.4
+pkgver=1.12.0
pkgrel=1
arch=('x86_64')
url="https://github.com/jumper149/blugon"
license=('Apache')
depends=('libx11' 'libxrandr' 'python')
optdepends=('xorg-xgamma: backend')
-makedepends=('git')
-source=('git+https://github.com/jumper149/blugon.git')
-_gitname="blugon"
-sha256sums=('SKIP')
-
-pkgver() {
- cd "${srcdir}/${_gitname}"
- grep "VERSION =" "blugon.py" | cut --delimiter="'" --fields=2
-}
+source=("https://github.com/jumper149/blugon/archive/${pkgver}.tar.gz")
+sha256sums=('b22a0d432d68a38131b6dd673c6a6358ae43ea7a2757432afafc5285a5865acf')
build() {
- cd "${_gitname}"
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd "${_gitname}"
+ cd "${pkgname}-${pkgver}"
make install DESTDIR="${pkgdir}"
make clean
}