summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-10-10 11:31:11 -0500
committerLuis Martinez2022-10-10 11:31:11 -0500
commit08afe39003209d99534332c72d7491c6647e2876 (patch)
tree1c63da55a7d8f4bc1507239765f189e97644bc47
parent26e8278a909165af821774c669cfbf5b544190c6 (diff)
downloadaur-bombadillo-bin.tar.gz
fix arch tags
-rw-r--r--.SRCINFO12
-rw-r--r--CHANGELOG21
-rw-r--r--PKGBUILD26
3 files changed, 44 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ff256cd041c..21802e5e9850 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,22 @@
pkgbase = bombadillo-bin
pkgdesc = A non-web client for the terminal, supporting Gopher, Gemini and much more.
pkgver = 2.3.3
- pkgrel = 1
+ pkgrel = 2
url = https://bombadillo.colorfield.space
+ changelog = CHANGELOG
arch = x86_64
arch = i686
- arch = arm
+ arch = armv7h
+ arch = aarch64
license = GPL3
depends = glibc
source_x86_64 = bombadillo-bin-2.3.3-x86_64.zip::https://bombadillo.colorfield.space/binaries/bombadillo-2.3.3_linux_64.zip
sha256sums_x86_64 = 8085294ef719d7cda2946ef3e26e7761470a8bc8a376e273df965d3d677cfc63
source_i686 = bombadillo-bin-2.3.3-i686.zip::https://bombadillo.colorfield.space/binaries/bombadillo-2.3.3_linux_32.zip
sha256sums_i686 = 898deff7136a0bfd1204edeb88ad4ea855a9f7c04335175f22b70ada0fbea5ee
- source_arm = bombadillo-bin-2.3.3-arm.zip::https://bombadillo.colorfield.space/binaries/bombadillo-2.3.3_linux_arm.zip
- sha256sums_arm = a366cb101a5f257d011116eafeefc987bbfbcc3cc7948140a5980d4345a8afa5
+ source_armv7h = bombadillo-bin-2.3.3-armv7h.zip::https://bombadillo.colorfield.space/binaries/bombadillo-2.3.3_linux_arm.zip
+ sha256sums_armv7h = a366cb101a5f257d011116eafeefc987bbfbcc3cc7948140a5980d4345a8afa5
+ source_aarch64 = bombadillo-bin-2.3.3-aarch64.zip::https://bombadillo.colorfield.space/binaries/bombadillo-2.3.3_linux_arm.zip
+ sha256sums_aarch64 = a366cb101a5f257d011116eafeefc987bbfbcc3cc7948140a5980d4345a8afa5
pkgname = bombadillo-bin
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 000000000000..f0dbbd6cd27b
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,21 @@
+- Adds `jump` command to allow forward copying of history locations
+- Simplifies makefile/build system, including versioning
+- Adds `version` command to allow retrieving version information wthin the program
+- Fixes bug in searching where previous search highlighting was not removed upon subsequent searches
+- Updates text and formatting in the man page
+- Adds support for legacy forms of hostname verification for gemini tls connections. This maintains compatibility when built with go > 1.14
+- Adds recognition and handling for various unicode line endings
+- Fixes bug where 404 errors for websites were not shown when using the `lynx` webmode setting
+- Adds left gutter for link numbering when displaying text/gemini documents; this creates a more unified look with how gopher maps are displayed
+- Adds messaging to display how a command should be used when it is used incorrectly
+- Updates the `help` command to take an optional command as a paramater to get the syntax for the given command
+- Minor optimizations to rendering
+- Updates to DEVELOPING document
+- Adds text/gemini as default mime for gemini requests, if no other mime is sent by the server (per the gemini spec)
+- Adds support for relatively linked redirects
+- Removes client certificate support for gemini. They were not well implemented and may come back at some point in the future
+- Simplifies and consolidates code for the `gui` setting of the webmode configuration option
+- Adds `gui` setting (for webmode configuration option) support for BSD systems
+- Adds a timeout configuration option that allows users to set the gopher/gemini timeout (in seconds)
+- Fixes to line wrapping and rendering
+
diff --git a/PKGBUILD b/PKGBUILD
index ea46f4b4aa93..292cc5cfec02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,28 @@
# Contributor: Emilio Reggi <nag@mailbox.org>
pkgname=bombadillo-bin
+_pkg="${pkgname%-bin}"
pkgver=2.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="A non-web client for the terminal, supporting Gopher, Gemini and much more."
-arch=('x86_64' 'i686' 'arm')
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://bombadillo.colorfield.space"
license=('GPL3')
depends=('glibc')
-source_x86_64=("$pkgname-$pkgver-x86_64.zip::$url/binaries/bombadillo-${pkgver}_linux_64.zip")
-source_i686=("$pkgname-$pkgver-i686.zip::$url/binaries/bombadillo-${pkgver}_linux_32.zip")
-source_arm=("$pkgname-$pkgver-arm.zip::$url/binaries/bombadillo-${pkgver}_linux_arm.zip")
+changelog=CHANGELOG
+source_x86_64=("$pkgname-$pkgver-x86_64.zip::$url/binaries/$_pkg-${pkgver}_linux_64.zip")
+source_i686=("$pkgname-$pkgver-i686.zip::$url/binaries/$_pkg-${pkgver}_linux_32.zip")
+source_armv7h=("$pkgname-$pkgver-armv7h.zip::$url/binaries/$_pkg-${pkgver}_linux_arm.zip")
+source_aarch64=("$pkgname-$pkgver-aarch64.zip::$url/binaries/$_pkg-${pkgver}_linux_arm.zip")
sha256sums_x86_64=('8085294ef719d7cda2946ef3e26e7761470a8bc8a376e273df965d3d677cfc63')
sha256sums_i686=('898deff7136a0bfd1204edeb88ad4ea855a9f7c04335175f22b70ada0fbea5ee')
-sha256sums_arm=('a366cb101a5f257d011116eafeefc987bbfbcc3cc7948140a5980d4345a8afa5')
+sha256sums_armv7h=('a366cb101a5f257d011116eafeefc987bbfbcc3cc7948140a5980d4345a8afa5')
+sha256sums_aarch64=('a366cb101a5f257d011116eafeefc987bbfbcc3cc7948140a5980d4345a8afa5')
package() {
- install -Dm 755 bombadillo -t "$pkgdir/usr/bin/"
- install -Dm 644 README.txt -t "$pkgdir/usr/share/doc/$pkgname/"
- install -Dm 644 bombadillo.desktop -t "$pkgdir/usr/share/applications/"
- install -Dm 644 bombadillo-icon.png -t "$pkgdir/usr/share/pixmaps/"
- install -Dm 644 bombadillo.1 -t "$pkgdir/usr/share/man/man1/"
+ install -D "$_pkg" -t "$pkgdir/usr/bin/"
+ install -Dm644 README.txt -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dm644 "$_pkg.desktop" -t "$pkgdir/usr/share/applications/"
+ install -Dm644 "$_pkg-icon.png" -t "$pkgdir/usr/share/pixmaps/"
+ install -Dm644 "$_pkg.1" -t "$pkgdir/usr/share/man/man1/"
}