summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2015-11-26 22:13:47 +0330
committerBehnam Momeni2015-11-26 22:13:47 +0330
commit9d6a27855047c5c62370734a0656522dd9cefd90 (patch)
treef5e75b0b1695c7ae3657209200b06635217c592e
parent3c66fcd9d345f584650db20372ee59198cd086e2 (diff)
downloadaur-9d6a27855047c5c62370734a0656522dd9cefd90.tar.gz
Adding two patches to make it compilable with g++ 5.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--autoptr2uniqueptr.patch11
-rw-r--r--stream_bool_cast.patch13
4 files changed, 37 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 149169c7eea1..d90c71385e9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bombono-dvd
pkgdesc = DVD authoring program with nice and clean GUI
pkgver = 1.2.2
- pkgrel = 5
+ pkgrel = 6
url = http://www.bombono.org
install = bombono-dvd.install
arch = i686
@@ -28,12 +28,16 @@ pkgbase = bombono-dvd
source = fix_ptr2bool_cast.patch
source = fix_c++11_literal_warnings.patch
source = fix_crefoftemp_bug.patch
+ source = autoptr2uniqueptr.patch
+ source = stream_bool_cast.patch
sha256sums = 3ffaadc803dc2526d2805629ee928800ce150cb2e6a40b6724d898c76366f68b
sha256sums = decc8f9261b0fcd18780080438c9fc4297d56a281355f195a5dee9a92abf474a
sha256sums = ee89adeff7bd19d731eac96c180d5d59766bb3a68f3b21b898199e1cb6c5639e
sha256sums = 9471454c97d8b91b4234085f1eabc625d9e23e76a91266b205dc3f79553322b9
sha256sums = 31dfc5400d450490a53bbd386bafb59d68a9a2d6f9036755419d3be035aa87be
sha256sums = 0ea8ad5ccf64d30d0463e9bde5b07abdedd00e2da2fa7f3f72de99aa3915a64c
+ sha256sums = 9214f838377cdf35bf1f151e4eaac10952049ccff4d74ca485fc8b6f05bc8ba4
+ sha256sums = 62d0f56ab4c2512bf004756426da6bf63cc0bd134ae6bc60304cc20116277e27
pkgname = bombono-dvd
diff --git a/PKGBUILD b/PKGBUILD
index 40294d1aafba..74088ba61e7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bombono-dvd
pkgver=1.2.2
-pkgrel=5
+pkgrel=6
pkgdesc="DVD authoring program with nice and clean GUI"
arch=('i686' 'x86_64')
url="http://www.bombono.org"
@@ -15,14 +15,17 @@ optdepends=('gvfs: web browser integration')
conflicts=('bombono-dvd-git')
source=(http://downloads.sourceforge.net/bombono/$pkgname-$pkgver.tar.bz2
fix_ffmpeg_codecid.patch bombono-dvd-1.2.2-ffmpeg26.patch
- fix_ptr2bool_cast.patch fix_c++11_literal_warnings.patch fix_crefoftemp_bug.patch)
+ fix_ptr2bool_cast.patch fix_c++11_literal_warnings.patch fix_crefoftemp_bug.patch
+ autoptr2uniqueptr.patch stream_bool_cast.patch)
install=bombono-dvd.install
sha256sums=('3ffaadc803dc2526d2805629ee928800ce150cb2e6a40b6724d898c76366f68b'
'decc8f9261b0fcd18780080438c9fc4297d56a281355f195a5dee9a92abf474a'
'ee89adeff7bd19d731eac96c180d5d59766bb3a68f3b21b898199e1cb6c5639e'
'9471454c97d8b91b4234085f1eabc625d9e23e76a91266b205dc3f79553322b9'
'31dfc5400d450490a53bbd386bafb59d68a9a2d6f9036755419d3be035aa87be'
- '0ea8ad5ccf64d30d0463e9bde5b07abdedd00e2da2fa7f3f72de99aa3915a64c')
+ '0ea8ad5ccf64d30d0463e9bde5b07abdedd00e2da2fa7f3f72de99aa3915a64c'
+ '9214f838377cdf35bf1f151e4eaac10952049ccff4d74ca485fc8b6f05bc8ba4'
+ '62d0f56ab4c2512bf004756426da6bf63cc0bd134ae6bc60304cc20116277e27')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -31,6 +34,8 @@ prepare() {
patch -Np1 -i "${srcdir}/fix_ptr2bool_cast.patch"
patch -Np1 -i "${srcdir}/fix_c++11_literal_warnings.patch"
patch -Np1 -i "${srcdir}/fix_crefoftemp_bug.patch"
+ patch -Np1 -i "${srcdir}/autoptr2uniqueptr.patch"
+ patch -Np1 -i "${srcdir}/stream_bool_cast.patch"
# python2 fix
for file in $(find . -name '*.py' -print); do
sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file
diff --git a/autoptr2uniqueptr.patch b/autoptr2uniqueptr.patch
new file mode 100644
index 000000000000..7aae4ec58f3b
--- /dev/null
+++ b/autoptr2uniqueptr.patch
@@ -0,0 +1,11 @@
+--- bombono-dvd-1.2.2/libs/boost-logging/boost/logging/detail/tss/tss_impl_pthread.hpp 2013-03-08 00:50:45.000000000 +0330
++++ new/libs/boost-logging/boost/logging/detail/tss/tss_impl_pthread.hpp 2015-11-26 20:06:48.693423531 +0330
+@@ -39,7 +39,7 @@
+ slots = static_cast<tss_slots*>( pthread_getspecific(tss_data_native_key()));
+ if (slots == 0)
+ {
+- std::auto_ptr<tss_slots> temp( new_object_ensure_delete<tss_slots>() );
++ std::unique_ptr<tss_slots> temp( new_object_ensure_delete<tss_slots>() );
+ // pre-allocate a few elems, so that we'll be fast
+ temp->resize(BOOST_LOG_TSS_SLOTS_SIZE);
+
diff --git a/stream_bool_cast.patch b/stream_bool_cast.patch
new file mode 100644
index 000000000000..51c9132ca87c
--- /dev/null
+++ b/stream_bool_cast.patch
@@ -0,0 +1,13 @@
+--- bombono-dvd-1.2.2/src/mgui/stream_utils.h 2013-03-08 00:50:45.000000000 +0330
++++ new/src/mgui/stream_utils.h 2015-11-26 20:37:42.780113771 +0330
+@@ -42,8 +42,8 @@
+ stream(std::iostream& strm): io_strm(strm) {}
+
+ std::iostream& strm() { return io_strm; }
+- operator void*() const { return (void*)io_strm; }
+- bool operator!() const { return !operator void*(); }
++ operator bool() const { return static_cast<bool> (io_strm); }
++ bool operator!() const { return !operator bool(); }
+ stream& seekg(streamoff off, ios_base::seekdir dir)
+ { io_strm.seekg(off, dir); return *this; }
+ stream& seekp(streamoff off, ios_base::seekdir dir)