summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaegil Bae2018-08-18 01:40:59 +0900
committerTaegil Bae2018-08-18 01:40:59 +0900
commit78f74f47f73f096fa6ac8f8a99c114657b10b87c (patch)
treeadc13af670d9e88d78a16890e6cf5c323bf9277e
parentaad3873c8b0c4940986bcfa45cdfd06528872a28 (diff)
downloadaur-78f74f47f73f096fa6ac8f8a99c114657b10b87c.tar.gz
Upgrade waf to fix error in compiling MPV
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--compilation_fix.patch103
-rw-r--r--upgrade_waf.patch74
4 files changed, 90 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f8a8c643ad0..e6ecdbe42eb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bomi-git
pkgdesc = Powerful and easy-to-use GUI multimedia player based on mpv (git version)
pkgver = 0.9.11.r39.g5f0cc0a7
- pkgrel = 1
+ pkgrel = 2
url = http://bomi-player.github.io
arch = i686
arch = x86_64
@@ -43,8 +43,10 @@ pkgbase = bomi-git
conflicts = bomi
source = git+https://github.com/d-s-x/bomi.git
source = add_sup_subext.patch
+ source = upgrade_waf.patch
md5sums = SKIP
md5sums = dacb0df199eea0f6e3d5c037c8c5429d
+ md5sums = 6bbade797cd850a576794fbf8aef0247
pkgname = bomi-git
diff --git a/PKGBUILD b/PKGBUILD
index 70b2453548b7..a98037dc7cae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _pkgbase=bomi
pkgname=$_pkgbase-git
pkgver=0.9.11.r39.g5f0cc0a7
-pkgrel=1
+pkgrel=2
pkgdesc="Powerful and easy-to-use GUI multimedia player based on mpv (git version)"
arch=('i686' 'x86_64')
url="http://bomi-player.github.io"
@@ -26,9 +26,11 @@ optdepends=('libva-intel-driver: hardware acceleration support for Intel GPU'
provides=('bomi')
conflicts=('cmplayer' 'bomi')
source=(git+https://github.com/d-s-x/${_pkgbase}.git
- add_sup_subext.patch)
+ add_sup_subext.patch
+ upgrade_waf.patch)
md5sums=('SKIP'
- 'dacb0df199eea0f6e3d5c037c8c5429d')
+ 'dacb0df199eea0f6e3d5c037c8c5429d'
+ '6bbade797cd850a576794fbf8aef0247')
#options=(debug !strip)
pkgver() {
@@ -41,6 +43,14 @@ prepare() {
patch -Np1 -i $srcdir/add_sup_subext.patch
+ # While compiling mpv, an error occurs in waf python code.
+ # Upgrading waf version fixes it.
+ patch -Np1 -i $srcdir/upgrade_waf.patch
+ pushd src/mpv
+ rm waf
+ ./bootstrap.py
+ popd
+
./configure --prefix=/usr
}
diff --git a/compilation_fix.patch b/compilation_fix.patch
deleted file mode 100644
index 452ae7a486f7..000000000000
--- a/compilation_fix.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-diff --git a/src/bomi/dialog/encoderdialog.cpp b/src/bomi/dialog/encoderdialog.cpp
-index 970bf7a..19b4962 100644
---- a/src/bomi/dialog/encoderdialog.cpp
-+++ b/src/bomi/dialog/encoderdialog.cpp
-@@ -255,7 +255,7 @@ auto EncoderDialog::run() -> QString
- {
- if (d->size.isEmpty())
- return tr("No video stream exists.");
-- d->g.unix = QDateTime::currentMSecsSinceEpoch();
-+ d->g._unix = QDateTime::currentMSecsSinceEpoch();
- d->g.dateTime = QDateTime::currentDateTime();
- d->g.start = d->ui.a->time();
- d->g.end = d->ui.b->time();
-diff --git a/src/bomi/misc/filenamegenerator.cpp b/src/bomi/misc/filenamegenerator.cpp
-index 3ae0d78..8b1e25a 100644
---- a/src/bomi/misc/filenamegenerator.cpp
-+++ b/src/bomi/misc/filenamegenerator.cpp
-@@ -51,8 +51,8 @@ auto get(const FileNameGenerator *g, const QString &ph) -> QString
- };
- get[u"%MEDIA_DISPLAY_NAME%"_q] = [] (const FileNameGenerator *g) { return g->mediaName; };
-
-- get[u"%UNIX%"_q] = [] (const FileNameGenerator *g) { return _N(g->unix / 1000llu); };
-- get[u"%UNIX_MS%"_q] = [] (const FileNameGenerator *g) { return _N(g->unix); };
-+ get[u"%UNIX%"_q] = [] (const FileNameGenerator *g) { return _N(g->_unix / 1000llu); };
-+ get[u"%UNIX_MS%"_q] = [] (const FileNameGenerator *g) { return _N(g->_unix); };
- return get;
- }();
- auto ret = func.value(ph);
-diff --git a/src/bomi/misc/filenamegenerator.hpp b/src/bomi/misc/filenamegenerator.hpp
-index dad8601..6567942 100644
---- a/src/bomi/misc/filenamegenerator.hpp
-+++ b/src/bomi/misc/filenamegenerator.hpp
-@@ -11,7 +11,7 @@ struct FileNameGenerator {
- QTime start, end;
- QString mediaName;
- Mrl mrl;
-- quint64 unix = 0;
-+ quint64 _unix = 0;
- };
-
- #endif // FILENAMEGENERATOR_HPP
-diff --git a/src/bomi/player/mainwindow_p.cpp b/src/bomi/player/mainwindow_p.cpp
-index 7c2aa8a..6c8765f 100644
---- a/src/bomi/player/mainwindow_p.cpp
-+++ b/src/bomi/player/mainwindow_p.cpp
-@@ -910,7 +910,7 @@ auto MainWindow::Data::fileNameGenerator(const QTime &end) const -> FileNameGene
- g.dateTime = QDateTime::currentDateTime();
- g.start = QTime::fromMSecsSinceStartOfDay(e.time());
- g.end = end.isNull() ? g.start : end;
-- g.unix = QDateTime::currentMSecsSinceEpoch();
-+ g._unix = QDateTime::currentMSecsSinceEpoch();
- g.mrl = e.mrl();
- g.mediaName = e.media()->name();
- return g;
-diff --git a/src/bomi/player/mainwindow_p.hpp b/src/bomi/player/mainwindow_p.hpp
-index 7f72589..9153f68 100644
---- a/src/bomi/player/mainwindow_p.hpp
-+++ b/src/bomi/player/mainwindow_p.hpp
-@@ -101,7 +101,7 @@ struct MainWindow::Data {
-
- struct {
- QDate date; QTime time, position;
-- quint64 unix = 0;
-+ quint64 _unix = 0;
- QMap<QString, std::function<QString(void)>> get;
- } ph;
- QTimer waiter, hider, dialogWorkaround;
-diff --git a/src/mpv/audio/filter/af_lavcac3enc.c b/src/mpv/audio/filter/af_lavcac3enc.c
-index 5695bfd..4d2abca 100644
---- a/src/mpv/audio/filter/af_lavcac3enc.c
-+++ b/src/mpv/audio/filter/af_lavcac3enc.c
-@@ -26,7 +26,6 @@
- #include <assert.h>
-
- #include <libavcodec/avcodec.h>
--#include <libavutil/audioconvert.h>
- #include <libavutil/intreadwrite.h>
- #include <libavutil/common.h>
- #include <libavutil/bswap.h>
-diff --git a/src/mpv/audio/filter/af_lavrresample.c b/src/mpv/audio/filter/af_lavrresample.c
-index 265fa4b..83b5505 100644
---- a/src/mpv/audio/filter/af_lavrresample.c
-+++ b/src/mpv/audio/filter/af_lavrresample.c
-@@ -28,7 +28,6 @@
- #include <assert.h>
-
- #include <libavutil/opt.h>
--#include <libavutil/audioconvert.h>
- #include <libavutil/common.h>
- #include <libavutil/samplefmt.h>
- #include <libavutil/mathematics.h>
-diff --git a/src/mpv/audio/out/ao_lavc.c b/src/mpv/audio/out/ao_lavc.c
-index b322982..16ff8c1 100644
---- a/src/mpv/audio/out/ao_lavc.c
-+++ b/src/mpv/audio/out/ao_lavc.c
-@@ -25,7 +25,6 @@
- #include <limits.h>
-
- #include <libavutil/common.h>
--#include <libavutil/audioconvert.h>
-
- #include "config.h"
- #include "options/options.h"
diff --git a/upgrade_waf.patch b/upgrade_waf.patch
new file mode 100644
index 000000000000..c39269ceffb9
--- /dev/null
+++ b/upgrade_waf.patch
@@ -0,0 +1,74 @@
+diff --git a/src/mpv/bootstrap.py b/src/mpv/bootstrap.py
+index c62914cb..b9b6e9b6 100755
+--- a/src/mpv/bootstrap.py
++++ b/src/mpv/bootstrap.py
+@@ -5,10 +5,10 @@
+ from __future__ import print_function
+ import os, sys, stat, hashlib, subprocess
+
+-WAFRELEASE = "waf-1.8.4"
++WAFRELEASE = "waf-2.0.9"
+ WAFURLS = ["http://ftp.waf.io/pub/release/" + WAFRELEASE,
+ "http://www.freehackers.org/~tnagy/release/" + WAFRELEASE]
+-SHA256HASH = "f02035fa5d8814f33f19b2b20d43822ddef6bb39b955ca196c2a247a1f9ffaa8"
++SHA256HASH = "2a8e0816f023995e557f79ea8940d322bec18f286917c8f9a6fa2dc3875dfa48"
+
+ if os.path.exists("waf"):
+ wafver = subprocess.check_output([sys.executable, './waf', '--version']).decode()
+diff --git a/src/mpv/wscript b/src/mpv/wscript
+index d28d18fb..e659b43f 100644
+--- a/src/mpv/wscript
++++ b/src/mpv/wscript
+@@ -811,15 +811,6 @@ standalone_features = [
+ ]
+
+ _INSTALL_DIRS_LIST = [
+- ('bindir', '${PREFIX}/bin', 'binary files'),
+- ('libdir', '${PREFIX}/lib', 'library files'),
+- ('confdir', '${PREFIX}/etc/mpv', 'configuration files'),
+-
+- ('incdir', '${PREFIX}/include', 'include files'),
+-
+- ('datadir', '${PREFIX}/share', 'data files'),
+- ('mandir', '${DATADIR}/man', 'man pages '),
+- ('docdir', '${DATADIR}/doc/mpv', 'documentation files'),
+ ('zshdir', '${DATADIR}/zsh/site-functions', 'zsh completion functions'),
+ ]
+
+@@ -827,6 +818,7 @@ def options(opt):
+ opt.load('compiler_c')
+ opt.load('waf_customizations')
+ opt.load('features')
++ opt.load('gnu_dirs')
+
+ group = opt.get_option_group("build and install options")
+ for ident, default, desc in _INSTALL_DIRS_LIST:
+@@ -897,6 +889,7 @@ def configure(ctx):
+ ctx.load('dependencies')
+ ctx.load('detections.compiler')
+ ctx.load('detections.devices')
++ ctx.load('gnu_dirs')
+
+ ctx.parse_dependencies(build_options)
+ ctx.parse_dependencies(main_dependencies)
+diff --git a/src/mpv/wscript_build.py b/src/mpv/wscript_build.py
+index 0d0685b0..04d435a5 100644
+--- a/src/mpv/wscript_build.py
++++ b/src/mpv/wscript_build.py
+@@ -510,14 +510,14 @@ def build(ctx):
+ features = 'subst',
+ PREFIX = ctx.env.PREFIX,
+ LIBDIR = ctx.env.LIBDIR,
+- INCDIR = ctx.env.INCDIR,
++ INCDIR = ctx.env.INCLUDEDIR,
+ VERSION = libversion,
+ PRIV_LIBS = get_deps(),
+ )
+
+ headers = ["client.h", "qthelper.hpp", "opengl_cb.h"]
+ for f in headers:
+- ctx.install_as(ctx.env.INCDIR + '/mpv/' + f, 'libmpv/' + f)
++ ctx.install_as(ctx.env.INCLUDEDIR + '/mpv/' + f, 'libmpv/' + f)
+
+ ctx.install_as(ctx.env.LIBDIR + '/pkgconfig/mpv.pc', 'libmpv/mpv.pc')
+