summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaan Kasım2015-08-12 14:23:40 +0300
committerKaan Kasım2015-08-12 14:23:40 +0300
commit89e91f302fd44a345c6b6cf4660fcbd1e5910426 (patch)
tree613bdc96dd87056204b26f10fce5193780c45150
downloadaur-89e91f302fd44a345c6b6cf4660fcbd1e5910426.tar.gz
Initial import
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD44
-rw-r--r--bomi.install12
3 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68e7c84c4aa8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,49 @@
+pkgbase = bomi-git
+ pkgdesc = Powerful and easy-to-use GUI multimedia player based on mpv (git version)
+ pkgver = 0.9.11.r18.gadb6dac
+ pkgrel = 1
+ url = http://bomi-player.github.io
+ install = bomi.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = mesa
+ makedepends = gcc
+ makedepends = pkg-config
+ makedepends = python
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-x11extras
+ depends = qt5-quickcontrols
+ depends = qt5-svg
+ depends = libdvdread
+ depends = libdvdnav
+ depends = libcdio-paranoia
+ depends = libcdio
+ depends = smbclient
+ depends = alsa-lib
+ depends = libpulse
+ depends = jack
+ depends = libchardet
+ depends = libbluray
+ depends = libva
+ depends = libvdpau
+ depends = libgl
+ depends = fribidi
+ depends = libass
+ depends = ffmpeg
+ optdepends = libva-intel-driver: hardware acceleration support for Intel GPU
+ optdepends = mesa-vdpau: hardware acceleration support for AMD/NVIDIA opensource driver
+ optdepends = youtube-dl: streaming website support including YouTube
+ optdepends = libaacs: AACS decryption for Blu-ray support
+ optdepends = libbdplus: BD+ decryption for Blu-ray support
+ provides = bomi
+ conflicts = cmplayer
+ conflicts = bomi
+ source = git+https://github.com/xylosper/bomi.git
+ md5sums = SKIP
+
+pkgname = bomi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a78e767e6cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Ben Reedy <breed808 *AT* breed808 *DOT* com>
+# Contributor: xylosper <darklin20@gmail.com>
+
+_pkgbase=bomi
+
+pkgname=$_pkgbase-git
+pkgver=0.9.11.r18.gadb6dac
+pkgrel=1
+pkgdesc="Powerful and easy-to-use GUI multimedia player based on mpv (git version)"
+arch=('i686' 'x86_64')
+url="http://bomi-player.github.io"
+license=('GPL')
+install=$_pkgbase.install
+depends=('qt5-base' 'qt5-declarative' 'qt5-x11extras' 'qt5-quickcontrols' 'qt5-svg'
+ 'libdvdread' 'libdvdnav' 'libcdio-paranoia' 'libcdio' 'smbclient'
+ 'alsa-lib' 'libpulse' 'jack' 'libchardet' 'libbluray'
+ 'libva' 'libvdpau' 'libgl' 'fribidi' 'libass' 'ffmpeg')
+makedepends=('git' 'mesa' 'gcc' 'pkg-config' 'python' 'qt5-tools')
+optdepends=('libva-intel-driver: hardware acceleration support for Intel GPU'
+ 'mesa-vdpau: hardware acceleration support for AMD/NVIDIA opensource driver'
+ 'youtube-dl: streaming website support including YouTube'
+ 'libaacs: AACS decryption for Blu-ray support'
+ 'libbdplus: BD+ decryption for Blu-ray support')
+provides=('bomi')
+conflicts=('cmplayer' 'bomi')
+source=(git+https://github.com/xylosper/${_pkgbase}.git)
+md5sums=('SKIP')
+#options=(debug !strip)
+
+pkgver() {
+ cd "$srcdir/$_pkgbase"
+ echo $(git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g' | cut -c2-)
+}
+
+build() {
+ cd "$srcdir/$_pkgbase"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgbase"
+ make DEST_DIR="$pkgdir" install
+}
diff --git a/bomi.install b/bomi.install
new file mode 100644
index 000000000000..6481cee07145
--- /dev/null
+++ b/bomi.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}