summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohnny English2018-04-10 10:59:59 +0200
committerJohnny English2018-04-10 10:59:59 +0200
commitab8f52896def4ffc00a10cc859ad9b74dfbcc2ab (patch)
tree38ee54ce0c56a6700d67cd82acfcab06cb6d62e8
parenta90e30c5213c5d2f3079f314805355df4d7e03bd (diff)
downloadaur-ab8f52896def4ffc00a10cc859ad9b74dfbcc2ab.tar.gz
fix: an issue with first run of the build (before it worked only for a repeated build)
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd09e58ccd7d..4e85ca92a58e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,6 @@
pkgver=7.6.0
pkgrel=1
-# FIXME a completely new package, because the product was relabeled
_basename=bonita-studio-community
_basenamever="${_basename}-$pkgver"
_prefix=bonitasoft
@@ -22,8 +21,7 @@ sha256sums_i686=( "9d1e60fd3df378e77c639bfc65b47503c5a05c046b4b533f75d86fb99720
install="${_basename}.install"
replaces=('bonita-bpm-community-bin') # yeah, they renamed it
-# FIXME 2018-01-04 22:47:31 UTC+1 revise deps
-depends=('ffmpeg-compat' 'java-environment' 'libxslt' 'python' 'gtk2')
+depends=('ffmpeg2.8' 'libglvnd' 'java-environment' 'libxslt' 'python' 'gtk2')
makedepends=()
# FIXME might be needed: 'postgresql' 'tomcat'
optdepends=(
@@ -55,12 +53,12 @@ build() {
chmod +x *.run
# FIXME a hack to kill the process, because it waits for user input indefinitely
# https://github.com/bonitasoft/bonita-studio/issues/397
- [ -e '/tmp/bitrock_installer.log' ] && pid=xxx
+ [ -e '/tmp/bitrock_installer.log' ] && first_run=yes
./*.run --mode unattended --prefix "$_prefix/$_basenamever" &
- [ -n "$pid" ] && pid=$!
+ pid=$!
while sleep 1; do
grep 'Installation completed' \
- "/tmp/bitrock_installer${pid:+_$pid}.log" >/dev/null && {
+ "/tmp/bitrock_installer${first_run:+_$pid}.log" >/dev/null && {
kill "$pid"
break
}