summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoey Sheffield2020-12-31 04:27:39 +0000
committerZoey Sheffield2020-12-31 04:27:39 +0000
commit69397aae6065de28e7212a30e762b85d95abbf3f (patch)
treeb35a6d26376ba3a0a0067a93c5e0e7ae82f84987
downloadaur-boop-gtk-extra-scripts.tar.gz
aad8f75
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--LICENSE.md21
-rw-r--r--PKGBUILD25
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cf5a2576a98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = boop-gtk-extra-scripts
+ pkgdesc = Extra scripts from Boop-GTK
+ pkgver = aad8f75
+ pkgrel = 1
+ url = https://github.com/IvanMathy/Boop/tree/main/Scripts
+ arch = x86_64
+ license = MIT
+ depends = boop-gtk>=1.6.0
+ source = Boop::git+https://github.com/IvanMathy/Boop#commit=aad8f75
+ sha512sums = SKIP
+
+pkgname = boop-gtk-extra-scripts
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5a046c1e6ba5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!/PKGBUILD
+!/.git*
+!/.SRCINFO
+!/LICENSE.md
diff --git a/LICENSE.md b/LICENSE.md
new file mode 100644
index 000000000000..74e2787c5da8
--- /dev/null
+++ b/LICENSE.md
@@ -0,0 +1,21 @@
+# The MIT License
+
+Copyright © 2020 Hoàng Văn Khải
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1c022ebf009
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Zoey Sheffield <me at zoey dot fyi>
+
+pkgname='boop-gtk-extra-scripts'
+pkgver='aad8f75' # last commit in the Scripts folder of https://github.com/IvanMathy/Boop
+pkgrel='1'
+pkgdesc="Extra scripts for Boop-GTK"
+arch=('x86_64')
+conflicts=()
+provides=()
+url='https://github.com/IvanMathy/Boop/tree/main/Scripts'
+license=('MIT')
+depends=("boop-gtk>=1.6.0")
+source=("Boop::git+https://github.com/IvanMathy/Boop#commit=$pkgver")
+sha512sums=('SKIP')
+
+package() {
+ # https://specifications.freedesktop.org/basedir-spec/basedir-spec-latest.html#variables
+ config_dirs="${XDG_CONFIG_DIRS:-/etc/xdg}"
+
+ for script in Boop/Scripts/*.js
+ do
+ f="$(basename -- $script)"
+ install -Dm644 "$script" "$pkgdir/$config_dirs/boop-gtk/scripts/$f"
+ done
+}