summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRohan Rao2015-12-25 09:31:52 -0500
committerRohan Rao2015-12-25 09:31:52 -0500
commit9328e751c1cd44b4188fb4789ac513a117c17bd6 (patch)
treec3ed909feaf11b8652294c235348a277c751aee2
downloadaur-boost-build-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a06c699bcc5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Dec 25 14:31:24 UTC 2015
+pkgbase = boost-build-git
+ pkgdesc = Boost.Build makes it easy to build C++ projects, everywhere.
+ pkgver = r11135.7d80077
+ pkgrel = 1
+ url = http://www.boost.org/build/
+ arch = any
+ license = custom:boost
+ depends = boost
+ depends = gcc
+ depends = python
+ conflicts = boost-build
+ conflicts = boost-build-nightly
+ source = git+https://github.com/boostorg/build.git
+ source = http://www.boost.org/LICENSE_1_0.txt
+ md5sums = SKIP
+ md5sums = e4224ccaecb14d942c71d31bef20d78c
+
+pkgname = boost-build-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b04b6bce67ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Rohan Rao <rao dot rohan dot a at gmail dot com>
+
+pkgname=boost-build-git
+_gitname=build
+_pkgname=boost-build
+pkgver=r11135.7d80077
+pkgrel=1
+pkgdesc='Boost.Build makes it easy to build C++ projects, everywhere.'
+arch=('any')
+url="http://www.boost.org/build/"
+license=('custom:boost')
+depends=('boost' 'gcc' 'python')
+conflicts=('boost-build' 'boost-build-nightly')
+source=("git+https://github.com/boostorg/build.git"
+ "http://www.boost.org/LICENSE_1_0.txt")
+md5sums=('SKIP' 'e4224ccaecb14d942c71d31bef20d78c')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${srcdir}
+
+ mkdir -p ${pkgdir}/usr/share
+ mkdir -p ${pkgdir}/etc
+
+ cp -R ${_gitname} ${pkgdir}/usr/share
+ mv ${pkgdir}/usr/share/${_gitname} ${pkgdir}/usr/share/${_pkgname}
+ rm -Rf ${pkgdir}/usr/share/${_pkgname}/.git
+
+ install -Dm644 LICENSE_1_0.txt "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+
+ echo "using gcc ;" > ${pkgdir}/etc/site-config.jam
+}