summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-10 19:24:36 +0800
committerzxp198210052024-04-10 19:24:36 +0800
commit90abbddbe9fa17d8355e247192a48d82726e3751 (patch)
treeb1912d011c323eb87e53109e49674388c19f806a
parent14c800648d896975c86a3d42fed25a6204d6c29e (diff)
downloadaur-boost-note-bin.tar.gz
fix errors
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD58
-rw-r--r--boost-note.sh16
3 files changed, 67 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d203a126c9c..a6bbf21c9fc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,17 @@
pkgbase = boost-note-bin
- pkgdesc = Boost Note.next, a replacement for Boostnote, an open source note-taking app for programmers. Official binary for the cloud space version.
+ pkgdesc = A document driven project management tool that maximizes remote DevOps team velocity.
pkgver = 0.23.1
- pkgrel = 1
+ pkgrel = 2
url = https://boostnote.io/
arch = any
- license = GPL3
+ license = GPL-3.0-only
+ depends = electron12-bin
+ depends = nodejs
+ provides = boost-note=0.23.1
conflicts = boost-note
- source = boost-note-bin-0.23.1.deb::https://github.com/BoostIO/BoostNote.next/releases/download/v0.23.1/boost-note-linux.deb
- sha512sums = f8b215d1b8a9e6471aef2a170aa1175d15c92db2ef43ad8cb96c37065bfe0ac99916836e6d65a9936f6cf479d8daf7433aa69bd5f1a08f07ac48987aafd8d520
+ source = boost-note-0.23.1.deb::https://github.com/BoostIO/BoostNote-App/releases/download/v0.23.1/boost-note-linux.deb
+ source = boost-note.sh
+ sha256sums = 391b4711af12e7d4a6ba90e428c990a2b9335cd537188e86704221fa47db2588
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = boost-note-bin
diff --git a/PKGBUILD b/PKGBUILD
index fdd01f5f30ba..9dd4ecc8030f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,45 @@
-pkgname=boost-note-bin
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+# Contributor: espenaf <espenaf at junta dot no>
+_appname="boost note"
+pkgname="${_appname// /-}-bin"
+_pkgname="Boost Note"
pkgver=0.23.1
-pkgrel=1
-pkgdesc="Boost Note.next, a replacement for Boostnote, an open source note-taking app for programmers. Official binary for the cloud space version."
+_electronversion=12
+pkgrel=2
+pkgdesc="A document driven project management tool that maximizes remote DevOps team velocity."
arch=('any')
url="https://boostnote.io/"
-license=('GPL3')
-conflicts=('boost-note')
-
-source=("${pkgname}-${pkgver}.deb::https://github.com/BoostIO/BoostNote.next/releases/download/v${pkgver}/boost-note-linux.deb")
-sha512sums=('f8b215d1b8a9e6471aef2a170aa1175d15c92db2ef43ad8cb96c37065bfe0ac99916836e6d65a9936f6cf479d8daf7433aa69bd5f1a08f07ac48987aafd8d520')
-
-
-package(){
-
- # Extract package data
- tar -xf data.tar.xz -C "${pkgdir}" --no-same-permissions
+_ghurl="https://github.com/BoostIO/BoostNote-App"
+license=('GPL-3.0-only')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ "electron${_electronversion}-bin"
+ 'nodejs'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux.deb"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('391b4711af12e7d4a6ba90e428c990a2b9335cd537188e86704221fa47db2588'
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|app|g" \
+ -e "s|@options@||g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ bsdtar -xf "${srcdir}/data."*
+ sed "s|/opt/${_pkgname}/${_appname// /}.next|${_appname// /-}|g;s|Icon=${_appname// /}.next|Icon=${_appname// /-}|g" \
+ -i "${srcdir}/usr/share/applications/${_appname// /}.next.desktop"
}
-
-
-
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/swiftshader/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/swiftshader"
+ cp -r "${srcdir}/opt/${_pkgname}/resources/app" "${pkgdir}/usr/lib/${pkgname%-bin}"
+ for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${_appname// /}.next.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"
+ done
+ install -Dm644 "${srcdir}/usr/share/applications/${_appname// /}.next.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+} \ No newline at end of file
diff --git a/boost-note.sh b/boost-note.sh
new file mode 100644
index 000000000000..7ddcaab8d734
--- /dev/null
+++ b/boost-note.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+set -e
+_APPDIR="/usr/lib/@appname@"
+_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
+export NODE_ENV=production
+cd "${_APPDIR}"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+else
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file