summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2017-01-25 13:28:49 +0300
committerArtem Vorotnikov2017-01-25 13:30:02 +0300
commit30ba1e395cc4ea08b66a5f6e5623ee5a6f1b6982 (patch)
tree210b5a03b1f15e4c079caac54cf0bd034bc0fa8d
downloadaur-boost.expected-git.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28dfc0db4545
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Jan 25 10:29:54 UTC 2017
+pkgbase = boost.expected-git
+ pkgdesc = Utility class to represent expected monad
+ pkgver = r341.2d1babd
+ pkgrel = 1
+ url = https://github.com/ptal/expected
+ arch = i686
+ arch = x86_64
+ license = boost
+ depends = boost
+ source = git+https://github.com/ptal/expected.git
+ sha256sums = SKIP
+
+pkgname = boost.expected-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..347b287b3369
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+_username=ptal
+_reponame=expected
+pkgname=boost.expected-git
+pkgver=r341.2d1babd
+pkgrel=1
+pkgdesc="Utility class to represent expected monad"
+url="https://github.com/ptal/expected"
+license=('boost')
+depends=('boost')
+arch=('i686' 'x86_64')
+source=("git+https://github.com/$_username/$_reponame.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ _repodir="$srcdir/$_reponame"
+
+ cd "$_repodir"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ _repodir="$srcdir/$_reponame"
+
+ install -d $pkgdir/usr/include
+ cp -r $_repodir/include $pkgdir/usr
+}