summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Giordano2017-03-19 14:11:06 -0300
committerFrancisco Giordano2017-03-19 14:14:22 -0300
commitfbe9ee12a6c0e331eac7f68e1c9a070774b20c36 (patch)
treea0f3a0bea72505b6bb1ad9da42aac309f0697ff8
parent95202b1a12afbb7d509130db11daea9a26b29b29 (diff)
downloadaur-fbe9ee12a6c0e331eac7f68e1c9a070774b20c36.tar.gz
Make version number correspond to boot executable
This package only installs the boot executable found in https://github.com/boot-clj/boot-bin. The installation and updating of the boot framework itself is handled internally by this program. Because of this, the package version number corresponds to the executable.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
-rw-r--r--boot.install4
3 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d903dd82116..969f110b21bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = boot
pkgdesc = A Clojure build framework and ad-hoc Clojure script evaluator
- pkgver = 2.7.0
- pkgrel = 2
- url = https://github.com/boot-clj/boot
+ pkgver = 2.5.2
+ pkgrel = 1
+ epoch = 1
+ url = http://boot-clj.com
install = boot.install
arch = any
license = EPL
diff --git a/PKGBUILD b/PKGBUILD
index 1f79d0786597..cbf65da2734d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,23 @@
# Maintainer: Francisco Giordano <frangio.1@gmail.com>
# Contributor: Tobias Frilling <tobias@frilling-online.de>
# Contributor: Martino Visintin <vise890@gmail.com>
+
+# NOTE: This package only installs the boot executable found in
+# https://github.com/boot-clj/boot-bin. The installation and updating of the
+# boot framework itself is handled internally by this program. Because of this,
+# the package version number corresponds to the executable.
+
pkgname=boot
-pkgver=2.7.0
-pkgrel=2
+pkgver=2.5.2
+pkgrel=1
+epoch=1
pkgdesc='A Clojure build framework and ad-hoc Clojure script evaluator'
arch=('any')
-url='https://github.com/boot-clj/boot'
+url='http://boot-clj.com'
license=('EPL')
depends=('java-environment' 'bash')
install='boot.install'
-source=('https://github.com/boot-clj/boot-bin/releases/download/2.5.2/boot.sh')
+source=("https://github.com/boot-clj/boot-bin/releases/download/${pkgver}/boot.sh")
noextract=('boot.sh')
sha1sums=('d9cbefc6cbf043361a58b416e6d62fc80e5ead32')
diff --git a/boot.install b/boot.install
index d40952f7e28b..20cece443d62 100644
--- a/boot.install
+++ b/boot.install
@@ -4,9 +4,9 @@ blue="${bold}$(tput setaf 4)"
yellow="${bold}$(tput setaf 3)"
note() {
- printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
}
post_upgrade() {
- note "Run 'boot -u' to update boot.jar"
+ note "Run 'boot -u' to update boot.jar"
}