summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMirko2022-09-15 22:22:17 +0200
committerMirko2022-09-15 22:22:17 +0200
commitf35e5fe5b1c3f01fe81e7f2ace79973d8ce51c39 (patch)
tree238cdff29446b88b39c4cd4121c0c8c47b707303
parent11229851e71102aef68884f7fe11b03f1a124cfc (diff)
downloadaur-f35e5fe5b1c3f01fe81e7f2ace79973d8ce51c39.tar.gz
2022.8.28-2
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD53
2 files changed, 55 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24f432015b54..d38a0eb30d16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,38 +1,46 @@
pkgbase = bottles
pkgdesc = Easily manage wine and proton prefix
- pkgver = 2022.5.28
- pkgrel = 5
+ pkgver = 2022.8.28
+ pkgrel = 1
epoch = 1
- url = https://usebottles.com
+ url = https://github.com/bottlesdevs/Bottles
arch = x86_64
license = GPL3
makedepends = meson
makedepends = ninja
- depends = lib32-gnutls
- depends = gtksourceview4
- depends = hicolor-icon-theme
+ makedepends = blueprint-compiler
+ depends = cabextract
depends = dconf
- depends = python
+ depends = fvs
+ depends = gtk4
+ depends = gtksourceview5
+ depends = hicolor-icon-theme
+ depends = icoextract
+ depends = imagemagick
+ depends = lib32-gnutls
+ depends = libadwaita
depends = libhandy
- depends = gtk3
- depends = patool
+ depends = libportal-gtk4
depends = p7zip
+ depends = patool
+ depends = python
depends = python-gobject
+ depends = python-markdown
+ depends = python-orjson
+ depends = python-pillow
depends = python-requests
+ depends = python-steamgriddb
depends = python-yaml
- depends = python-markdown
- depends = wine
- depends = cabextract
depends = webkit2gtk
depends = xorg-xdpyinfo
- depends = icoextract
+ optdepends = gamemode
optdepends = gvfs
- optdepends = vkd3d
optdepends = lib32-vkd3d
optdepends = lib32-vulkan-icd-loader
+ optdepends = vkd3d
+ optdepends = wine
optdepends = vulkan-icd-loader
- optdepends = gamemode
- source = bottles-2022.5.28-trento-3.tar.gz::https://github.com/bottlesdevs/Bottles/archive/2022.5.14-trento-3.tar.gz
- sha256sums = 07d8a054abfe8393ae8115761ce4a709735ebb4455a2a923785c9d2ae042949f
+ source = bottles-2022.8.28-brescia-2.tar.gz::https://github.com/bottlesdevs/Bottles/archive/2022.8.28-brescia-2.tar.gz
+ sha256sums = 85d83092f1b8884650811009ca601741b801b482f2c6bf974b0ccb4c42c02b15
pkgname = bottles
diff --git a/PKGBUILD b/PKGBUILD
index 5ceecccade29..ebbf9a8f3584 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,49 @@
# Contributor: Francesco Masala <mail@francescomasala.me>
pkgname=bottles
-pkgver=2022.5.28
-pkgrel=5
+pkgver=2022.8.28
+pkgrel=1
epoch=1
pkgdesc='Easily manage wine and proton prefix'
arch=('x86_64')
url="https://github.com/bottlesdevs/Bottles"
license=('GPL3')
depends=(
+ 'cabextract'
+ 'dconf'
+ 'fvs'
+ 'gtk4'
+ 'gtksourceview5'
+ 'hicolor-icon-theme'
+ 'icoextract'
+ 'imagemagick'
'lib32-gnutls'
- 'gtksourceview4'
- 'hicolor-icon-theme'
- 'dconf'
- 'python'
- 'libhandy'
- 'gtk3'
- 'patool'
- 'p7zip'
- 'python-gobject'
- 'python-requests'
- 'python-yaml'
+ 'libadwaita'
+ 'libhandy'
+ 'libportal-gtk4'
+ 'p7zip'
+ 'patool'
+ 'python'
+ 'python-gobject'
'python-markdown'
- 'wine'
- 'cabextract'
+ 'python-orjson'
+ 'python-pillow'
+ 'python-requests'
+ 'python-steamgriddb'
+ 'python-yaml'
'webkit2gtk'
- 'xorg-xdpyinfo'
- 'icoextract')
+ 'xorg-xdpyinfo')
optdepends=(
+ 'gamemode'
'gvfs'
- 'vkd3d'
'lib32-vkd3d'
'lib32-vulkan-icd-loader'
- 'vulkan-icd-loader'
- 'gamemode')
-makedepends=('meson' 'ninja')
-source=("${pkgname}-${pkgver}-trento-3.tar.gz::https://github.com/bottlesdevs/Bottles/archive/${pkgver}-trento-3.tar.gz")
-sha256sums=('07d8a054abfe8393ae8115761ce4a709735ebb4455a2a923785c9d2ae042949f')
+ 'vkd3d'
+ 'wine'
+ 'vulkan-icd-loader')
+makedepends=('meson' 'ninja') # 'blueprint-compiler' will be needed since 2022.9.28
+source=("${pkgname}-${pkgver}-brescia-2.tar.gz::https://github.com/bottlesdevs/Bottles/archive/${pkgver}-brescia-2.tar.gz")
+sha256sums=('85d83092f1b8884650811009ca601741b801b482f2c6bf974b0ccb4c42c02b15')
build() {
if [[ -d Bottles ]]; then