summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrés Rodríguez2020-10-12 21:01:46 -0300
committerAndrés Rodríguez2020-10-12 21:01:46 -0300
commita3f5d1e5d72e54a49094e034a36c9a2695d3f414 (patch)
tree4bca29a881bd98ae944897193318e6f4960d2a91
parentb9b3d3ff5006ca8ea7080b2e23e44087dcdbe1a4 (diff)
downloadaur-a3f5d1e5d72e54a49094e034a36c9a2695d3f414.tar.gz
Improve user ns support logic and remove obsolete workaround
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--brave-bin.sh11
3 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9d0552f7b30..c6a2321078af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brave-bin
pkgdesc = Web browser that blocks ads and trackers by default (binary release).
pkgver = 1.15.72
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://brave.com/download
arch = x86_64
@@ -26,7 +26,7 @@ pkgbase = brave-bin
source = brave-browser.desktop
source = logo.png
sha512sums = 99c6366ff57759b85470b16c8270da89fa88232677fff1cd9fde512e4c21c7c45a5ccdc8c0d591c94d50777220b54bb7027803a0aa984d925b6f86188bd93efb
- sha512sums = 2e80e926bba79830cb0e6780d028edfc7a80b5fe81880224c1e2c31329353081f9970ba8755f9003b106a3247b26861f80a3e3ac8731e0bf3c5d515eecca60eb
+ sha512sums = ff99db6b5673846f4ec0daf0ec60535921166f6185131d8d966452452393580f655c421e7ad5889f5a6f6cb3f1e76e7908d711aa003ee37a1ae50774371a8b53
sha512sums = 137e14b6ff8faf19fcbfc2adcde73a3fb8f6529e9662c8eed04fc4a891073775c20b79c7149fb617465f53b980a8e46114c1c8eb704be7755da8d22a974761dd
sha512sums = d7bef52e336bd908d24bf3a084a1fc480831d27a3c80af4c31872465b6a0ce39bdf298e620ae9865526c974465807559cc75610b835e60b4358f65a8a8ff159e
diff --git a/PKGBUILD b/PKGBUILD
index 7cd45b8ac4ea..598f6bb053d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=brave-bin
pkgver=1.15.72
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Web browser that blocks ads and trackers by default (binary release)."
arch=("x86_64")
@@ -27,7 +27,7 @@ source=("$pkgname-$pkgver.zip::https://github.com/brave/brave-browser/releases/d
"logo.png")
options=(!strip)
sha512sums=("99c6366ff57759b85470b16c8270da89fa88232677fff1cd9fde512e4c21c7c45a5ccdc8c0d591c94d50777220b54bb7027803a0aa984d925b6f86188bd93efb"
- "2e80e926bba79830cb0e6780d028edfc7a80b5fe81880224c1e2c31329353081f9970ba8755f9003b106a3247b26861f80a3e3ac8731e0bf3c5d515eecca60eb"
+ "ff99db6b5673846f4ec0daf0ec60535921166f6185131d8d966452452393580f655c421e7ad5889f5a6f6cb3f1e76e7908d711aa003ee37a1ae50774371a8b53"
"137e14b6ff8faf19fcbfc2adcde73a3fb8f6529e9662c8eed04fc4a891073775c20b79c7149fb617465f53b980a8e46114c1c8eb704be7755da8d22a974761dd"
"d7bef52e336bd908d24bf3a084a1fc480831d27a3c80af4c31872465b6a0ce39bdf298e620ae9865526c974465807559cc75610b835e60b4358f65a8a8ff159e")
noextract=("$pkgname-$pkgver.zip")
diff --git a/brave-bin.sh b/brave-bin.sh
index 641135bc726d..398934ae497f 100644
--- a/brave-bin.sh
+++ b/brave-bin.sh
@@ -8,8 +8,8 @@ if [[ -f $USER_FLAGS_FILE ]]; then
USER_FLAGS="$(cat $USER_FLAGS_FILE | sed 's/#.*//')"
fi
-if [[ ! (-r /proc/sys/kernel/unprivileged_userns_clone && $(< /proc/sys/kernel/unprivileged_userns_clone) == 1 && -n $(zcat /proc/config.gz | grep CONFIG_USER_NS=y) ) ]]; then
- >&2 echo "User namespaces are not detected as enabled on your system, Brave will run with the sandbox disabled"
+if [[ -f /proc/sys/kernel/unprivileged_userns_clone && $(< /proc/sys/kernel/unprivileged_userns_clone) == 0 ]]; then
+ >&2 echo "User namespaces are detected as disabled on your system, Brave will run with the sandbox disabled"
SANDBOX_FLAG="--no-sandbox"
fi
@@ -19,9 +19,4 @@ if [[ -f $BRAVE_PEPPER_FLASH_SO && $BRAVE_USE_FLASH_IF_AVAILABLE == "true" ]]; t
PEPPER_FLASH_FLAG="--ppapi-flash-path=$BRAVE_PEPPER_FLASH_SO --ppapi-flash-version=$BRAVE_PEPPER_FLASH_VERSION"
fi
-# OR true included because Brave currently segfaults when a second
-# window is opened from running the brave binary.
-# GH Issue: https://github.com/brave/brave-browser/issues/4142
-# NOTE: Replace with an exec call once we don't have to work around
-# this bug by having the browser be a subprocess of this script
-/usr/lib/brave-bin/brave "$@" $SANDBOX_FLAG $PEPPER_FLASH_FLAG $USER_FLAGS || true
+exec /usr/lib/brave-bin/brave "$@" $SANDBOX_FLAG $PEPPER_FLASH_FLAG $USER_FLAGS