summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPavel Antonov2021-01-27 01:52:55 +0700
committerPavel Antonov2021-01-27 01:52:55 +0700
commitc79b571f74da1cde3a312a703ff96f52ddc2aad4 (patch)
tree30206df2b44a35904d7a625c937a67bfb319b961
parent261706d9c542a25d25bac45bcf853d7f9c95832d (diff)
downloadaur-breeze-patched.tar.gz
v5.20.5.5
-rw-r--r--.SRCINFO16
-rw-r--r--1.patch116
-rw-r--r--PKGBUILD22
3 files changed, 145 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56a312b25371..342d4d18b28a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = breeze-patched
pkgdesc = Artwork, styles and assets for the Breeze visual style for the Plasma Desktop
- pkgver = 5.20.5.4
+ pkgver = 5.20.5.5
pkgrel = 1
- url = https://github.com/pvantonov/breeze
+ url = https://kde.org/plasma-desktop/
arch = i686
arch = x86_64
groups = plasma
@@ -19,8 +19,16 @@ pkgbase = breeze-patched
provides = breeze
conflicts = breeze
replaces = breeze
- source = https://github.com/pvantonov/breeze/archive/v5.20.5.4.tar.gz
- md5sums = af1acfe0595ecd6637c238c2c859be7e
+ source = https://download.kde.org/stable/plasma/5.20.5/breeze-5.20.5.tar.xz
+ source = https://download.kde.org/stable/plasma/5.20.5/breeze-5.20.5.tar.xz.sig
+ source = 1.patch
+ validpgpkeys = 2D1D5B0588357787DE9EE225EC94D18F7F05997E
+ validpgpkeys = 0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D
+ validpgpkeys = D07BD8662C56CB291B316EB2F5675605C74E02CF
+ validpgpkeys = 1FA881591C26B276D7A5518EEAAF29B42A678C20
+ sha256sums = d43845a34e08d393bac182d9ede863950d33e207c7f2841a8cd419aa182cf507
+ sha256sums = SKIP
+ sha256sums = ac87674325ab48ad9be1174902a23ed8ebdb58744062f226aaec9242c387cd0c
pkgname = breeze-patched
diff --git a/1.patch b/1.patch
new file mode 100644
index 000000000000..7dc0ce34dafb
--- /dev/null
+++ b/1.patch
@@ -0,0 +1,116 @@
+From 295613dfc6bfe6c863c6bf95c6c1425bfc44ad13 Mon Sep 17 00:00:00 2001
+From: Pavel Antonov <pvantonov@gmail.com>
+Date: Wed, 27 Jan 2021 01:28:38 +0700
+Subject: [PATCH 1/2] Disable menu item's icon if item is checkable
+
+---
+ kstyle/breezestyle.cpp | 13 ++++++-------
+ 1 file changed, 6 insertions(+), 7 deletions(-)
+
+diff --git a/kstyle/breezestyle.cpp b/kstyle/breezestyle.cpp
+index 546cac1a..16fac2ab 100644
+--- a/kstyle/breezestyle.cpp
++++ b/kstyle/breezestyle.cpp
+@@ -2794,13 +2794,12 @@ namespace Breeze
+
+ int leftColumnWidth = 0;
+
+- // add icon width
+- if( iconWidth > 0 )
+- { leftColumnWidth += iconWidth + Metrics::MenuItem_ItemSpacing; }
+-
+ // add checkbox indicator width
+- if( menuItemOption->menuHasCheckableItems )
++ if( menuItemOption->checkType != QStyleOptionMenuItem::NotCheckable )
+ { leftColumnWidth += Metrics::CheckBox_Size + Metrics::MenuItem_ItemSpacing; }
++ // add icon width
++ else if( iconWidth > 0 )
++ { leftColumnWidth += iconWidth + Metrics::MenuItem_ItemSpacing; }
+
+ // add spacing for accelerator
+ /*
+@@ -4768,7 +4767,7 @@ namespace Breeze
+ // define relevant rectangles
+ // checkbox
+ QRect checkBoxRect;
+- if( menuItemOption->menuHasCheckableItems )
++ if( menuItemOption->checkType != QStyleOptionMenuItem::NotCheckable )
+ {
+ checkBoxRect = QRect( contentsRect.left(), contentsRect.top() + (contentsRect.height()-Metrics::CheckBox_Size)/2, Metrics::CheckBox_Size, Metrics::CheckBox_Size );
+ contentsRect.setLeft( checkBoxRect.right() + Metrics::MenuItem_ItemSpacing + 1 );
+@@ -4803,7 +4802,7 @@ namespace Breeze
+
+ // icon
+ int iconWidth = 0;
+- const bool showIcon( showIconsInMenuItems() );
++ const bool showIcon( showIconsInMenuItems() && menuItemOption->checkType == QStyleOptionMenuItem::NotCheckable);
+ if( showIcon ) iconWidth = isQtQuickControl( option, widget ) ? qMax( pixelMetric(PM_SmallIconSize, option, widget ), menuItemOption->maxIconWidth ) : menuItemOption->maxIconWidth;
+
+ QRect iconRect;
+--
+2.30.0
+
+
+From d540de23bfba9beee1fc5b8f725469b7f1615eda Mon Sep 17 00:00:00 2001
+From: Pavel Antonov <pvantonov@gmail.com>
+Date: Wed, 27 Jan 2021 01:44:33 +0700
+Subject: [PATCH 2/2] Disable items overlap with menu border
+
+---
+ kstyle/breezestyle.cpp | 20 +++++++++++++-------
+ 1 file changed, 13 insertions(+), 7 deletions(-)
+
+diff --git a/kstyle/breezestyle.cpp b/kstyle/breezestyle.cpp
+index 16fac2ab..e2665c19 100644
+--- a/kstyle/breezestyle.cpp
++++ b/kstyle/breezestyle.cpp
+@@ -4711,9 +4711,9 @@ namespace Breeze
+ if( StyleConfigData::menuOpacity() < 100 )
+ {
+ color = _helper->alphaColor( palette.color( QPalette::WindowText ), 0.25 ) ;
+- // don`t overlap with menu border
+- copy.adjust( 1, 0, -1, 0 );
+ }
++ // don`t overlap with menu border
++ copy.adjust( 1, 0, -1, 0 );
+
+ _helper->renderSeparator( painter, copy, color );
+ return true;
+@@ -4725,6 +4725,8 @@ namespace Breeze
+ * in that case they are rendered as menu title buttons
+ */
+ QStyleOptionToolButton copy( separatorMenuItemOption( menuItemOption, widget ) );
++ // don`t overlap with menu border
++ copy.rect.adjust( 1, 0, -1, 0 );
+ renderMenuTitle( &copy, painter, widget );
+
+ return true;
+@@ -4748,16 +4750,20 @@ namespace Breeze
+ const auto color = _helper->focusColor( palette );
+ const auto outlineColor = _helper->focusOutlineColor( palette );
+
++ QRect copy( rect );
++ // don`t overlap with menu border
++ copy.adjust( 1, 0, -1, 0 );
++
+ Sides sides = nullptr;
+ if( !menuItemOption->menuRect.isNull() )
+ {
+- if( rect.top() <= menuItemOption->menuRect.top() ) sides |= SideTop;
+- if( rect.bottom() >= menuItemOption->menuRect.bottom() ) sides |= SideBottom;
+- if( rect.left() <= menuItemOption->menuRect.left() ) sides |= SideLeft;
+- if( rect.right() >= menuItemOption->menuRect.right() ) sides |= SideRight;
++ if( copy.top() <= menuItemOption->menuRect.top() ) sides |= SideTop;
++ if( copy.bottom() >= menuItemOption->menuRect.bottom() ) sides |= SideBottom;
++ if( copy.left() <= menuItemOption->menuRect.left() ) sides |= SideLeft;
++ if( copy.right() >= menuItemOption->menuRect.right() ) sides |= SideRight;
+ }
+
+- _helper->renderFocusRect( painter, rect, color, outlineColor, sides );
++ _helper->renderFocusRect( painter, copy, color, outlineColor, sides );
+
+ }
+
+--
+2.30.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 9428388cc1c9..75ba5cc62093 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Pavel Antonov <pvantonov@gmail.com>
pkgname=breeze-patched
-pkgver=5.20.5.4
+pkgver=5.20.5.5
pkgrel=1
pkgdesc="Artwork, styles and assets for the Breeze visual style for the Plasma Desktop"
arch=(i686 x86_64)
-url="https://github.com/pvantonov/breeze"
+url="https://kde.org/plasma-desktop/"
license=('LGPL')
groups=()
depends=(breeze-icons frameworkintegration hicolor-icon-theme kdecoration kwayland)
@@ -19,12 +19,24 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/pvantonov/breeze/archive/v$pkgver.tar.gz")
+source=("https://download.kde.org/stable/plasma/5.20.5/breeze-5.20.5.tar.xz"{,.sig}
+ "1.patch")
+sha256sums=('d43845a34e08d393bac182d9ede863950d33e207c7f2841a8cd419aa182cf507'
+ 'SKIP'
+ 'ac87674325ab48ad9be1174902a23ed8ebdb58744062f226aaec9242c387cd0c')
+validpgpkeys=('2D1D5B0588357787DE9EE225EC94D18F7F05997E' # Jonathan Riddell <jr@jriddell.org>
+ '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D' # Bhushan Shah <bshah@kde.org>
+ 'D07BD8662C56CB291B316EB2F5675605C74E02CF' # David Edmundson <davidedmundson@kde.org>
+ '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
noextract=()
-md5sums=(af1acfe0595ecd6637c238c2c859be7e)
+
+prepare() {
+ cd "breeze-5.20.5"
+ patch --forward --strip=1 --input="${srcdir}/1.patch"
+}
build() {
- cmake -B build -S breeze-$pkgver \
+ cmake -B build -S breeze-5.20.5 \
-DBUILD_TESTING=OFF
cmake --build build
}