summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Vihrov2016-02-25 23:33:12 +0200
committerAndrey Vihrov2016-02-25 23:33:12 +0200
commit7506199eb3b784db4a74de8b9d4c05f0221a5ba9 (patch)
tree5e3b3ce88c7407898aa62f2368fc71b2811aa5fb
parent5a74c45918e96893248dadb3d2a2a9d83e14fdb8 (diff)
downloadaur-7506199eb3b784db4a74de8b9d4c05f0221a5ba9.tar.gz
Remove custom code in favor of the new Pacman DKMS hooks
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--broadcom-wl-dkms.install32
3 files changed, 8 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cec06996db08..897315d09b43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Feb 25 21:14:04 UTC 2016
+# Thu Feb 25 21:23:05 UTC 2016
pkgbase = broadcom-wl-dkms
pkgdesc = Broadcom 802.11 Linux STA wireless driver
pkgver = 6.30.223.271
- pkgrel = 4
+ pkgrel = 5
url = https://www.broadcom.com/support/?gid=1
install = broadcom-wl-dkms.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 79db6b6834ef..ecc3fc67ff13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=broadcom-wl-dkms
pkgver=6.30.223.271
-pkgrel=4
+pkgrel=5
pkgdesc="Broadcom 802.11 Linux STA wireless driver"
arch=('i686' 'x86_64')
url="https://www.broadcom.com/support/?gid=1"
diff --git a/broadcom-wl-dkms.install b/broadcom-wl-dkms.install
index 9c7677fa6fa8..c94de1ef0033 100644
--- a/broadcom-wl-dkms.install
+++ b/broadcom-wl-dkms.install
@@ -1,31 +1,4 @@
post_install() {
- dkms_install $1
-}
-
-pre_upgrade() {
- dkms_remove $2
-}
-
-post_upgrade() {
- dkms_install $1
-}
-
-pre_remove() {
- dkms_remove $1
-}
-
-dkms_remove() {
- # In case a different version is installed, use "dkms status broadcom-wl"
- # to list and remove installed versions.
-
- if [ -n "$(dkms status -m broadcom-wl -v ${1%%-*})" ]; then
- dkms remove -m broadcom-wl -v ${1%%-*} --all || return 1
- fi
-}
-
-dkms_install() {
- dkms install -m broadcom-wl -v ${1%%-*} || return 1
-
cat << EOF || return 1
To load the new module, run as root:
@@ -34,5 +7,10 @@ To load the new module, run as root:
modprobe wl
or just reboot the system.
+
EOF
}
+
+post_upgrade() {
+ post_install $1
+}