summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-09 16:46:15 +0200
committersmls2015-07-09 16:46:15 +0200
commit4a0ef5566e887594018d7d0dd59005d845bca756 (patch)
tree632ac2b02a03a4b9dbd85fd18f22ebf9dfe40d5e
downloadaur-brokensword-hib.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD51
-rw-r--r--brokensword-hib.desktop10
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae3aa9e752d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = brokensword-hib
+ pkgdesc = A classic point-and-click adventure game (2009 remake; Humble Bundle version)
+ pkgver = 1.0.800+h20130701
+ pkgrel = 1
+ url = http://revolution.co.uk/games/bs1dc/
+ arch = i686
+ arch = x86_64
+ license = custom: commercial
+ makedepends = imagemagick
+ depends = sdl
+ depends = libgl
+ depends = openal
+ depends = libvorbis
+ depends = xdg-utils
+ options = !upx
+ source = hib://BrokenSword1DirectorsCut_v1.0.800_Linux_1372464772.tar.gz
+ source = brokensword-hib.desktop
+ md5sums = f4867d26cda9d8b06b617abcdd8bb1b7
+ md5sums = 6af18e848dff2f265da638ec5a48ea6c
+
+pkgname = brokensword-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a92d043fe1a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+
+pkgname=brokensword-hib
+pkgver=1.0.800+h20130701
+_ver=v1.0.800
+_build=1372464772
+pkgrel=1
+pkgdesc="A classic point-and-click adventure game (2009 remake; Humble Bundle version)"
+url='http://revolution.co.uk/games/bs1dc/'
+arch=('i686' 'x86_64')
+license=('custom: commercial')
+depends=('sdl' 'libgl' 'openal' 'libvorbis' 'xdg-utils')
+makedepends=('imagemagick')
+options=("!upx")
+PKGEXT='.pkg.tar'
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+source=("hib://BrokenSword1DirectorsCut_${_ver}_Linux_${_build}.tar.gz"
+ "$pkgname.desktop")
+md5sums=('f4867d26cda9d8b06b617abcdd8bb1b7'
+ '6af18e848dff2f265da638ec5a48ea6c')
+
+package() {
+ cd $srcdir
+
+ # Install game files
+ install -d "$pkgdir/opt/"
+ mv -T bs1dc_linux_$_ver "$pkgdir/opt/BrokenSword"
+
+ # Remove unneeded libraries
+ if [ $CARCH == i686 ]; then _arch=i386; _wrong_arch=x86_64; fi
+ if [ $CARCH == x86_64 ]; then _arch=x86_64; _wrong_arch=i386; fi
+ rm "$pkgdir/opt/BrokenSword/$_arch"/{libSDL-1.2.so.0,libopenal.so.1}
+ rm -r "$pkgdir/opt/BrokenSword/$_wrong_arch"
+
+ # Install launch script
+ install -d "$pkgdir/usr/bin/"
+ ln -s "/opt/BrokenSword/BS1DC" "$pkgdir/usr/bin/brokensword"
+
+ # Install icon
+ install -d "$pkgdir/usr/share/pixmaps/"
+ convert "$pkgdir/opt/BrokenSword/icon.bmp" \
+ "$pkgdir/usr/share/pixmaps/brokensword.png"
+
+ # Install desktop entry
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ # Install license
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ mv "$pkgdir/opt/BrokenSword/legal.txt" "$pkgdir/usr/share/licenses/$pkgname/"
+}
diff --git a/brokensword-hib.desktop b/brokensword-hib.desktop
new file mode 100644
index 000000000000..8e71dbd8fbde
--- /dev/null
+++ b/brokensword-hib.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Categories=Game;
+Name=Broken Sword: The Shadow of the Templars
+Comment=Revolution Software
+GenericName=Point-and-Click Adventure
+Icon=brokensword
+Exec=/usr/bin/brokensword
+Terminal=false