summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2017-01-19 19:04:05 -0500
committerChris Severance2017-01-19 19:04:05 -0500
commit93d4eb737ca65e11cbd295ae68ef47ed71eb2c0c (patch)
treeb0769bd3e5ac375f6c716e560bffd64d41c4e9c3
downloadaur-brother-bradmin-light.tar.gz
Initial Import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..390f62f84689
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Fri Jan 20 00:03:41 UTC 2017
+pkgbase = brother-bradmin-light
+ pkgdesc = administer Brother printers
+ pkgver = 1.20.0
+ pkgrel = 1
+ url = http://support.brother.com/g/s/id/linux/en/download_esp.html
+ arch = any
+ license = custom:Brother Industries
+ depends = java-environment
+ source = http://www.brother.com/pub/bsc/linux/dlf/qdsel120brl.tar.gz
+ sha256sums = a6e09cf8b39be008d0cdf3cdd45c4e23ae1548720415671b8840a81359b09c39
+
+pkgname = brother-bradmin-light
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd4e0cc33da0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+
+set -u
+pkgname='brother-bradmin-light'
+pkgver='1.20.0'; _brfile='qdsel120brl'
+pkgrel='1'
+pkgdesc='administer Brother printers'
+arch=('any')
+url='http://support.brother.com/g/s/id/linux/en/download_esp.html'
+license=('custom:Brother Industries')
+depends=('java-environment')
+source=("http://www.brother.com/pub/bsc/linux/dlf/${_brfile}.tar.gz")
+sha256sums=('a6e09cf8b39be008d0cdf3cdd45c4e23ae1548720415671b8840a81359b09c39')
+
+package() {
+ set -u
+ cd "${_brfile}"
+ install -d "${pkgdir}/opt/brother-bradmin/"
+ mv * "${pkgdir}/opt/brother-bradmin/"
+
+ # Desktop file for config tool
+ install -Dm644 <(cat << EOF
+[Desktop Entry]
+Name=BRAdmin Light
+GenericName=Brother Printer Manager
+Comment=Administer Brother Printers
+Exec=java -jar '/opt/brother-bradmin/BRAdmin Light.jar'
+Terminal=false
+Type=Application
+#Icon=
+Categories=Settings;Utility;
+MimeType=application/x-executable
+EOF
+ ) "${pkgdir}/usr/share/applications/brother-bradmin-light.desktop"
+ set +u
+}
+set +u