summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorewolnux2016-08-22 10:35:26 +0200
committerewolnux2016-08-22 10:35:26 +0200
commita8f8499c24841501923f0ee6f917cb867b580a5c (patch)
tree2d1783846beb1db802f67b0f87c87d83dc951020
downloadaur-brother-dcp130c.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD56
-rw-r--r--brother-dcp130c.install9
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c202d9e1dec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Aug 22 08:34:25 UTC 2016
+pkgbase = brother-dcp130c
+ pkgdesc = LPR and CUPS driver for the Brother DCP130C
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/
+ install = brother-dcp130c.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother commercial license
+ depends = cups
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcp130clpr-1.0.1-1.i386.rpm
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcp130ccupswrapper-1.0.1-1.i386.rpm
+ md5sums = 752d1cd03483cc2137f92b3481693bb0
+ md5sums = fefbc571a5d75673233ce3a65ae26e68
+
+pkgname = brother-dcp130c
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8cdb3dad7b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: ewolnux <thinux@gmx.fr>
+pkgname="brother-dcp130c"
+pkgver="1.0.1"
+pkgrel=1
+pkgdesc="LPR and CUPS driver for the Brother DCP130C"
+arch=('i686' 'x86_64')
+url="http://solutions.brother.com/linux/en_us/"
+license=('custom:brother commercial license')
+depends=('cups')
+install="$pkgname.install"
+source=(
+ "http://www.brother.com/pub/bsc/linux/dlf/dcp130clpr-$pkgver-$pkgrel.i386.rpm"
+ "http://www.brother.com/pub/bsc/linux/dlf/dcp130ccupswrapper-$pkgver-$pkgrel.i386.rpm"
+)
+md5sums=(
+ '752d1cd03483cc2137f92b3481693bb0'
+ 'fefbc571a5d75673233ce3a65ae26e68'
+)
+if test "$CARCH" == x86_64; then
+ depends+=('lib32-glibc')
+fi
+prepare() {
+# do not install in '/usr/local'
+ if [ -d $srcdir/usr/local/Brother ]; then
+ install -d $srcdir/usr/share
+ mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
+ rm -rf $srcdir/usr/local
+ sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
+ fi
+# setup cups-directories
+ install -d $srcdir/usr/share/cups/model
+ install -d $srcdir/usr/lib/cups/filter
+# go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
+ cd `find . -type d -name 'cupswrapper'`
+ if [ -f cupswrapper* ]; then
+ _wrapper_source=`ls cupswrapper*`
+ sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
+ sed -i '/^sleep/d' $_wrapper_source
+ sed -i '/^lpadmin/d' $_wrapper_source
+ sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
+ sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
+ sed -i 's|/model/Brother|/model|g' $_wrapper_source
+ sed -i 's|lpinfo|echo|g' $_wrapper_source
+ export srcdir=$srcdir
+ ./$_wrapper_source
+ sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ rm $_wrapper_source
+ fi
+# /etc/printcap is managed by cups
+ rm `find $srcdir -type f -name 'setupPrintcap*'`
+}
+package() {
+ cp -R $srcdir/usr $pkgdir
+ if [ -d $srcdir/opt ]; then cp -R $srcdir/opt $pkgdir; fi
+}
diff --git a/brother-dcp130c.install b/brother-dcp130c.install
new file mode 100644
index 000000000000..3ddb04120f84
--- /dev/null
+++ b/brother-dcp130c.install
@@ -0,0 +1,9 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+echo "Restart CUPS to load the new files"
+echo "You can now register your new printer using the web interface at:"
+echo " http://localhost:631/"
+}