aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormarnout2019-01-19 16:11:20 +0100
committermarnout2019-01-19 16:11:20 +0100
commitb3df418e86d63248cd3dc8150eb2dba0cd417c89 (patch)
tree4ff42cbe7340b0096ebc05916daeb8c081209ff5
parent11a2682ce75ce5c05d0f9ee58eea111b4d56ba66 (diff)
downloadaur-brother-dcpj140w.tar.gz
rm makedep from PKGBUILD and add README
-rw-r--r--.SRCINFO3
-rw-r--r--LISEZMOI26
-rw-r--r--PKGBUILD23
-rw-r--r--README26
4 files changed, 63 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e983c24e99c..e3e267ec972a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Fri Oct 21 20:40:47 UTC 2016
pkgbase = brother-dcpj140w
pkgdesc = Driver for the Brother DCP-j140w wifi multifuncional printer
pkgver = 1.1.3
@@ -9,7 +7,6 @@ pkgbase = brother-dcpj140w
arch = i686
arch = x86_64
license = custom:brother
- makedepends = rpmextract
depends = a2ps
depends = cups
source = fix_lp.patch
diff --git a/LISEZMOI b/LISEZMOI
new file mode 100644
index 000000000000..e6c8cf2a657d
--- /dev/null
+++ b/LISEZMOI
@@ -0,0 +1,26 @@
+Le pilote fourni par Brother étant écrit en 32 bits,
+installez d’abord lib32-libstdc ++ 5 depuis aur:
+
+1. Avec git :
+ $ git clone https://aur.archlinux.org/lib32-libstdc++5.git
+ $ cd lib32-libstdc ++ 5
+ $ makepkg -si
+
+2. Avec curl :
+ $ curl -L -O https://aur.archlinux.org/cgit/aur.git/snapshot/lib32-libstdc++5.tar.gz
+ $ rm "lib32-libstdc++5.tar.gz"
+ $ cd lib32-libstdc++5
+ $ makepkg -si"
+
+3. avec wget :
+ $ wget "https://aur.archlinux.org/cgit/aur.git/snapshot/lib32-libstdc++5.tar.gz"
+ $ tar vxf "lib32-libstdc++5.tar.gz"
+ $ rm "lib32-libstdc++5.tar.gz"
+ $ cd lib32-libstdc++5
+ $ makepkg -si"
+
+REMARQUES :
+Installez le pilote brother-dcpj140w par l'une des méthodes ci-dessus.
+
+Le pilote du scanner de cette imprimante est disponible dans aur :
+https://aur.archlinux.org/packages/brscan4/
diff --git a/PKGBUILD b/PKGBUILD
index 1d0bd1f97833..6af2a99619b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Contributor: Alessio Bianchi <venator85@gmail.com>
# Contributor: Jacek Roszkowski <j.roszk@gmail.com>
# Contributor: Javier Cordero <jneight@gmail.com>
-# Contributor: Vieux Grognon <vieux@grognon.net>
-# Maintainer: Vieux Grognon <vieux@grognon.net>
+# Contributor: M. Arnout <marnout at free.fr>
+# Maintainer: M. Arnout <marnout at free.fr>
pkgname=brother-dcpj140w
pkgver=1.1.3
@@ -11,7 +11,6 @@ pkgdesc="Driver for the Brother DCP-j140w wifi multifuncional printer"
url="http://solutions.brother.com/linux/en_us/index.html"
license=('custom:brother')
depends=('a2ps' 'cups')
-makedepends=('rpmextract')
install="brother-dcpj140w.install"
arch=('i686' 'x86_64')
@@ -20,24 +19,24 @@ md5sums=('69229583e5d43d82e5655f74729c05ba'
'fa2d50677492bfc83e27184f316061c3')
source=(
- "fix_lp.patch" \
- "http://www.brother.com/pub/bsc/linux/dlf/dcpj140wlpr-$pkgver-6.i386.rpm" \
+ "fix_lp.patch" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj140wlpr-$pkgver-6.i386.rpm" \
"http://www.brother.com/pub/bsc/linux/dlf/dcpj140wcupswrapper-$pkgver-6.i386.rpm"
)
build() {
- cd "$srcdir"
- patch -Np0 < fix_lp.patch
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
}
post_install() {
- /opt/brother/Printers/dcpj140w/cupswrapper/cupswrapperdcpj140w
+ /opt/brother/Printers/dcpj140w/cupswrapper/cupswrapperdcpj140w
}
package()
{
- install -d $pkgdir/usr/bin
- install -d $pkgdir/var/spool/lpd
- install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj140w "$pkgdir"/usr/bin/
- cp -R $srcdir/opt $pkgdir/opt
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj140w "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
}
diff --git a/README b/README
new file mode 100644
index 000000000000..96d00d37050d
--- /dev/null
+++ b/README
@@ -0,0 +1,26 @@
+As the driver provided by Brother is written in 32 bits,
+first install lib32-libstdc++5 from aur :
+
+1. With git:
+ $ git clone https://aur.archlinux.org/lib32-libstdc++5.git
+ $ cd lib32-libstdc ++ 5
+ $ makepkg -si
+
+2. With curl:
+ $ curl -L -O https://aur.archlinux.org/cgit/aur.git/snapshot/lib32-libstdc++5.tar.gz
+ $ rm "lib32-libstdc ++ 5.tar.gz"
+ $ cd lib32-libstdc ++ 5
+ $ makepkg -si "
+
+3. With wget:
+ $ wget "https://aur.archlinux.org/cgit/aur.git/snapshot/lib32-libstdc++5.tar.gz"
+ $ tar vxf "lib32-libstdc ++ 5.tar.gz"
+ $ rm "lib32-libstdc ++ 5.tar.gz"
+ $ cd lib32-libstdc ++ 5
+ $ makepkg -si "
+
+NOTES:
+Install the brother-dcpj140w driver by one of the methods above.
+
+The scanner driver for this printer is available in aur:
+https://aur.archlinux.org/packages/brscan4/