summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPrem Kumar2019-05-23 00:43:18 +0530
committerPrem Kumar2019-05-23 00:43:18 +0530
commite3c1a1e1ecb96308cb026184580560f1cae72f8e (patch)
treedc9861da9e035fa5b8a5030ac8dfcdf4ceed12df
parentf3de0180845becd39dafe4df8139de35ddd6b513 (diff)
downloadaur-brother-dcpl2520d-cups-bin.tar.gz
ppd and filter files are installed to correct location
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d666242b2b6..43e8aeb3f102 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = brother-dcpl2520d-cups-bin
pkgdesc = CUPS wrapper for Brother DCP-L2520D printer
pkgver = 3.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://support.brother.com/g/b/downloadlist.aspx?c=in&lang=en&prod=dcpl2520d_as&os=128
arch = i686
arch = x86_64
groups = base-devel
license = EULA
+ depends = lib32-glibc
source = https://download.brother.com/welcome/dlf101125/brgenml1cupswrapper-3.1.0-1.i386.deb
md5sums = 9d31b628b552959419f2f6c05e16b84a
diff --git a/PKGBUILD b/PKGBUILD
index cc8c0250d1a4..4f2b765cd677 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Prem Kumar <prmsrswt@gmail.com>
pkgname=brother-dcpl2520d-cups-bin
pkgver=3.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="CUPS wrapper for Brother DCP-L2520D printer"
arch=("i686" "x86_64")
url="https://support.brother.com/g/b/downloadlist.aspx?c=in&lang=en&prod=dcpl2520d_as&os=128"
@@ -9,6 +9,20 @@ license=("EULA")
groups=("base-devel")
source=("https://download.brother.com/welcome/dlf101125/brgenml1cupswrapper-3.1.0-1.i386.deb")
md5sums=('9d31b628b552959419f2f6c05e16b84a')
+
+if test "$CARCH" == x86_64; then
+ depends+=('lib32-glibc')
+fi
+
+prepare() {
+ tar -xf data.tar.gz -C "${srcdir}"
+ sed -i -e '47,53c my $basedir = "/opt/brother/Printers/BrGenML1";' \
+ ${srcdir}/opt/brother/Printers/BrGenML1/cupswrapper/brother_lpdwrapper_BrGenML1
+}
+
package() {
- tar -xf data.tar.gz -C "${pkgdir}"
+ mkdir -p ${pkgdir}/usr/share/cups/model/Brother
+ mkdir -p ${pkgdir}/usr/lib/cups/filter
+ cp ${srcdir}/opt/brother/Printers/BrGenML1/cupswrapper/brother-BrGenML1-cups-en.ppd ${pkgdir}/usr/share/cups/model/Brother
+ cp ${srcdir}/opt/brother/Printers/BrGenML1/cupswrapper/brother_lpdwrapper_BrGenML1 ${pkgdir}/usr/lib/cups/filter
}